Current situation for Pale Moon

Pale Moon releases and site news
(read-only)
User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 31996
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Current situation for Pale Moon

Unread post by Moonchild » 2022-03-22, 13:13

Just to give everyone a situation update to hopefully take away any confusion as to versions and what not.

Pale Moon v30 has been recalled due to an incomplete release and deliberate damage done to the project. It was unacceptable to leave people in limbo on a new milestone with no additional services to speak of and known issues that couldn't be quickly addressed.

What does this mean in practice? One of three things:
  • If you have been updated to Pale Moon 30.0.1 over the weekend or last Monday, and are not experiencing any difficulties in your browsing, then you should be fine to stay on that version until 30.1.0 comes out later. Please do note there are known issues that will not be addressed soon, like (among others) emoji display and issues with streaming media (live streams). If you think you may rely on these features, it's recommended to re-install 29.4.4. Normally with a new milestone we would be able to spend time immediately after release to address feedback and bugs like this which are always expected with a major update, but obviously due to the issues at hand, we cannot dedicate any time to this right now.
  • If you are on 29.4.4, then you are fine. This is the current (latest) version of the browser for normal use. We are working on a security update to address a major issue that was fixed in v30.0.0, which will be released very soon.
  • If you are on v30.0.0 or are having issues with v30.0.1, then you are strongly encouraged to download v29.4.4 from the website and downgrade the browser to that version. It is best in that case if you also restore a backup of your profile from v29, but should not be disastrous if you don't have such a backup handy. You will be served 29.4.5 when it is released to get security up to date on this version. In this case you may also need to re-download v29 versions of any add-ons that may have been updated to a v30 one (you can recognise these by the -fxguid suffix to the version). These can be found in the temporary location on the archive server.
"You will observe with concern how long a useful truth may be known and exist before it is generally received and practiced on." -- Benjamin Franklin
"Compromise and collaboration lie at the heart of all great endeavours" -- Kassandra
Image

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 31996
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Current situation for Pale Moon

Unread post by Moonchild » 2022-04-04, 10:07

As a follow-up, and since a number of software portals are still offering the recalled v30 milestone for download, please consider going to 29.4.5.1 by downloading it from the main website and re-installing any add-ons from the add-ons site to replace incompatible -fxguid extensions that may have been installed. There should be little to no problem downgrading from 30.0.0 or 30.0.1 to 29.4.* in terms of profile compatibility this time around, although we generally recommend restoring from a backup when going back to an earlier version.
"You will observe with concern how long a useful truth may be known and exist before it is generally received and practiced on." -- Benjamin Franklin
"Compromise and collaboration lie at the heart of all great endeavours" -- Kassandra
Image

Post Reply