Upcoming 29.2.0 extension support notice

Pale Moon releases and site news
(read-only)
Post Reply
User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 30036
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Upcoming 29.2.0 extension support notice

Post by Moonchild » 2021-04-22, 11:50

As people who have followed our community's news have already been aware for some months, our extension support in Pale Moon 29.2.0 will change.
In particular, unmaintained legacy Firefox extensions (that do not target Pale Moon directly) can no longer be installed on 29.2.0 and later. Only browser extensions that target Pale Moon directly will be able to be used from this point forward.

Why is this necessary?

For those who have not seen the previous announcement and still have this question, I would like to point out the explanatory posts made before on this topic, which should provide the necessary background in some detail.
Please see the topic "About using Firefox extensions on Pale Moon"

I'm using unmaintained Firefox extensions - what do I do now?

You'll be pleased to know that Pale Moon currently has over 230 extensions listed on its add-ons site, that should cover most of the most important uses of extensions like content blockers, download managers and user interface tweaks. Of course there may not (yet) be a replacement available for what you are currently using, since there has been a rather unfortunate lack of involvement or care for the extension ecosystem with how backwards compatibility has been maintained and in some cases forced.
Please go to https://addons.palemoon.org/ to browse the quality extensions that have been created or forked by our community members and of which most are currently maintained to run on current versions of Pale Moon. There is a very good chance you will find replacements for Firefox extensions that you are currently using but that will no longer be compatible with 29.2.0.

For a rich and vibrant extension ecosystem, we do ask for your help and participation. While the current group of people who have forked unmaintained Firefox extensions into Pale Moon extensions of course deserve credit for their work, it's not possible for them to take on a much larger number (or any number, for that matter) of extensions; like original extension authors for Firefox, they are primarily volunteers and hobbyists who spent some time on creating what they want or need for their own browser use, and are people like you. Much in the same way that "everyone can cook", everyone can, with a little effort, create or fork browser extensions for Pale Moon. And since we have a self-publishing control panel on the add-ons website, it's very easy to share what you've done with other users of the browser.

What if I can't live without what I have now?

If you rely exclusively on extensions that you are currently using that have not been forked yet for Pale Moon, then you can temporarily remain on 29.1.1 -- thankfully there are currently no critical security vulnerabilities that we know of in Pale Moon that 29.2.0 will fix. It's not recommended to stay on this version long-term though, as it will become inevitably more risky.
So, you should really look into getting your critical Firefox extensions known in that case, either by doing it yourself (the best option) or e.g. by posting on the forum in this thread, so someone can look into forking it (if possible). You may also want to offer compensation if you can't do it yourself but absolutely rely on the extension for, for example, work or research.

A note on upgrading/downgrading

If you find that you can't live without the unmaintained Firefox extensions and there is no alternative yet, you may be tempted after upgrading to downgrade back to an older version of Pale Moon. Please note that that is generally not a good idea since migration of profiles to other versions is normally one-way (older to newer only) and aside from some minor version updates that you could "roll back", you should not consider going back to older versions on an existing profile. Always restore your profile from a backup that matches the version you are downgrading to. Please have a read over the information contained on our developer site regarding profile migration: http://developer.palemoon.org/docs/profile-migration/
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

Post Reply