TV2.no - Video playback fails! Topic is solved

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderator: trava90

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1435
Joined: 2015-07-23, 16:09
Location: Norway

TV2.no - Video playback fails!

Post by Tomaso » 2020-03-26, 11:19

Issue:
Video playback fails at TV2.no.

Example:
https://www.tv2.no/v/1553076/

Console:

Code: Select all

Cannot play media. No decoders for requested formats: application/dash+xml
Note:
With adblocking disabled, pre-roll ads plays, but not the videos themselves.

--

(Pale Moon v28.9.0.2,x64 / Win8.1Pro)

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6924
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: TV2.no - Video playback fails!

Post by New Tobin Paradigm » 2020-03-26, 11:31

You mean..

Code: Select all

Timestamp: 3/26/2020 7:31:23 AM
Warning: HTTP “Content-Type” of “application/dash+xml” is not supported. Load of media resource https://stream-od.akamaized.net/dashvod16/_definst_/amlst:1553076.smil/manifest.mpd failed.
Source File: https://www.tv2.no/v/1553076/
Line: 0
Image
- This program cannot be run in DOS mode. -
https://binaryoutcast.com/ | Freenode #binaryoutcast | http://thereisonlyxul.org/

User avatar
therube
Board Warrior
Board Warrior
Posts: 1206
Joined: 2018-06-08, 17:02

Re: TV2.no - Video playback fails!

Post by therube » 2020-03-26, 11:36

Every video in every browser I tried (SeaMonkey, PM, FF), failed.

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1435
Joined: 2015-07-23, 16:09
Location: Norway

Re: TV2.no - Video playback fails!

Post by Tomaso » 2020-03-26, 11:45

New Tobin Paradigm wrote:
2020-03-26, 11:31
You mean..
Yeah, that looks more descriptive, thanks.

--
therube wrote:
2020-03-26, 11:36
Every video in every browser I tried (SeaMonkey, PM, FF), failed.
They play just fine for me in Firefox and Chromium-ungoogled, but fails in Basilisk.

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2120
Joined: 2015-09-26, 04:51
Location: U.S.

Re: TV2.no - Video playback fails!

Post by coffeebreak » 2020-03-26, 12:09

It requires DRM.
Played fine in FF68 after enabling that:

tv2.no-drm.png

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1435
Joined: 2015-07-23, 16:09
Location: Norway

Re: TV2.no - Video playback fails!

Post by Tomaso » 2020-03-26, 12:12

coffeebreak wrote:
2020-03-26, 12:09
It requires DRM.
Ah, I see.
Guess it will work once Widevine has been implemented then.
Thanks for troubleshooting! :)

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 26136
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: TV2.no - Video playback fails!

Post by Moonchild » 2020-03-26, 12:16

Of course it uses Google DRM. It's a TV station.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2120
Joined: 2015-09-26, 04:51
Location: U.S.

Re: TV2.no - Video playback fails!

Post by coffeebreak » 2020-03-26, 12:28

Tomaso wrote:
2020-03-26, 11:45
but fails in Basilisk.
Tomaso wrote:
2020-03-26, 12:12
Guess it will work once Widevine has been implemented then.
The video plays fine here in Basilisk-2020.03.11 if DRM is enabled.
(Widevine 1.4.9.1088)

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1435
Joined: 2015-07-23, 16:09
Location: Norway

Re: TV2.no - Video playback fails!

Post by Tomaso » 2020-03-26, 12:55

Moonchild wrote:
2020-03-26, 12:16
Of course it uses Google DRM. It's a TV station.
It's a recent change for them, perhaps something they've enforced today.

--
coffeebreak wrote:
2020-03-26, 12:28
The video plays fine here in Basilisk-2020.03.11 if DRM is enabled.
Confirmed! :thumbup:

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 26136
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: TV2.no - Video playback fails!

Post by Moonchild » 2020-03-26, 12:57

So, not everyone has moved to Widevine v4.10 yet. That's good to know.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6924
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: TV2.no - Video playback fails!

Post by New Tobin Paradigm » 2020-03-26, 12:57

So RESOLVED INVALID for Pale Moon.

Another waste of time from that tomato.
Image
- This program cannot be run in DOS mode. -
https://binaryoutcast.com/ | Freenode #binaryoutcast | http://thereisonlyxul.org/

illiad
Fanatic
Fanatic
Posts: 196
Joined: 2016-05-15, 13:04

Re: TV2.no - Video playback fails!

Post by illiad » 2020-03-26, 17:23

so when is PM getting widevine?? :mrgreen:
VM 300Mbs in london england :lol: :coffee: on Intel Core I7 3GHz on Gigabyte X58a.
PM 28.9.0.2(64bit) on win7(64bit) sp1, modded to run on active directory domain:ugeek:
Got 24G, Nvidia GTX 1060 :D dont need 4k - not rich, not gamer, newer GPUs only for $$$ peeps
UA mostly FFF 62 :angel: :P

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 26136
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: TV2.no - Video playback fails!

Post by Moonchild » 2020-03-26, 18:07

illiad wrote:
2020-03-26, 17:23
so when is PM getting widevine?? :mrgreen:
When you stop asking stupid questions...
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6924
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: TV2.no - Video playback fails!

Post by New Tobin Paradigm » 2020-03-26, 18:53

Moonchild wrote:
2020-03-26, 18:07
illiad wrote:
2020-03-26, 17:23
so when is PM getting widevine?? :mrgreen:
When you stop asking stupid questions...
Bad call.. He might actually stop.
Image
- This program cannot be run in DOS mode. -
https://binaryoutcast.com/ | Freenode #binaryoutcast | http://thereisonlyxul.org/

User avatar
Isengrim
Board Warrior
Board Warrior
Posts: 1077
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: TV2.no - Video playback fails!

Post by Isengrim » 2020-03-27, 03:13

illiad wrote:
2020-03-26, 17:23
so when is PM getting widevine?? :mrgreen:
PM will not get Widevine because Widevine is EME, and EME is bad for the web and for users. It is a pay-to-play obstacle to smaller browser projects such as this one. This has been covered extensively in other threads.
Linux Mint 19.2 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

illiad
Fanatic
Fanatic
Posts: 196
Joined: 2016-05-15, 13:04

Re: TV2.no - Video playback fails!

Post by illiad » 2020-03-27, 16:43

Off-topic:

*** please** do sympathize with those of us, (who are **not** so deep in the tech, that they do not realise that their words sound like Kzinti to a Sol native..)
It would help if the TLAs were given some explanation :mrgreen:

is it Efficacy and Mechanism Evaluation ??

https://www.dictionary.com/browse/eme
VM 300Mbs in london england :lol: :coffee: on Intel Core I7 3GHz on Gigabyte X58a.
PM 28.9.0.2(64bit) on win7(64bit) sp1, modded to run on active directory domain:ugeek:
Got 24G, Nvidia GTX 1060 :D dont need 4k - not rich, not gamer, newer GPUs only for $$$ peeps
UA mostly FFF 62 :angel: :P

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6924
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: TV2.no - Video playback fails!

Post by New Tobin Paradigm » 2020-03-27, 16:51

You are using words but I don't understand how or why they are strung together as you have done so.
Image
- This program cannot be run in DOS mode. -
https://binaryoutcast.com/ | Freenode #binaryoutcast | http://thereisonlyxul.org/

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2120
Joined: 2015-09-26, 04:51
Location: U.S.

Re: TV2.no - Video playback fails!

Post by coffeebreak » 2020-03-27, 17:16

illiad wrote:
2020-03-27, 16:43
Off-topic:
is it Efficacy and Mechanism Evaluation ??

https://www.dictionary.com/browse/eme
@illiad,
if not for the link that ended your post, I would have had no clue at all what you were saying. Apologies, but it made little, scratch that, no sense. However, given that link...
EME, by the way, is far from an obscure term, not to mention easily found through web search.

Wikipedia: Encrypted Media Extensions (EME)

illiad
Fanatic
Fanatic
Posts: 196
Joined: 2016-05-15, 13:04

Re: TV2.no - Video playback fails!

Post by illiad » 2020-03-27, 17:45

it is actually the **twentieth** item of the search, it needs to goto next page...
not many scifi geeks here then??
VM 300Mbs in london england :lol: :coffee: on Intel Core I7 3GHz on Gigabyte X58a.
PM 28.9.0.2(64bit) on win7(64bit) sp1, modded to run on active directory domain:ugeek:
Got 24G, Nvidia GTX 1060 :D dont need 4k - not rich, not gamer, newer GPUs only for $$$ peeps
UA mostly FFF 62 :angel: :P

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2120
Joined: 2015-09-26, 04:51
Location: U.S.

Re: TV2.no - Video playback fails!

Post by coffeebreak » 2020-03-27, 17:58

illiad wrote:
2020-03-27, 17:45
it is actually the **twentieth** item of the search, it needs to goto next page...
First item on the list in my search: what is eme (browsers)

With an acronym that -might- mean multiple things, ALWAYS search with some qualifier to particularize it.

Post Reply