Youtube painfully slow loading (7+ seconds)

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
whatever64
Newbie
Newbie
Posts: 6
Joined: 2016-12-27, 00:50

Youtube painfully slow loading (7+ seconds)

Post by whatever64 » 2020-02-13, 13:49

Using latest version (28.8.2.1 x64), emptied cache and new profile. Logged-in to YouTube and go directly to subscriptions. Page takes upwards of 7 seconds to fully load, and most of that time is spent with the browser frozen up for 5 seconds. This does not happen on videos, which load instantly. Only subscriptions or home page. It is probably some script running for several seconds and locking up the entire browser while doing so. Attached screenshot showing load time.
Attachments
Untitled-1.jpg

User avatar
Pentium4User
Moon lover
Moon lover
Posts: 94
Joined: 2019-04-24, 09:38

Re: Youtube painfully slow loading (7+ seconds)

Post by Pentium4User » 2020-02-13, 13:53

It is maybe because of YouTube's new bullshitty polymer design.
The old one is now deprecated and will be shut down in some months.
Yes, I still use a Pentium 4 processor with Pale Moon. It is located at my grandfather's house and runs Lubuntu 18.04 x64. It was my main system until 2018, when I got a Pentium D system.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25679
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Youtube painfully slow loading (7+ seconds)

Post by Moonchild » 2020-02-13, 15:02

On top going there with a blank slate and going immediately to the most JS heavy part of that design will make you feel the full effect of having to compile megabytes of scripting while being bottle-necked by whatever it is they are doing in polymer that uses a lot of baseline CPU.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

whatever64
Newbie
Newbie
Posts: 6
Joined: 2016-12-27, 00:50

Re: Youtube painfully slow loading (7+ seconds)

Post by whatever64 » 2020-02-13, 15:16

Unfortunately, even on subsequent loads, it's still just as slow. I tried reloading several times.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25679
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Youtube painfully slow loading (7+ seconds)

Post by Moonchild » 2020-02-13, 17:40

Well then, start with providing us with some more information about your setup. please see the stickies in this general support board.
Knowing what hardware you're running on would also help.

By the way, having the devtools open will also slow down loading and processing a lot.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

whatever64
Newbie
Newbie
Posts: 6
Joined: 2016-12-27, 00:50

Re: Youtube painfully slow loading (7+ seconds)

Post by whatever64 » 2020-02-14, 12:56

I've got an i7-2600K w/ 16 GB RAM. Running Windows 10 x64. It's almost as slow w/o devtools. Maybe half a second faster with it closed.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25679
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Youtube painfully slow loading (7+ seconds)

Post by Moonchild » 2020-02-14, 13:05

On your CPU it certainly shouldn't be that slow, although even on my decent AMD FX-6300 YouTube's polymer design simply takes some time to load (a number of seconds), it most certainly doesn't lock up the browser.
As said please provide troubleshooting information as explained in the stickies. We can't examine much more without that.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

Sessh
Moon lover
Moon lover
Posts: 78
Joined: 2018-01-11, 18:43

Re: Youtube painfully slow loading (7+ seconds)

Post by Sessh » 2020-02-14, 16:55

I have an i7 6700 @ 3.40 GHz on Windows 7 and Youtube isn't slow for me. It is slower than the old layout, but not "slow" persay. When I first load a Youtube page (especially if it's my channel page), the browser will lock up for about 2 seconds while it's trying to load initially, then it loads fine and browsing the site doesn't cause freezes after that. Scrolling is a little choppy at times, but it doesn't take long to load videos up.

I don't know what it's doing to cause a brief browser lock-up upon initial loading of the site, but it doesn't seem to be a major issue. I would assume there's considerable bloat with the new layout. I do block quite a bit of it with uBlock/uMatrix, though.

RJARRRPCGP
Lunatic
Lunatic
Posts: 337
Joined: 2015-06-22, 19:48
Location: USA (North Springfield, Vermont)
Contact:

Re: Youtube painfully slow loading (7+ seconds)

Post by RJARRRPCGP » 2020-02-14, 16:59

Sadly, I have to report that YouTube does lock up the browser for at least almost several seconds with Pale Moon 28.8.2.1 x64 on Windows 10 Home 1909 x64 with all current updates and no Windows Update error codes or an SFC error.

On a Ryzen 3 3200G and Radeon RX 580 8 GB video card with 16 GB of DDR4 SDRAM!

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25679
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Youtube painfully slow loading (7+ seconds)

Post by Moonchild » 2020-02-14, 18:49

I'm afraid it can't be helped because polymer is simply "shite" and it'll only render smooth and fast on Blink or something very close to it. v2 might possibly be better but we need Google WebComponents for that, which we simply don't have yet.
So, have some patience, we're working on it. And have some patience when dealing with YouTube's initial load. It just isn't any different right now. Not like a few seconds of non-responsiveness (that isn't hidden from the UI unlike some browsers) is going to kill you, is it? 8-)
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

RJARRRPCGP
Lunatic
Lunatic
Posts: 337
Joined: 2015-06-22, 19:48
Location: USA (North Springfield, Vermont)
Contact:

Re: Youtube painfully slow loading (7+ seconds)

Post by RJARRRPCGP » 2020-02-14, 19:02

Moonchild wrote:
2020-02-14, 18:49
So, have some patience, we're working on it. And have some patience when dealing with YouTube's initial load. It just isn't any different right now. Not like a few seconds of non-responsiveness (that isn't hidden from the UI unlike some browsers) is going to kill you, is it? 8-)
I posted that, because Pale Moon wouldn't respond to tabs during the loading, making me feel like I'm on a 20+ year old PC or something low-end!

User avatar
ScalNeCuS
New to the forum
New to the forum
Posts: 2
Joined: 2020-02-14, 19:46

Re: Youtube painfully slow loading (7+ seconds)

Post by ScalNeCuS » 2020-02-14, 19:56

Is Alphabeth, Google, Youtube on a mission to eliminate concurrent browsers, of which they have no spying software installed?
Youtube stopped working for me today on Pale Moon. Same with Gmail. What a coincidence. I have to choose Gmail for slow connections to see my mails.
Hope I am m wrong, but knowing the evil intentions of Google, I doubt it. Basislisk still works though (under the radar?). I'm suspicious.

Kudos for making it work again.

User avatar
puppyX
Apollo supporter
Apollo supporter
Posts: 30
Joined: 2019-05-30, 11:43

Re: Youtube painfully slow loading (7+ seconds)

Post by puppyX » 2020-02-14, 20:08

Thinkpad X60 1.83 core duo, 2GB RAM, Linux Trisquel 32 bit.
Thinkpad X200 2.53 core 2 duo 4GB RAM, WIn 7pro 32 bit.

X60 =
Pale Moon, ublockorigin (on & off) - approx 20 seconds until ready to play video
Abrowser, ublockorigin (on & off) - approx 9 seconds ---------"-----------"-------------
Tor, after waiting for onion to load - a few seconds to play video

X200 =
PM = 15 s
Firefox 63.0.3 = 4s

Before the recent changes by youtube it loaded quickly in all browsers.
Of course, this is not a problem, after all, youtube works as normal in all the OS and browsers chosen. Minor time delay be damned.

User avatar
Al6bus
Fanatic
Fanatic
Posts: 249
Joined: 2015-08-24, 14:55
Location: Lemberg

Re: Youtube painfully slow loading (7+ seconds)

Post by Al6bus » 2020-02-14, 20:14

have some patience, we're working on it
probably too early you made the "override" transition to new youtube design while the old one is still working :think:
Windows 7 Pro x64 - Pale Moon x86
We hope for e10s(multiprocessing) or another alternative implementation :)

User avatar
Pentium4User
Moon lover
Moon lover
Posts: 94
Joined: 2019-04-24, 09:38

Re: Youtube painfully slow loading (7+ seconds)

Post by Pentium4User » 2020-02-14, 22:06

Al6bus wrote:
2020-02-14, 20:14
have some patience, we're working on it
probably too early you made the "override" transition to new youtube design while the old one is still working :think:
It was because of the amount of complaints written in the forum.
Yes, I still use a Pentium 4 processor with Pale Moon. It is located at my grandfather's house and runs Lubuntu 18.04 x64. It was my main system until 2018, when I got a Pentium D system.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25679
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Youtube painfully slow loading (7+ seconds)

Post by Moonchild » 2020-02-14, 22:10

RJARRRPCGP wrote:
2020-02-14, 19:02
I posted that, because Pale Moon wouldn't respond to tabs during the loading, making me feel like I'm on a 20+ year old PC or something low-end!
So you're just happy to blast us for Google's design. :thumbdown:
Al6bus wrote:
2020-02-14, 20:14
probably too early you made the "override" transition to new youtube design while the old one is still working :think:
Aside from the fact that everyone was screaming at us because of the warning thrown up.

Also, by far most people don't have severe issues with the browser "not responding", so it's not just a given. My workstation is clearly not as powerful as you people with latest gen i7s and what now, yet I don't see any hangs. Now that must have a reason too, don't y'all think?
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

Sessh
Moon lover
Moon lover
Posts: 78
Joined: 2018-01-11, 18:43

Re: Youtube painfully slow loading (7+ seconds)

Post by Sessh » 2020-02-14, 22:14

Moonchild wrote:
2020-02-14, 18:49
So, have some patience, we're working on it. And have some patience when dealing with YouTube's initial load. It just isn't any different right now. Not like a few seconds of non-responsiveness (that isn't hidden from the UI unlike some browsers) is going to kill you, is it? 8-)
For the record, I wasn't really complaining so much as supplying a data point. I figure a complete browser lock-up was noteworthy enough to mention. I know you're working on it, no biggie. :)

After a little more experimenting, the 2-second lock up only seems to happen when I load my channel page. Loading a video from an empty page doesn't cause the issue. I have my channel page bookmarked and it's usually what I use to go to Youtube. I don't notice the lock up happening at any other time. This is every time I load my channel page. Loading it from the Youtube dropdown menu in the upper-right corner doesn't cause the issue. It's only when using a bookmark to go there. I'm guessing this is because using a bookmark causes the whole thing to reload from scratch whereas using the menu to go there doesn't require a complete reloading as it's already loaded.

No errors at all in the console aside from me blocking downloadable fonts. Unblocking them changes nothing.

User avatar
ScalNeCuS
New to the forum
New to the forum
Posts: 2
Joined: 2020-02-14, 19:46

Re: Youtube painfully slow loading (7+ seconds)

Post by ScalNeCuS » 2020-02-14, 22:47

Rather, or, if not being mad as stupid. Reloading Windows10. And presto, it works again.
I hate Microsoft, I hate Bill Gates.

RJARRRPCGP
Lunatic
Lunatic
Posts: 337
Joined: 2015-06-22, 19:48
Location: USA (North Springfield, Vermont)
Contact:

Re: Youtube painfully slow loading (7+ seconds)

Post by RJARRRPCGP » 2020-02-14, 23:29

Moonchild wrote:
2020-02-14, 22:10
RJARRRPCGP wrote:
2020-02-14, 19:02
I posted that, because Pale Moon wouldn't respond to tabs during the loading, making me feel like I'm on a 20+ year old PC or something low-end!
So you're just happy to blast us for Google's design. :thumbdown:
I wasn't meaning to blast squat to anyone at Pale Moon. :| And it's not even always this slow, IIRC. It possibly got worse just some hours ago. I apologize.

User avatar
moonbat
Board Warrior
Board Warrior
Posts: 1072
Joined: 2015-12-09, 15:45
Location: Australia

Re: Youtube painfully slow loading (7+ seconds)

Post by moonbat » 2020-02-15, 03:07

ScalNeCuS wrote:
2020-02-14, 19:56
I have to choose Gmail for slow connections to see my mails.
Off-topic:
If you can, use a dedicated email client for Gmail over IMAP. The web interface is a giant memory hog.
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Linux Mint 19.3 Xfce x64 on HP i5 laptop with 4 GB RAM, always latest versions of PM & Basilisk unless specified.

Post Reply