Trouble with Invidious?

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
Post Reply
evcco
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: 2016-05-30, 15:41

Trouble with Invidious?

Post by evcco » 2020-02-08, 00:36

I just learned about Invidio.us from the "Youtube will stop supporting Pale Mon" thread.

It worked great the first day I tried it, but today I get "No compatible source was found for this media." on all videos.
Nothing changed on my end, anyone else having this issue?

(PS: I would have asked this question on the Invidious GitHub page but I can't sign up for an account there because it no longer supports my browser)

I'm running PM Version: 27.9.0 (32-bit) on Windows Vista
(can't upgrade browser or OS at the moment, so not an option)

Thanks for any help in advance...

doofy
Astronaut
Astronaut
Posts: 615
Joined: 2017-08-14, 23:43

Re: Trouble with Invidious?

Post by doofy » 2020-02-08, 00:46

I've never got Invidious to work properly, and am too lazy to research why.
Hooktube works fine, and there's a couple of others worth trying.

vannilla
Keeps coming back
Keeps coming back
Posts: 813
Joined: 2018-05-05, 13:29

Re: Trouble with Invidious?

Post by vannilla » 2020-02-08, 00:53

I always could use the site just fine.
The media error is likely because you are using Pale Moon 27.
That version simply lacks some features which are necessary for modern multimedia-heavy websites/webapplications.

User avatar
moonbat
Board Warrior
Board Warrior
Posts: 1072
Joined: 2015-12-09, 15:45
Location: Australia

Re: Trouble with Invidious?

Post by moonbat » 2020-02-08, 01:06

Why oh why don't you people ever update your browser, and remain 2 or 3 entire major versions behind, to say nothing of being open to multiple security holes that have long since been patched?
It's not like you have to do it manually either - the auto updater or the Linux repo both work without your intervention. Then you get royally flamed by Tobin and run off to complain on Reddit.
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Linux Mint 19.3 Xfce x64 on HP i5 laptop with 4 GB RAM, always latest versions of PM & Basilisk unless specified.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 4079
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: Trouble with Invidious?

Post by Night Wing » 2020-02-08, 01:15

After reading the OP's comments, I opened up a tab and went to the Invidious site. I had no problem getting there and everything works as it should.

At the time of this posting, I'm using "the newest" 64 bit linux Pale Moon 28.8.2.1 version running in 64 bit linux Mint 19.3 (Tricia) Xfce. The only addons I use are NoSquint and uBlock Origin with UBO enabled for Invidious. The site sees my user agent mode as Firefox Compatibility.

As a sidenote, update to the newest PM version in either linux or windows.
Attachments
Invidious1366.png
Linux Mint 19.3 (Tricia) Xfce 64 Bit with 64 Bit linux Pale Moon

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2067
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Trouble with Invidious?

Post by coffeebreak » 2020-02-08, 01:16

Invidio.us plays fine here with current Pale Moon.

I'm not experienced with the site, don't know its quirks, but picked a couple of videos from the front page at random
(vid1, vid2) and they played trouble-free. Can you play them?

It's my instinct as well that the old browser version is at fault - however gotta say I did try the site with PM 27.9.4 and those same two videos still played fine.

Have you tried in safe mode or failing that, tested with a new profile?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25679
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Trouble with Invidious?

Post by Moonchild » 2020-02-08, 01:21

Everyone can stop trying to check/solve the issue. it's already been determined they are on an unsupported very old version of the browser (27 milestone and not even the latest on it, at that) which will very likely not be able to handle the scripting involved.
On top, Vista is also lacking in modern media capabilities.

Solution: update the OS from Vista to -at least- 7 (people do sell digital licenses for a few bucks, price of a coffee really), and update your browser to the latest version.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

evcco
Hobby Astronomer
Hobby Astronomer
Posts: 19
Joined: 2016-05-30, 15:41

Re: Trouble with Invidious?

Post by evcco » 2020-02-08, 01:53

coffeebreak wrote:
2020-02-08, 01:16
Invidio.us plays fine here with current Pale Moon.

I'm not experienced with the site, don't know its quirks, but picked a couple of videos from the front page at random
(vid1, vid2) and they played trouble-free. Can you play them?

It's my instinct as well that the old browser version is at fault - however gotta say I did try the site with PM 27.9.4 and those same two videos still played fine.

Have you tried in safe mode or failing that, tested with a new profile?
On your video links I get "Could not extract video info. Instance is likely blocked."
If I refresh the page I then get the original error again.

Interesting that you are running PM 27.9.4 and they work - not far off from my browser version.
I suspect you're not running Windows Vista though, as I understand PM 27.9.0 is the last version compatible with Vista (at least for me, any updates beyond 27.9.0 never seemed to work that well).
Safe mode, new profile, different browser - none of them work.

The only other thing I can think of is that on one of the last videos I successfully played, I switched from WebM to MP4 in the player just to test the difference. It worked fined. The next video played back in default WebM again. Didn't think anything of that. But if that somehow contributed to the problem, because I get the "No compatible source was found for this media." error I am not offered the option to switch between WebM and MP4 any more. I don't get any options. In "Preferred video quality", on the Preferences page, I get 4 options: Dash, HD720, Medium, Small - but no choice between WebM and MP4. Tried them all anyway. Still don't work.

As for everyone talking about my out of date browser/OS (even though I said upgrading is not an option): Why (as I said in the OP) did it work just fine yesterday? It would be quite a large and unfortunate coincidence if they changed support for either/or both the very day I started using it. Possible - but as I can't find any announcements to that effect on their end I must assume there might be some other solution still out there....

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2067
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Trouble with Invidious?

Post by coffeebreak » 2020-02-08, 02:03

evcco wrote:
2020-02-08, 01:53
Interesting that you are running PM 27.9.4 and they work - not far off from my browser version.
I suspect you're not running Windows Vista though
I "run" Windows 7 with current Pale Moon. And additionally tested with a 27.9.4 portable version.

doofy
Astronaut
Astronaut
Posts: 615
Joined: 2017-08-14, 23:43

Re: Trouble with Invidious?

Post by doofy » 2020-02-08, 02:33

moonbat wrote:
2020-02-08, 01:06
Then you get royally flamed by Tobin and run off to complain on Reddit.
The PM Reddit forum used to be very quiet, inhabited by a few posters who would answer PM specific questions, and a few moz fanbois, who would do moz fanboi stuff.
Recently it is much higher traffic and my suspicion is that this is partly down to you promoting it here with posts like this one.

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6649
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: Trouble with Invidious?

Post by New Tobin Paradigm » 2020-02-08, 02:41

What does reddit have to do with the price of eggs?

doofy
Astronaut
Astronaut
Posts: 615
Joined: 2017-08-14, 23:43

Re: Trouble with Invidious?

Post by doofy » 2020-02-08, 02:46

Quite.

User avatar
moonbat
Board Warrior
Board Warrior
Posts: 1072
Joined: 2015-12-09, 15:45
Location: Australia

Re: Trouble with Invidious?

Post by moonbat » 2020-02-08, 06:37

doofy wrote:
2020-02-08, 02:33

The PM Reddit forum used to be very quiet, inhabited by a few posters who would answer PM specific questions, and a few moz fanbois, who would do moz fanboi stuff.
Recently it is much higher traffic and my suspicion is that this is partly down to you promoting it here with posts like this one.
The sub got popular during the archive server hack - tons of comments about how a server hack supposedly demonstrates that the browser is insecure. And recently there was a similar episode over changing default search engines, the poster went there to complain.
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Linux Mint 19.3 Xfce x64 on HP i5 laptop with 4 GB RAM, always latest versions of PM & Basilisk unless specified.

User avatar
Moonraker
Board Warrior
Board Warrior
Posts: 1248
Joined: 2015-09-30, 23:02
Location: uk.

Re: Trouble with Invidious?

Post by Moonraker » 2020-02-08, 09:05

invidious cpu usage was around 70% for me at times so i have returned to youtube which is more stable.
Xenial puppy linux 32-bit.
Tahrpup 6.0.5.32 bit.
Pale moon 28.8.1.

User avatar
Andrew Herbert
Apollo supporter
Apollo supporter
Posts: 49
Joined: 2019-11-25, 21:46

Re: Trouble with Invidious?

Post by Andrew Herbert » 2020-02-13, 14:07

Off-topic:
Moonraker wrote:
2020-02-08, 09:05
invidious cpu usage was around 70% for me at times so i have returned to youtube which is more stable.
Maybe you should open an issue on GitHub: https://github.com/omarroth/invidious

User avatar
4td8s
Apollo supporter
Apollo supporter
Posts: 34
Joined: 2018-08-18, 23:54

Re: Trouble with Invidious?

Post by 4td8s » 2020-02-14, 17:52

doofy wrote:
2020-02-08, 00:46
Hooktube works fine, and there's a couple of others worth trying.
a little harder to get youtube videos to work on Hooktube with eMatrix addon enabled (had to set everything on the youtube & hooktube sites to "green" in ematrix in order for it to show & play any videos)

Post Reply