cant play this video no more.....?

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
llorc
Hobby Astronomer
Hobby Astronomer
Posts: 17
Joined: 2016-06-03, 16:17

cant play this video no more.....?

Unread post by llorc » 2019-09-13, 07:17

Hello, and a good Morning!
need a little help: after updating to last pm 28.7.1
ii couldnt play videos from https://www.arte.tv/de/videos/079371-00 ... -zeit-1-6/
no more.all media source extensions are enabled, as before.
any hint?
thanks for help,

llorc

User avatar
moonbat
Lunatic
Lunatic
Posts: 380
Joined: 2015-12-09, 15:45
Location: Australia

Re: cant play this video no more.....?

Unread post by moonbat » 2019-09-13, 07:27

Server throws a 500 error, so it appears that the problem is at their end.
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Linux Mint 19.2 Xfce x64 on HP i5 laptop with 4 GB RAM, always latest versions of PM & Basilisk unless specified.

llorc
Hobby Astronomer
Hobby Astronomer
Posts: 17
Joined: 2016-06-03, 16:17

Re: cant play this video no more.....?

Unread post by llorc » 2019-09-13, 08:14

@moonbat
thx for answer!

Tried some other browsers and still the same.
So its up to them....probably.

llorc

User avatar
moonbat
Lunatic
Lunatic
Posts: 380
Joined: 2015-12-09, 15:45
Location: Australia

Re: cant play this video no more.....?

Unread post by moonbat » 2019-09-13, 08:28

When you get a 500 error on any site, it's a problem with the webserver, not your browser or anything else at your end :)
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Linux Mint 19.2 Xfce x64 on HP i5 laptop with 4 GB RAM, always latest versions of PM & Basilisk unless specified.

User avatar
Konrad
Moonbather
Moonbather
Posts: 74
Joined: 2018-11-17, 18:19

Re: cant play this video no more.....?

Unread post by Konrad » 2019-09-13, 12:08

No trouble with video playback in Pale Moon 28.5.1.
Probably, it was a temporary snag.

llorc
Hobby Astronomer
Hobby Astronomer
Posts: 17
Joined: 2016-06-03, 16:17

Re: cant play this video no more.....?

Unread post by llorc » 2019-09-13, 12:57

No,its still not working.
llorc

User avatar
gepus
Lunatic
Lunatic
Posts: 328
Joined: 2017-12-14, 12:59

Re: cant play this video no more.....?

Unread post by gepus » 2019-09-13, 14:00

moonbat wrote:
2019-09-13, 08:28
When you get a 500 error on any site, it's a problem with the webserver, not your browser or anything else at your end :)
500 error which the server sends here is a fake error. It's browser sniffing.
Changed the UA to Firefox 60 and magically no more 500 error and the video plays fine in Pale Moon.

User avatar
gepus
Lunatic
Lunatic
Posts: 328
Joined: 2017-12-14, 12:59

Re: cant play this video no more.....?

Unread post by gepus » 2019-09-13, 14:07

@ llorc

Make sure that the User Agent Mode is set to Firefox compatibility. This is the default setting and shouldn't be changed except you know what you are doing.

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1296
Joined: 2015-07-23, 16:09
Location: Norway

Re: cant play this video no more.....?

Unread post by Tomaso » 2019-09-13, 14:14

The video is geolocked.
Simply blocking geoloc.arte.tv will allow the video to play regardlessly.
AdGuard Spyware filter takes care of that part, with the following rule:

Code: Select all

||geoloc.arte.tv^
For me, the video plays just fine in Pale Moon v28.7.1, with the default UA mode (Firefox Compatibility).
Native mode triggers the 500 error.
Last edited by Tomaso on 2019-09-13, 14:15, edited 3 times in total.

coffeebreak
Board Warrior
Board Warrior
Posts: 1820
Joined: 2015-09-26, 04:51
Location: U.S.

Re: cant play this video no more.....?

Unread post by coffeebreak » 2019-09-13, 14:14

gepus wrote:
2019-09-13, 14:07
Make sure that the User Agent Mode is set to Firefox compatibility.
Seconded. FF Compat worked fine for me too.

The specific video linked in the original post was region blocked for me, as were most of the German-language videos (Dieses Video ist in Ihrem Land nicht verfügbar | This video is not available in your country) but content in the English language section played fine.


Edit: Aha! Thanks, Tomaso.
Tomaso wrote:
2019-09-13, 14:14
Simply blocking geoloc.arte.tv will allow the video to play regardlessly.
AdGuard Spyware filter takes care of that part, with the following rule:

Code: Select all

||geoloc.arte.tv^

User avatar
moonbat
Lunatic
Lunatic
Posts: 380
Joined: 2015-12-09, 15:45
Location: Australia

Re: cant play this video no more.....?

Unread post by moonbat » 2019-09-13, 14:26

The error 500 is down to blocking cookies. If you allow cookies (and use the geolocation hack mentioned, as I had to) it plays fine.
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Linux Mint 19.2 Xfce x64 on HP i5 laptop with 4 GB RAM, always latest versions of PM & Basilisk unless specified.

coffeebreak
Board Warrior
Board Warrior
Posts: 1820
Joined: 2015-09-26, 04:51
Location: U.S.

Re: cant play this video no more.....?

Unread post by coffeebreak » 2019-09-13, 15:07

moonbat wrote:
2019-09-13, 14:26
The error 500 is down to blocking cookies.
Not exclusively.
If you accept cookies and use Native mode you will get the 500 error.

At least that was my experience.

User avatar
gepus
Lunatic
Lunatic
Posts: 328
Joined: 2017-12-14, 12:59

Re: cant play this video no more.....?

Unread post by gepus » 2019-09-13, 15:48

coffeebreak wrote:
2019-09-13, 15:07
At least that was my experience.
Mine as well.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24457
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: cant play this video no more.....?

Unread post by Moonchild » 2019-09-13, 16:00

I wish people would not throw http errors arbitrarity. It's incredibly bad practice (and breaking specs, since you're throwing the wrong error) and makes troubleshooting pretty much impossible..
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
therube
Board Warrior
Board Warrior
Posts: 1078
Joined: 2018-06-08, 17:02

Re: cant play this video no more.....?

Unread post by therube » 2019-09-13, 16:09

Tomaso wrote:Simply blocking geoloc.arte.tv will allow the video to play
Worked on my end, also. USA.

Goodydino
Astronaut
Astronaut
Posts: 512
Joined: 2017-10-10, 21:20

Re: cant play this video no more.....?

Unread post by Goodydino » 2019-09-13, 18:54

There must be more to the problem than all the suggestions given. I allowed cookies, I added the block for ||geoloc.arte.tv^ to uBlock Origin, and set up a fake Firefox user agent and still got the 500 error.

User avatar
badnick
Lunatic
Lunatic
Posts: 395
Joined: 2017-03-23, 19:56

Re: cant play this video no more.....?

Unread post by badnick » 2019-09-13, 19:19

"The video is not accesible for your country"
So ,there are countryes where is not available.
Attachments
Screenshot (758).png
Windows 10 /64 (version 1809)
PM last/64

User avatar
gepus
Lunatic
Lunatic
Posts: 328
Joined: 2017-12-14, 12:59

Re: cant play this video no more.....?

Unread post by gepus » 2019-09-13, 19:30

Goodydino wrote:
2019-09-13, 18:54
There must be more to the problem than all the suggestions given.
Maybe at your end.
Made the below screenshot few minutes ago.
(No geo-blocking here since I'm connecting from DE.)
screenshot

coffeebreak
Board Warrior
Board Warrior
Posts: 1820
Joined: 2015-09-26, 04:51
Location: U.S.

Re: cant play this video no more.....?

Unread post by coffeebreak » 2019-09-13, 21:53

Goodydino wrote:
2019-09-13, 18:54
There must be more to the problem than all the suggestions given. I allowed cookies, I added the block for ||geoloc.arte.tv^ to uBlock Origin, and set up a fake Firefox user agent and still got the 500 error.
When I change the user agent globally + do those other things it works for me.
But for some reason a site specific override for arte.tv is not similarly effective. I assume this means that an override is needed for some third-party domain, but so far I haven't been able to figure out which one(s).

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1296
Joined: 2015-07-23, 16:09
Location: Norway

Re: cant play this video no more.....?

Unread post by Tomaso » 2019-09-13, 22:19

coffeebreak wrote:
2019-09-13, 21:53
I assume this means that an override is needed for some third-party domain
No, arte.tv is the one you need to target.
Try this one:

Code: Select all

Mozilla/5.0 (Windows; WOW64; x64; rv:52.0) Gecko/20100101 Firefox/52.0

Post Reply