Another problem website?

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
DogMouth
Moongazer
Moongazer
Posts: 11
Joined: 2018-02-14, 13:28

Another problem website?

Unread post by DogMouth » 2019-07-13, 04:27

I'm using 28.6.0.1 64b. The website https://www.paint.org doesn't work for me in PM. It constantly reloads the page. If I deny JS execution, it simply breaks the site completely. I tried picking through the scripts to block one that would stop it, but I end up with the same thing: constant reloading or a blank page. The behavior persists in Safe Mode and in a fresh profile. It also does this in 28.4; that's the only other version I have handy ATM.

This appears to work fine in FFX 68, Chromium, and my crusty old copy of Arora. I tried spoofing UA, but I couldn't get anything to work. I have no idea what they're doing that's making it not work in PM, so I have no idea what a fix would entail. I guess at this point I'd just like to see if anyone else can reproduce the issue. If it just boils down to "this website is hot garbage", I can accept that.

User avatar
Cassette
Fanatic
Fanatic
Posts: 203
Joined: 2015-05-08, 14:30
Location: Wichita, KS

Re: Another problem website?

Unread post by Cassette » 2019-07-13, 05:07

Running mozregression it shows last bad 02-27-2019, first good 02-28-2019. Pushlog https://hg.mozilla.org/mozilla-central/ ... 29d0fd5fd4

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23950
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Another problem website?

Unread post by Moonchild » 2019-07-13, 10:45

Most likely they are using the changed/revamped spec for document.open().
This is already being tracked on our issue tracker, unfortunately nobody has had the time or inclination to address it yet.
See Issue #1118 (UXP)
City of Heroes public server: https://www.moonshard.org/ -- Vote for it on cohservers.com

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

Goodydino
Lunatic
Lunatic
Posts: 493
Joined: 2017-10-10, 21:20

Re: Another problem website?

Unread post by Goodydino » 2019-07-13, 21:21

It flickers between the normal page and a page that shows different versions of the image at the top with both Pale Moon and SeaMonkey. With Slimjet, it loads one page and does not change. With Opera and Safari, the top image keeps changing slowly. I am guessing that the latter is its normal behaviour.

Post Reply