browser.showQuitWarning apparently not working

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
rmrichesjr
Newbie
Newbie
Posts: 3
Joined: 2019-06-14, 03:37

browser.showQuitWarning apparently not working

Unread post by rmrichesjr » 2019-06-14, 04:04

I'm preparing to switch to Pale Moon as my primary browser (from many years on Mozilla->Firefox). However, I need at least a warning in case my finger slips and I mistype Ctrl-Q when I intended Ctrl-W. I'm using Pale Moon 28.5.0 (64-bit) on Devuan Ascii amd64. Preferences -> General -> Startup is set to 'Show my home page' with a URL of "file:///home/myusername/myhomepage.html". I gather from other threads that one of the other options for that preference setting interacts with the settings to show the quit warning. In about:config, both browser.showQuitWarning and browser.warnOnQuit are set to true (the former in user set state).

Is there another method that is sufficient to either block Ctrl-Q from causing the browser to quit or to ensure that the quit warning dialog will appear and give the user a chance to cancel the quit operation?

User avatar
therube
Keeps coming back
Keeps coming back
Posts: 967
Joined: 2018-06-08, 17:02

Re: browser.showQuitWarning apparently not working

Unread post by therube » 2019-06-14, 10:27

Looks to be working on my end, with your settings.

The only time you don't get a prompt (regardless of the browser.showQuitWarning setting) is when you have, When Pale moon starts: Show my windows and tabs from last time.

That too is expected.
(That was the way that FF behaved too. But somewhere along the line, not sure if it started with Quantum or only with more recent Quantum versions, but the browser.showQuitWarning;true will now prompt in all cases.)


Did your PM come from PM or is it from your distro?
(Likewise, I wouldn't know if maybe behavior is simply different on this between Windows & Linux?)

User avatar
rmrichesjr
Newbie
Newbie
Posts: 3
Joined: 2019-06-14, 03:37

Re: browser.showQuitWarning apparently not working

Unread post by rmrichesjr » 2019-06-15, 03:53

Thanks for checking. Do I guess correctly that you're running PM on Windows? My PM came from the PM download site, tarball palemoon-28.5.0.linux-x86_64.tar.bz2

ron_1
Board Warrior
Board Warrior
Posts: 1996
Joined: 2012-06-28, 01:20

Re: browser.showQuitWarning apparently not working

Unread post by ron_1 » 2019-06-15, 05:07

I tested your two about:config settings in a new profile. I only get the Quit Warning when I have two or more tabs open. With only one tab, no warning.

I am also using Devuan ascii with the Mate DE. BTW, Pale Moon is now up to version 28.5.2.

User avatar
rmrichesjr
Newbie
Newbie
Posts: 3
Joined: 2019-06-14, 03:37

Re: browser.showQuitWarning apparently not working

Unread post by rmrichesjr » 2019-06-16, 03:42

Thanks for testing it. I also get the warning if there are multiple tabs or multiple windows open (but not if there is only a single window with a single tab). I can probably live with that.

(Two of the reasons I'm preparing to switch to Pale Moon from Firefox are 1) Armag-add-on 2.0; 2) browser crashes after watching something on YouTube. Today, Firefox crashed several times while searching for an online vendor of custom paper grocery bags.)

Post Reply