How to disable giant SVG glyphs?

General discussion and chat (archived)

Moderator: satrow

Michaell
Fanatic
Fanatic
Posts: 119
Joined: 2018-05-26, 18:13

How to disable giant SVG glyphs?

Unread post by Michaell » 2019-05-17, 22:53

I'm sure this is unsupported, so just wondering if any other users here know. On some/many sites, when you have css disabled (or it doesn't load due to busy connection), you get these giant images of things that should be small buttons. I'm not currently running an extension for blocking other elements of the page, and adding an adblocker with element hiding might be overkill for this. I found lots of instructions on adding them to a site, but nothing on blocking. I can live with it, and in fact have been for a long time. I blame poor site design, not the browser. So, just wondering if there is a setting or anything simple to either stop display of them completely or keep them at a normal size.
Win10home(1709), PM28.4port

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23975
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: How to disable giant SVG glyphs?

Unread post by Moonchild » 2019-05-19, 18:37

It's inherent to you disabling CSS. Many sites use larger versions of images/glyphs in their design so they remain sharp and unpixelated on hiDPI. The proper size in the design is determined by CSS in that case. If you disable CSS, then styling and resizing is not something you should expect.

So, bottom line: don't disable CSS if you want stuff to look proper. Don't blame the site design for this.
City of Heroes public server: https://www.moonshard.org/ -- Vote for it on cohservers.com

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

Locked