Videos on Facebook not working

The place to report Pale Moon specific bugs on the Windows operating system.

Moderator: satrow

SGvagon
Astronaut
Astronaut
Posts: 544
Joined: 2013-02-16, 13:33
Location: Czech Republic - Slavonice
Contact:

Videos on Facebook not working

Unread post by SGvagon » 2019-05-17, 13:03

Hello,

I think that from the last update (28.5.0) , videos on Facebook not working anymore. I have set not autoplay (in FB profile settings) and then, when I click to play video, it start infinite loading. Sometimes it plays 1-2 sec and then stuck in loading again.

Btw. Facebook page is almost unusable on Palemoon. There is still problem with loading images (infinite loading too) , then when I close the image loading, FB returns me to the previous page (same as Back page button) . CPU usage when scrolling is too high too, ... etc. .

Thank you in advance.

_yuyu_
Fanatic
Fanatic
Posts: 167
Joined: 2015-03-02, 14:18
Location: Moscow

Re: Videos on Facebook not working

Unread post by _yuyu_ » 2019-05-17, 20:08

Update to 28.5.0 isn't the case. In 27.4.1 FB videos also don't play. The most interesting thing here is that they don't play only when you are logged in. As soon as you log out, they play normally.
Pale Moon 32-bit on Win 7 x64

User avatar
therube
Board Warrior
Board Warrior
Posts: 1006
Joined: 2018-06-08, 17:02

Re: Videos on Facebook not working

Unread post by therube » 2019-05-17, 20:35


SGvagon
Astronaut
Astronaut
Posts: 544
Joined: 2013-02-16, 13:33
Location: Czech Republic - Slavonice
Contact:

Re: Videos on Facebook not working

Unread post by SGvagon » 2019-05-18, 09:25

therube: But Youtube videos works for me. I have issues only on Facebook.

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1402
Joined: 2012-08-19, 20:32

Re: Videos on Facebook not working

Unread post by back2themoon » 2019-05-18, 10:12

Post more details, like installed extensions etc. Also post link(s) to said FB videos. It's difficult to help with no details and zero examples.
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x86 • Emsisoft Anti-Malware

SGvagon
Astronaut
Astronaut
Posts: 544
Joined: 2013-02-16, 13:33
Location: Czech Republic - Slavonice
Contact:

Re: Videos on Facebook not working

Unread post by SGvagon » 2019-05-18, 12:23

back2themoon: Did you tried yourself first, hm? I tried clean PM profile too, same issue. And post link? This issue I have on all FB videos, so link is no necessary. I see, some videos works some didn't.
Videos which don't work have in most cases blurry thumbnail. Videos stuck in infinite loading or play 1-2 sec and then infinite loading again.

Here is a screenshot of this problem (blurry thumbnail and infinite loading)
Image

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1402
Joined: 2012-08-19, 20:32

Re: Videos on Facebook not working

Unread post by back2themoon » 2019-05-18, 13:33

SGvagon wrote:
2019-05-18, 12:23
back2themoon: Did you tried yourself first, hm? I tried clean PM profile too, same issue. And post link? This issue I have on all FB videos, so link is no necessary. I see, some videos works some didn't.
Yes, I use Facebook and videos work normally. The screenshot is useless I'm afraid. Find a public video that doesn't work and post the link. If so many videos are unplayable for you, it shouldn't be difficult.

You also failed to post the troubleshooting information, which is essential.
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x86 • Emsisoft Anti-Malware

SGvagon
Astronaut
Astronaut
Posts: 544
Joined: 2013-02-16, 13:33
Location: Czech Republic - Slavonice
Contact:

Re: Videos on Facebook not working

Unread post by SGvagon » 2019-05-18, 14:30


SGvagon
Astronaut
Astronaut
Posts: 544
Joined: 2013-02-16, 13:33
Location: Czech Republic - Slavonice
Contact:

Re: Videos on Facebook not working

Unread post by SGvagon » 2019-05-18, 14:37

Ok more progress, videos not working, when I am logged in to Facebook :crazy: . When I log out, videos works. _yuyu_ has good point.

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1402
Joined: 2012-08-19, 20:32

Re: Videos on Facebook not working

Unread post by back2themoon » 2019-05-18, 14:53

This video plays fine here, whether logged in or not. So, for the third time... post the troubleshooting info.

Also try clearing all browser cache/history/cookies etc. Try disabling hardware acceleration (Preferences/Advanced/General).
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x86 • Emsisoft Anti-Malware

jars_
Lunatic
Lunatic
Posts: 253
Joined: 2016-12-27, 00:12

Re: Videos on Facebook not working

Unread post by jars_ » 2019-05-18, 15:41

No problem with fb_videos to. whether logged in or not.
Image

SGvagon
Astronaut
Astronaut
Posts: 544
Joined: 2013-02-16, 13:33
Location: Czech Republic - Slavonice
Contact:

Re: Videos on Facebook not working

Unread post by SGvagon » 2019-05-18, 16:03

Ok here you are the troubleshoot info
Btw. I tried clean PM profile too. So it not doing on 99% any extension which I use.
Attachments
Troubleshoot_info.txt
Troubleshoot info
(12.47 KiB) Downloaded 14 times

SGvagon
Astronaut
Astronaut
Posts: 544
Joined: 2013-02-16, 13:33
Location: Czech Republic - Slavonice
Contact:

Re: Videos on Facebook not working

Unread post by SGvagon » 2019-05-18, 16:17

And here is the another image https://ctrlv.cz/shots/2019/05/18/kC7I.png . On videos page only the first Popular video works. Others blurry and not works.

User avatar
therube
Board Warrior
Board Warrior
Posts: 1006
Joined: 2018-06-08, 17:02

Re: Videos on Facebook not working

Unread post by therube » 2019-05-19, 11:16

I have set not autoplay (in FB profile settings)
And if you toggle that setting?
(I don't see where that particular video autoplays in any case.
Changing media.autoplay.enabled, in PM, didn't seem to have any effect on playback, which works on my end.
I don't "have" FB so I guess I can't change the particular FB setting you have.)
On videos page only
URL?

SGvagon
Astronaut
Astronaut
Posts: 544
Joined: 2013-02-16, 13:33
Location: Czech Republic - Slavonice
Contact:

Re: Videos on Facebook not working

Unread post by SGvagon » 2019-05-19, 11:21

therube: If I set automatic play videos I have same issue (I see only blurry thumbnails or videos plays 1-2 sec and then infinity loading again) . And URL on video page is that I posted above (if you logged in to FB you see similar page that I posted above on the long screenshot - with different videos of coarse) .

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1402
Joined: 2012-08-19, 20:32

Re: Videos on Facebook not working

Unread post by back2themoon » 2019-05-19, 13:05

Try on a new/clean profile again, but first close the browser and delete the entire cache folder (C:\Users\yourusername\AppData\Local\Moonchild Productions). Looks like you have several extensions that might cause this.
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x86 • Emsisoft Anti-Malware

User avatar
therube
Board Warrior
Board Warrior
Posts: 1006
Joined: 2018-06-08, 17:02

Re: Videos on Facebook not working

Unread post by therube » 2019-05-19, 13:07

As a test, create a new, clean Profile.
Load your FB videos...

SGvagon
Astronaut
Astronaut
Posts: 544
Joined: 2013-02-16, 13:33
Location: Czech Republic - Slavonice
Contact:

Re: Videos on Facebook not working

Unread post by SGvagon » 2019-05-19, 13:27

I tried it, Palemoon portable too. Videos still not loading :-/ . I think that this problem is on Facebook. Maybe FB testing new features and breaking some users profiles. I don't know.
The main thing is, I am not alone, who have this problem.

_yuyu_
Fanatic
Fanatic
Posts: 167
Joined: 2015-03-02, 14:18
Location: Moscow

Re: Videos on Facebook not working

Unread post by _yuyu_ » 2019-05-19, 13:43

SGvagon wrote:
2019-05-19, 13:27
The main thing is, I am not alone, who have this problem.
I confirm. I have exatly the same issue. Most of the videos work only when I am logged off. The same on fresh profile. I think it all began a couple of weeks ago or so.
Pale Moon 32-bit on Win 7 x64

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1402
Joined: 2012-08-19, 20:32

Re: Videos on Facebook not working

Unread post by back2themoon » 2019-05-19, 20:30

Also try Preferences/Content/Video/Enable Media Source Extensions (set to off and refresh page). If this works, you can install HTML5 Media Tuner which allows toggling this on a per-site basis (=enabled everywhere, except Facebook for example).
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Interlink x86 • Emsisoft Anti-Malware

Post Reply