Odd sound issue plus workaround (Fedora 22, pnp sound card)

Support and discussions for the x86/x64 Linux version of Pale Moon and specific Linux distribution questions related to the browser.

Moderator: trava90

Forum rules
If your question is about general use of the browser and not specific to Linux, then please use the General Support board.
Locked
cfalcon

Odd sound issue plus workaround (Fedora 22, pnp sound card)

Post by cfalcon » 2015-12-15, 08:11

I'm running Fedora 22, in xfce.

When I start anything with sound (youtube or theonion, some others I think), the video glitches hard, speeding through playback in a matter of seconds, the sound being all garbled.

In pavucontrol, palemoon shows up as using ALSA plug-in.



Firefox using CubebUtils and works fine. The options listed are an HDMI port (not in use), an analog stereo out (not in use) and a USB PnP sound device (this is a USB sound card- totally some commodity guy). The last one is the one I have my headphones in, and it's just that staticy mess.

The workaround is simple: I change the output in pavucontrol -> playback -> ALSA plug-in [palemoon] to either of the other two, begin playback. Then, once playback has begun, I switch it to the USB PnP Sound Device Analog Stereo, and everything is fine for the remainder of that video.

The headphones work fine in VLC and Firefox (Firefox appears as "CubebUtils", so it's presumably using a different thing that Pale Moon).

The workaround functions for just that video: subsequent videos, or reloading that one, require the procedure to be repeated.



This isn't the end of the world or anything, but it does strike me as odd. Think it's actually related to pale moon at all, or just some strange side effect? Any other sound output binaries I could run that would prove enlightening?


EDIT: 20160610

Edited to not bump thread. At some point in the last month or so, this issue went away completely after I did a dnf update on my whole system. This means something changed about Linux, or Pulseaudio, or something. Videos no longer start scratchy or skip to the end in fast-mo, and I no longer need to work around by setting pulseaudio's output to system out, then manually switching it to headphones. Additionally, I had seen this problem briefly in a couple games- the problem is also gone there. This was definitely not a Pale Moon specific issue!
Last edited by cfalcon on 2016-06-10, 18:45, edited 1 time in total.

User avatar
Moonraker
Board Warrior
Board Warrior
Posts: 1578
Joined: 2015-09-30, 23:02
Location: uk.

Re: Odd sound issue plus workaround (Fedora 22, pnp sound ca

Post by Moonraker » 2015-12-15, 11:11

This was the main reason i gave up with fedora.Constant audio issues.
This is my input as it may or may not be relevant in your case.It was quite a common issue when the last fedora was released.
Xenial puppy linux 32-bit.

Pale moon 28.15.0

half-moon

Re: Odd sound issue plus workaround (Fedora 22, pnp sound ca

Post by half-moon » 2015-12-15, 11:25

If you ask me, it's pulseaudio to blame. I installed it once recently on another distro, and sound was basically borked.

Kunagi7

Re: Odd sound issue plus workaround (Fedora 22, pnp sound ca

Post by Kunagi7 » 2015-12-16, 22:12

Pulseaudio's fault as far as I know. Even though I don't have problems with palemoon alone, if I start a VirtualBox VM audio sometimes starts glitching. The only option is restarting the pulseaudio server to get things working again.

Locked