Google Trends

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
Locked
User avatar
cartel
Lunatic
Lunatic
Posts: 408
Joined: 2014-03-16, 21:57
Location: Chilliwack, BC

Google Trends

Post by cartel » 2015-07-29, 18:18

Since noscript version 2.6.9.32, I cant get this page to work without disabling noscript....any ideas?



https://www.google.com/trends/explore#q=Donald%20Trump%2C%20Jeb%20bush%2C%20Hillary%20clinton&date=now%207-d&cmpt=q&tz=Etc%2FGMT%2B4
Image

ball keeps spinning

Can anyone else verify this?

thanks

I have the semi transparent overlay with the spinning ball.
If I disable noscript, the page loads.


NOSCRIPT DISABLED
Image


NOSCRIPT ENABLED
Image


Version 2.6.9.31 loads fine.
ImageImage

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 4025
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: Google Trends

Post by Night Wing » 2015-07-29, 19:03

I don't use NoScript. But I do use Adblock Latitude and the Google Trends site loads quickly and renders properly using ABL which is enabled (turned on).
Linux Mint 19.2 (Tina) Xfce 64 Bit (Default Distribution OS) with 64 Bit linux Pale Moon
Windows 7 Home Premium & Ultimate SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

Frasier
Fanatic
Fanatic
Posts: 227
Joined: 2014-05-07, 02:44
Location: Indiana

Re: Google Trends

Post by Frasier » 2015-07-29, 19:07

Same issue here cartel. Pale Moon 25.6 (x86) Win 7 SP1 (x64).

superA
Lunatic
Lunatic
Posts: 308
Joined: 2014-07-03, 12:34
Location: Greece

Re: Google Trends

Post by superA » 2015-07-29, 19:45

I think is related with the google.analytics.

While you allow google.analytics in noscript , maybe it is still blocked in your ABL's settings.Take a look in there and make a rule to allow google.analytics.com for this site.That's how it worked for me.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25033
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Google Trends

Post by Moonchild » 2015-07-29, 19:50

You block scripts on a site that uses scripting to perform its tasks... hmmm... let me think... what might be the cause...
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

intofix

Re: Google Trends

Post by intofix » 2015-07-29, 21:13

On my side:
Firefox with NoScript v2.6.9.33 (all scripts allowed) and Ublock Origin turned off/on, working.
Pale Moon with NoScript v2.6.9.33 (all scripts allowed) and Ublock Origin turned off/on, not working.

Edit: with Firefox it works even with Google Analytics not allowed.

User avatar
cartel
Lunatic
Lunatic
Posts: 408
Joined: 2014-03-16, 21:57
Location: Chilliwack, BC

Re: Google Trends

Post by cartel » 2015-07-29, 22:12

Moonchild wrote:You block scripts on a site that uses scripting to perform its tasks... hmmm... let me think... what might be the cause...
you mean ABL?
The site loads fine with noscript 2.6.9.31 but not with 2.6.9.32 and later.

ABL on/off makes 0 difference.
2015040.jpg


:thumbup:
Thanks for verifying with Firefox also Intofix and Frasier too.
ImageImage

intofix

Re: Google Trends

Post by intofix » 2015-07-29, 23:35

cartel wrote:Thanks for verifying with Firefox also Intofix and Frasier too.
I am interested in your post to know the result about this issue, because for me NoScript is indispensable and until now i never had problem using it with Pale Moon. If this is due to NoScript and its developer don't want to support Pale Moon, this will be a serious problem...

hackerman1
Lunatic
Lunatic
Posts: 378
Joined: 2013-12-19, 15:12
Location: Sweden

Re: Google Trends

Post by hackerman1 » 2015-07-30, 00:13

Pale Moon-64 (25.6.0), Noscript v2.6.9.33 enabled.
No problems with that page.
But if i block script on google-analytics.com the ball keeps spinning... ;)
Administrator on Windows Server to Workstation
Moderator (and "undercover" Admin) on The Windows Club Forum

Security: EAM, Comodo Firewall and HIPS, WinPatrol+, HOSTS-file, UAC (max), Sandboxie, NoScript and ADBlock.

intofix

Re: Google Trends

Post by intofix » 2015-07-30, 01:10

Just tried with NoScript v2.9.6.31 reseted, contrary to the later versions (also reseted) it works fine effectively, and on my side nothing to do with Google Analytics:

Image

The problem starts from the version 2.6.9.32rc3, maybe the latest line about googletag?

Version 2.6.9.32rc3 Publié July 25, 2015 Fonctionne avec Firefox 3.0.9 et supérieures, Mobile 1.0 - 2.0a1pre, SeaMonkey 2.0 et supérieures
=============================================================
+ Added domains required for Netflix playback to the default whitelist
x Fixed inline script blocking broken by latest Nightlies
x Fixed NOSCRIPT elements not being shown in script-blocked pages on Firefox betas
x [Surrogate] shimmed or replaced code causing deprecations
x [Surrogate] updated googletag replacement (thanks barbaz)

imacomputer

Re: Google Trends

Post by imacomputer » 2015-07-31, 01:11

idk if this is the same issue but are you having trouble loading google groups as well
here's an example:
https://groups.google.com/forum/#!forum/alt.games.sf2
if i have google-analytics blocked i just get a white page
i've run into issues with having google-analytics blocked on some other pages too

now one may say: "oh, you're blocking a script the page needs to function"
that's not true though, because in firefox with noscript, the page works fine with analytics blocked. in the old versions of pale moon until the most recent autoupdate i received it worked too.
so it's either a pale moon bug or a noscript bug.

apparently there's a thread over here too:
https://forums.informaction.com/viewtop ... 10&t=21084

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25033
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Google Trends

Post by Moonchild » 2015-07-31, 10:38

Sounds like the same NoScript issue that's known from other threads.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
cartel
Lunatic
Lunatic
Posts: 408
Joined: 2014-03-16, 21:57
Location: Chilliwack, BC

Re: Google Trends

Post by cartel » 2015-08-07, 08:15

#OK, the surrogate system is not completely dead... there's something else weird going on with the specific surrogate I was testing against (the OWASP anti-clickjacking surrogate is not working on the Adobe site in PaleMoon, but that's a different story).
What's NOT fine is that on PaleMoon, the $S() function is returning 0 and not an object.

As such I would expect that some surrogates do still work... but I'm seeing a second bug: surrogates whose sources have no prefix don't ever run if the scripts they're replacing are 1st-party (e.g. trying to replace a palemoon.org JS file while on palemoon.org).
I don't have time to track down exactly what surrogate functionality works and what doesn't atm, but it seems it's far less clear cut that I had originally thought.

Testing with NoScript 2.6.9.34rc2 in a clean profile in PaleMoon 25.6 (because my main profile has a bunch of add-ons I haven't yet fixed to work in PaleMoon 25.x and I want to not have malfunctioning other extensions in my testing).
(What a pleasant UX to use a browser with a friendly, easy-to-navigate UI and a nice set of builtin dev-tools; even better is that it's "modern".)
https://forums.informaction.com/viewtop ... 4&start=15


Ok I'm over my head..maybe this info can be better understood by you guys.
Seems they like the browser though! :thumbup:
ImageImage

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25033
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Google Trends

Post by Moonchild » 2015-08-08, 22:20

cartel wrote:What's NOT fine is that on PaleMoon, the $S() function is returning 0 and not an object.
If someone could relay here what is missing/expected/different in Pale Moon that their functionality relies on, then I can look at a browser-side solution for this issue as well. I'd need more info though, about the nature of the function, what it relies on, what function specifically returns a value instead of an object (and if this is not according to spec or if the spec has changed since our implementation), etc. I think only the NoScript people can answer this question ;)
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
cartel
Lunatic
Lunatic
Posts: 408
Joined: 2014-03-16, 21:57
Location: Chilliwack, BC

Re: Google Trends

Post by cartel » 2015-08-12, 11:39

This issue seems to be fixed with Noscript 2.6.9.35 :thumbup:
ImageImage

Locked