ηMatrix/eMatrix support thread

General discussion, compatibility and contributed extensions.

Moderators: Lootyhoof, FranklinDM

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2476
Joined: 2015-09-26, 04:51
Location: U.S.

Re: ηMatrix/eMatrix support thread

Post by coffeebreak » 2020-09-08, 15:24

Attronarch wrote:
2020-09-08, 08:43
I've created a local file, linked to it, and it worked.
To be clear...
That local file you added was added (subscribed) solely to eMatrix, and its contents are stored in your browser profile, in \ematrix-data\ematrix.sqlite

User avatar
nicolaasjan
Apollo supporter
Apollo supporter
Posts: 46
Joined: 2017-07-28, 14:44
Location: The Netherlands

Re: ηMatrix/eMatrix support thread

Post by nicolaasjan » 2020-09-18, 19:15

Just FYI,

uMatrix repo is now archived.
This repository has been archived by the owner. It is now read-only.
Anyway, as it is, I've archived uMatrix's repo, I can't and won't be spending any more time on this project, and neither on all such issues.
Whoever is free to fork under a new name -- I may re-open and resume development in some future if ever I feel for it.
(from here)
Linux Mint 19.3 Mate 64bit
Pale Moon latest

vannilla
Board Warrior
Board Warrior
Posts: 1186
Joined: 2018-05-05, 13:29

Re: ηMatrix/eMatrix support thread

Post by vannilla » 2020-09-18, 20:09

Doesn't really affect ηMatrix and hasn't been for a long time.

User avatar
moonbat
Moon Magic practitioner
Moon Magic practitioner
Posts: 2270
Joined: 2015-12-09, 15:45

Re: ηMatrix/eMatrix support thread

Post by moonbat » 2020-09-19, 10:58

Is it because Noscript is better known for the same purpose and continues to be available for Firefox?
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Image
Linux Mint 20 Xfce x64 on HP i5-5200 laptop, 12 GB RAM.
Advanced URL Builder(fork)|PermissionsPlus|PMPlayer|Pure URL|RecordRewind|TextFX

vannilla
Board Warrior
Board Warrior
Posts: 1186
Joined: 2018-05-05, 13:29

Re: ηMatrix/eMatrix support thread

Post by vannilla » 2020-09-20, 16:43

I was running a few experiments and noticed that the setting used to spoof the referer can't be disabled.
If I tick it off and refresh the dashboard, the checkbox is ticked instead of being empty. The other settings seem to honor the on/off as expected.
Is anyone else experiencing this? It might be an actual bug.

coffeebreak
Moon Magic practitioner
Moon Magic practitioner
Posts: 2476
Joined: 2015-09-26, 04:51
Location: U.S.

Re: ηMatrix/eMatrix support thread

Post by coffeebreak » 2020-09-20, 17:59

vannilla wrote:
2020-09-20, 16:43
the setting used to spoof the referer can't be disabled.
Yes, confirmed.
With v4.3.2 and earlier this issue is not present.

After unticking the setting, the My rules tab shows the corresponding rule as struck through:
referrer-spoof: * true
where it can be removed manually by clicking "Commit".


Edit: fixed goof.
Last edited by coffeebreak on 2020-09-20, 21:52, edited 1 time in total.

vannilla
Board Warrior
Board Warrior
Posts: 1186
Joined: 2018-05-05, 13:29

Re: ηMatrix/eMatrix support thread

Post by vannilla » 2020-09-20, 18:40

Thanks, I've identified the bug and pushed an update.

Post Reply