can't login to Microsoft Teams

Support and discussions for the x86/x64 Linux version of Pale Moon and specific Linux distribution questions related to the browser.

Moderator: trava90

Forum rules
If your question is about general use of the browser and not specific to Linux, then please use the General Support board.
Post Reply
raphael75
Moongazer
Moongazer
Posts: 10
Joined: 2018-05-07, 00:04

can't login to Microsoft Teams

Post by raphael75 » 2020-02-05, 13:20

I have Palemoon Linux 28.8.0 64-bit on KDE Plasma with Debian 10.

I am able to login to office.com and access Word, Outlook, Excel, and most of the other items with no issues. When I try to login to Teams it hangs on the "hang" (screenshot) screen for at least 1 minute, then I get the error (screenshot) page. Clicking "Try Again" goes back to the hang screen and then I get the error screen again.

Teams used to work in Palemoon until about 2 months ago. I am able to access Teams in Chrome and FF.

I have tried restarting in Safe Mode and using a private window, and get the same results as above.

Is there any way I can login with Palemoon?
Attachments
hang.png
error.png

User avatar
Pentium4User
Lunatic
Lunatic
Posts: 464
Joined: 2019-04-24, 09:38

Re: can't login to Microsoft Teams

Post by Pentium4User » 2020-02-05, 13:29

You're using an outdated version of Pale Moon, update now.
Then check the user agent you are using for MS Teams.
It doesn't work for me either but this can be also caused by settings/addons.
Powerline adapters (dLAN) hardly interfere shortwave radio, so stop using them.

Yes, I still use a 64 bit capable Pentium 4 670 processor with Pale Moon.

raphael75
Moongazer
Moongazer
Posts: 10
Joined: 2018-05-07, 00:04

Re: can't login to Microsoft Teams

Post by raphael75 » 2020-02-05, 14:02

You're using an outdated version of Pale Moon, update now.
Then check the user agent you are using for MS Teams.
It doesn't work for me either but this can be also caused by settings/addons.
Good catch. I updated Palemoon to 28.8.2.1. I downloaded User Agent Switcher from the classic addons archive, and changed my user agent to
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.130 Safari/537.36
However, I still am unable to login. I get the same behavior as before.

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 8073
Joined: 2012-10-09, 19:37
Location: I'm.. over there.

Re: can't login to Microsoft Teams

Post by New Tobin Paradigm » 2020-02-05, 14:09

Code: Select all

Timestamp: 2/5/2020 9:08:37 AM
Warning: Content Security Policy: Directive ‘child-src’ has been deprecated. Please use directive ‘worker-src’ to control workers, or directive ‘frame-src’ to control frames respectively.

Timestamp: 2/5/2020 9:08:37 AM
Warning: Content Security Policy: Couldn’t process unknown directive ‘prefetch-src’

Timestamp: 2/5/2020 9:08:37 AM
Warning: Content Security Policy: Couldn’t parse invalid host 'report-sample'

Timestamp: 2/5/2020 9:08:37 AM
Warning: Content Security Policy: Ignoring “'unsafe-inline'” within script-src or style-src: nonce-source or hash-source specified

Offline cache update error, URL=https://teams.microsoft.com/skypespaces.web.appcache?tenantId=b13d5dc7-bcad-4f1e-9e73-31cfa9e5dd6f

Timestamp: 2/5/2020 9:08:41 AM
Error: Content Security Policy: The page’s settings blocked the loading of a resource at https://teams.microsoft.com/skypespaces.web.appcache?tenantId=b13d5dc7-bcad-4f1e-9e73-31cfa9e5dd6f (“default-src 'none'”).
It really seems they are expecting very specific features and behavior likely of a Chromium browser. You REALLY can't trust a browser maker's other products and services not to work outside of their browser. ESPECIALLY Microsoft be it Internet Explorer, Old Edge, or Chrome Edge. This, of course, was taken to heart by Google some time ago.

I know I don't give two shits about anything but a UXP Browser. Though, there is a good chance that if it works with Goanna it will work everywhere else. This is only true for THEM because EVERY OTHER FUCKING BROWSER ON THIS PLANET IS EITHER CHROME OR EMULATING CHROME. Including Microsoft's newest browser. I mean, they kinda tell you as much when they suggest using some "app" instead.
Your computer has too much computer in it and not enough typewriter.
Image

raphael75
Moongazer
Moongazer
Posts: 10
Joined: 2018-05-07, 00:04

Re: can't login to Microsoft Teams

Post by raphael75 » 2020-03-27, 18:48

New Tobin Paradigm wrote:
2020-02-05, 14:09
It really seems they are expecting very specific features and behavior likely of a Chromium browser. You REALLY can't trust a browser maker's other products and services not to work outside of their browser. ESPECIALLY Microsoft be it Internet Explorer, Old Edge, or Chrome Edge. This, of course, was taken to heart by Google some time ago.

I know I don't give two shits about anything but a UXP Browser. Though, there is a good chance that if it works with Goanna it will work everywhere else. This is only true for THEM because EVERY OTHER FUCKING BROWSER ON THIS PLANET IS EITHER CHROME OR EMULATING CHROME. Including Microsoft's newest browser. I mean, they kinda tell you as much when they suggest using some "app" instead.
I completely agree with you, I would never use Teams if I wasn't forced to for work. Unfortunately, my company requires it.

I've tried using User Agent Switcher to make it think I was using Firefox or Chrome, but it still won't load.

raphael75
Moongazer
Moongazer
Posts: 10
Joined: 2018-05-07, 00:04

Re: can't login to Microsoft Teams

Post by raphael75 » 2020-03-27, 18:53

Pentium4User wrote:
2020-02-05, 13:29
You're using an outdated version of Pale Moon, update now.
Then check the user agent you are using for MS Teams.
It doesn't work for me either but this can be also caused by settings/addons.
I am now on 28.9.0.2 (64-bit). I restarted in safe mode and still can't login to Teams. I can login to Outlook, so it's just some crap they put on the Teams site that doesn't like Pale Moon.

Post Reply