Turn off executables warning?

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderator: trava90

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
Post Reply
User avatar
Patron
Newbie
Newbie
Posts: 5
Joined: 2018-10-27, 21:59

Turn off executables warning?

Post by Patron » 2019-09-13, 13:37

Updated to 28.7.1 late yesterday on Win10. Get to work this morning, go to open my jnlp apps, get a pop-up window that says - “[application].jnlp” is an executable file. Executable files may contain viruses or other malicious code that could harm your computer. Use caution when opening this file. Are you sure you want to launch “[application].jnlp”?

Yes, of course I want to run it. Yes, I understand the security implications and why the pop-up exists. However, the way I use PM this is not necessary for me. How do I turn it off? I did search the forum, and through the config. Thank you.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 26208
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Turn off executables warning?

Post by Moonchild » 2019-09-13, 14:03

That shouldn't happen in 28.7.1 -- the change to mark them as executable introduced in 28.5.* was reverted in 28.6.0 so they are not considered executables. Are you sure you're running 28.7.1?
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

User avatar
Patron
Newbie
Newbie
Posts: 5
Joined: 2018-10-27, 21:59

Re: Turn off executables warning?

Post by Patron » 2019-09-13, 14:27

Thank you for the reply. Yes, I'm sure it's 28.7.1. I updated from 28.3.1.

Is it possible some other override I've set is tripping the pop-up? I have overrode a few other security setting over the years. The profile I'm using goes back probably three years.

Something from the updates.xml file that might help:

Code: Select all

<update appVersion="28.7.1" buildID="20190909125145" channel="release" displayVersion="28.7.1" installDate="1568315115172" isCompleteUpdate="false" isOSUpdate="false" name="Pale Moon 28.7.1" serviceURL="https://aus.palemoon.org/?application=Pale Moon&version=28.3.1&arch=WINNT_x86_64-msvc-x64&buildid=20190123120221&channel=release&force=1" showNeverForVersion="false" showPrompt="false" promptWaitTime="86400" backgroundInterval="600" type="major" detailsURL="http://www.palemoon.org/releasenotes.shtml" previousAppVersion="28.3.1" statusText="The Update was successfully installed" extensionVersion="28.7.1" foregroundDownload="true">
<patch type="complete" URL="http://aus.palemoon.org/release/palemoon-28.7.1.win64.complete.mar" finalURL="http://aus.palemoon.org/release/palemoon-28.7.1.win64.complete.mar" hashFunction="SHA256" hashValue="cb792dae2301e130746811017b0bee936e43c81be32e9aff10c658a674339749" size="50201643" selected="true" state="succeeded"/>
I'm happy to provide whatever other troubleshooting I can to help.
pm28.jpg

User avatar
therube
Board Warrior
Board Warrior
Posts: 1206
Joined: 2018-06-08, 17:02

Re: Turn off executables warning?

Post by therube » 2019-09-13, 15:48

As a test, create a new, clean Profile.
See if you get the prompt there.

If not, you can pretty much assume it is something in your original Profile.
Then just have to figure out what ;-).

(About the only "java" I see on my end [I don't have Java] is, plugin.java.mime.)

User avatar
Patron
Newbie
Newbie
Posts: 5
Joined: 2018-10-27, 21:59

Re: Turn off executables warning?

Post by Patron » 2019-09-25, 21:56

Creating a new profile did not help. After enabling the handler for JNLP, I still get the same warning.

User avatar
Patron
Newbie
Newbie
Posts: 5
Joined: 2018-10-27, 21:59

Re: Turn off executables warning?

Post by Patron » 2019-10-02, 13:09

Any other options?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 26208
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Turn off executables warning?

Post by Moonchild » 2019-10-02, 14:27

Patron wrote:
2019-10-02, 13:09
Any other options?
I'm afraid not. The browser itself shouldn't provide an executable warning for jnlp... As said that was temporarily the case but the change was reverted; it'll teat it the same as any document. Java, however, will still provide a warning if set to do so.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

Post Reply