HTML5 Buttons not responding

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderator: trava90

Locked
User avatar
d-[a_a]-b
Newbie
Newbie
Posts: 4
Joined: 2019-07-20, 18:24

HTML5 Buttons not responding

Post by d-[a_a]-b » 2019-07-20, 18:28

I'm not sure if anyone else is having this issue or just me. On some websites recently, HTML5 buttons have done nothing beyond highlight-on-hover.
I suspect the problem is on my end. I had Noscript enabled for awhile, but even when I enable all scripts, the button still does nothing. And yes, Javascript works on other pages.

Anyone else run into this snag and know how to fix it?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 26142
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: HTML5 Buttons not responding

Post by Moonchild » 2019-07-20, 19:34

One of the many issues one can run into with NoScript.

The only solution is to completely uninstall NoScript.
There are alternative extensions available that are fully compatible with Pale Moon, that also allow you to block script content.
"There will be times when the position you advocate, no matter how well framed and supported, will not be accepted by the public simply because you are who you are." -- Merrill Rose
Image

User avatar
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2174
Joined: 2012-06-28, 01:20

Re: HTML5 Buttons not responding

Post by ron_1 » 2019-07-20, 19:39

As Moonchild said, just having NoScript installed can cause problems (even if you enabled all scripts). I know from first hand experience. Try those buttons in a brand new clean profile.

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6927
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: HTML5 Buttons not responding

Post by New Tobin Paradigm » 2019-07-20, 19:42

Well since you use noscript.. No one is WILL help you unless you ALSO try in an uncorrupted clean profile. Beyond that, no one is going to be ABLE to help unless you provide some specific examples.

Satisfy those conditions, please.
Image
- This program cannot be run in DOS mode. -
https://binaryoutcast.com/ | Freenode #binaryoutcast | http://thereisonlyxul.org/

User avatar
d-[a_a]-b
Newbie
Newbie
Posts: 4
Joined: 2019-07-20, 18:24

Re: HTML5 Buttons not responding

Post by d-[a_a]-b » 2019-07-25, 03:23

Hm... Darn.
I realize Palemoon is a long ways from Firefox, although Noscript does work in FF. Why not in Palemoon? *musing*
Anyways... Is there an alternative to Noscript that *doesn't* have this issue?

User avatar
Isengrim
Board Warrior
Board Warrior
Posts: 1077
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: HTML5 Buttons not responding

Post by Isengrim » 2019-07-25, 10:28

Off-topic:
d-[a_a]-b wrote:
2019-07-25, 03:23
I realize Palemoon is a long ways from Firefox, although Noscript does work in FF. Why not in Palemoon? *musing*
a) I noticed issues with NoScript even when I used to use it with Firefox - things would break even after enabling everything.
b) NoScript for Firefox is currently a Web Extension, and likely works differently than the XUL version.
d-[a_a]-b wrote:
2019-07-25, 03:23
Anyways... Is there an alternative to Noscript that *doesn't* have this issue?
I recommend eMatrix instead.
Linux Mint 19.2 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

User avatar
d-[a_a]-b
Newbie
Newbie
Posts: 4
Joined: 2019-07-20, 18:24

Re: HTML5 Buttons not responding

Post by d-[a_a]-b » 2019-07-25, 15:09

Thanks! I'll check it out.

UPDATE: ematrix didn't do anything at all, but maybe I have too old of a version? (26.4.0.1) The version history says it should work with 26.0, but who knows. In any case, enabling javascript altogether makes tons of sites crash for me (because those sites use too much JS, it appears), hence the minimal JS.

Thanks anyways!

User avatar
therube
Board Warrior
Board Warrior
Posts: 1206
Joined: 2018-06-08, 17:02

Re: HTML5 Buttons not responding

Post by therube » 2019-07-25, 16:49

On some websites recently, HTML5 buttons have done nothing beyond highlight-on-hover.
URLs where this occurs?

vannilla
Keeps coming back
Keeps coming back
Posts: 888
Joined: 2018-05-05, 13:29

Re: HTML5 Buttons not responding

Post by vannilla » 2019-07-25, 19:52

d-[a_a]-b wrote:
2019-07-25, 15:09
(26.4.0.1)
I think the problems you are facing are caused by this.
If you can't get v28 at least go with 27.

And I should probably increase the minor supported version to 28 when I release eMatrix 4.

Locked