All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
schnuck
Moongazer
Moongazer
Posts: 10
Joined: 2019-05-16, 13:49

All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by schnuck » 2019-05-16, 14:36

Hello everybody,

it seems something must have changed after the version 27.8.1.
This version is the last which plays all youtube videos without any problem.
When I switch to version 28.2.0, 28.4.0 or 28.5.0 the same problem occurs:
Youtube videos start for a fraction of a second, then stop and there's a circle in the video display area turning around forever (as if there is no data coming in or the bandwidth is low). When I press the play button repeatly video playback always starts for a fraction of a second and immediately stops.
There's always a few frames of the videos playing back and also a short part of the sound, but it always stops.
This happens for all youtube videos.
With versions 27.x.y there never was any problem (and still isn't). But every 28.x.0 version has this problem.

It is independent of the kernel version I am using. Also it does not depend on the flash player plugin I am using (tested several versions 30.x up to 32.x and even without flashplayer plugin).
I can start a new instance of palemoon without any extentions - and the problem already occurs.

I am using ALSA for sound and nvidia graphics card.
Any Ideas what I should try?

Greetings and Thanks

User avatar
trava90
Contributing developer
Contributing developer
Posts: 1565
Joined: 2013-05-20, 18:19
Location: Earth
Contact:

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by trava90 » 2019-05-16, 14:51

What distro are you using? Is it up to date? 64-bit or 32-bit Pale Moon? Are the FFmpeg and libavcodec packages installed?

User avatar
schnuck
Moongazer
Moongazer
Posts: 10
Joined: 2019-05-16, 13:49

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by schnuck » 2019-05-16, 14:56

Hello trava90,

Distro is Mageia 6.0 and it is up-to-date. But distro should not be the reason, since all 27.x. versions are actually working flawlessly.
It's 64bit version. 64bit versions of FFmpeg and libavcodec are installed.

Greetings

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 25004
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by Moonchild » 2019-05-16, 15:35

schnuck wrote:
2019-05-16, 14:56
But distro should not be the reason, since all 27.x. versions are actually working flawlessly.
That's not a logical conclusion. v28 is significantly different under the hood than v27, and will rely on different libs.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
therube
Board Warrior
Board Warrior
Posts: 1105
Joined: 2018-06-08, 17:02

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by therube » 2019-05-16, 16:15

Perhaps related?
peeves
hello there. i have problems with youtube. somehow a javascript problem. i guess they changed something and seamonkey isn't able to get it right.

peeves
i suspect this error: http://mibpaste.com/YfQ2oj

therube_agone
Pale Moon mentions YT + polymer & suggested a UA change, so might see if that works on your end ? viewtopic.php?p=146194#p146194
https://mozilla.logbot.info/seamonkey/20190515

User avatar
schnuck
Moongazer
Moongazer
Posts: 10
Joined: 2019-05-16, 13:49

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by schnuck » 2019-05-16, 17:24

Hello,

I was already using the Compatibility mode, where you can set up either Native, Gecko or Firefox Mode.
Also I tried using 'about:config' and set up 'general.useragent.complexOverride.moodle' to true, so
a special useragent is used for youtube - but that also doesn't change anything.

Then I used hooktube.com to see whether this interface works, but it also doesn't work.

So it just stays as it was, 28.x nope, 27.x yes ....

Greetings

User avatar
Isengrim
Board Warrior
Board Warrior
Posts: 1002
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by Isengrim » 2019-05-16, 20:47

Have you tried switching to a a temporary new profile, to verify that this isn't being caused by an extension or misconfiguration in an existing profile?
Linux Mint 19.2 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

User avatar
schnuck
Moongazer
Moongazer
Posts: 10
Joined: 2019-05-16, 13:49

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by schnuck » 2019-05-16, 20:57

Hello,

Yes, I had done that before. In the original posting I said "in a new instance". That was the test case where I had a new profile without any extentions and no
configuration at all. I've done that once again, just to make ultra sure - but it doesn't change anything.

Greetings

User avatar
therube
Board Warrior
Board Warrior
Posts: 1105
Joined: 2018-06-08, 17:02

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by therube » 2019-05-17, 00:51

What does YouTube HTML5 Video Player show?

Also it does not depend on the flash player plugin
Youtube no longer supports Flash.
Hasn't in a long time now.

User avatar
schnuck
Moongazer
Moongazer
Posts: 10
Joined: 2019-05-16, 13:49

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by schnuck » 2019-05-17, 01:27

s. Attachment - that's the output of https://www.youtube.com/html5

I expected Youtube to not depend on flash anymore, actually. I just wanted to point out that I already checked a lot of different things, that might have something to do with it - even if it's very unlikely ...

Greetings
Attachments
Support.jpg

vingtzwanzig
Fanatic
Fanatic
Posts: 127
Joined: 2017-04-20, 21:25
Contact:

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by vingtzwanzig » 2019-05-17, 14:20

Mageia seems to have recently got a New Moon package, initially there were You Tube problems but they are not mentioned later, so might it work better now? Something about using bundled icu?
https://bugs.mageia.org/show_bug.cgi?id=15489
I can watch You Tube videos in Pale Moon 64 bit linux, with binaries from the Pale Moon site, but I'm not using Mageia or the same hardware I expect.

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6268
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by New Tobin Paradigm » 2019-05-17, 14:35

By any chance did you mess woth the ua override and bump it to get the newer layout?
Image
- Gorhill is an interdimensional shape-shifting reptilian.. -
http://binaryoutcast.com/ | http://thereisonlyxul.org/ | Freenode #binaryoutcast

User avatar
schnuck
Moongazer
Moongazer
Posts: 10
Joined: 2019-05-16, 13:49

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by schnuck » 2019-05-17, 20:43

Hello Everybody,

I changed the UA settings several times, because people suggested that the changes are necessary.
But the problems are present in a new instance without any extentions and no configuration at all, as well as in any instance
(profile) I am using with very different configurations and extentions installed.
So, it's completely independent of any configuration at all.

Greetings

User avatar
schnuck
Moongazer
Moongazer
Posts: 10
Joined: 2019-05-16, 13:49

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by schnuck » 2019-05-17, 21:14

Hello Again,

User vingtzwanzig suggested using the newmoon package provided by the Blogdrake repositories.
It's basically a palemoon compiled for use in Mageia6 (AFAIK).

It has the same problems as every palemoon version of 28.x.

Does that prove anything? I don't know ...

Greetings

User avatar
schnuck
Moongazer
Moongazer
Posts: 10
Joined: 2019-05-16, 13:49

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by schnuck » 2019-05-17, 23:26

Hello Forum,

A new observation - which may help or just confuse even more ;-).
In a new instance of newmoon (palemoon) 28.5.0 without any extentions and no configuration at all, the ads served by Google/Youtube actually work flawlessly,
but the real content afterwards doesn't work.

Greetings

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6268
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by New Tobin Paradigm » 2019-05-17, 23:34

New Moon? What is the source of the build you are using?
Image
- Gorhill is an interdimensional shape-shifting reptilian.. -
http://binaryoutcast.com/ | http://thereisonlyxul.org/ | Freenode #binaryoutcast

User avatar
Isengrim
Board Warrior
Board Warrior
Posts: 1002
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by Isengrim » 2019-05-18, 00:56

New Moon is unofficial branding for browsers based on Pale Moon. Any builds being publicly distributed should not be using this branding, and certainly none of these builds are officially supported. If you are using these builds, you are on your own.
Linux Mint 19.2 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6268
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by New Tobin Paradigm » 2019-05-18, 02:02

Unofficial branding can be used by anyone, that is what it is there for. Though they are NOT supported by us or at all.
Image
- Gorhill is an interdimensional shape-shifting reptilian.. -
http://binaryoutcast.com/ | http://thereisonlyxul.org/ | Freenode #binaryoutcast

User avatar
Isengrim
Board Warrior
Board Warrior
Posts: 1002
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by Isengrim » 2019-05-18, 03:34

Off-topic:
What I meant was that it's bad practice... because now, AFAICT, there are multiple "New Moons" floating around that are named the same but are not the same product, and it's very confusing to keep track of.
Linux Mint 19.2 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

User avatar
schnuck
Moongazer
Moongazer
Posts: 10
Joined: 2019-05-16, 13:49

Re: All 28.x versions cannot run Youtube Videos, all 27.x.y versions can

Post by schnuck » 2019-05-18, 11:01

Hello Again,

To put things as clear as possible: I am only using the officially distributed binaries from palemoon.org and only those.
I am NOT using any other binary floating around at the internet, or any version made up by anyone.

Someone suggested that the newmoon version had the same problems I have, and that those distributors had solved these.
It was not the case. And I am NOT using those binaries apart from this little check.

So, once again. I AM using the officially distributed binaries from palemoon.org and no other version.

Greetings

Post Reply