Video content randomly freezing and stopping with Jack

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
tom__
Moongazer
Moongazer
Posts: 7
Joined: 2019-02-25, 02:11

Video content randomly freezing and stopping with Jack

Unread post by tom__ » 2019-02-25, 02:16

Video content content appears to randomly start slowing down then completely stopping to a pause when using Jack Audio Subsystem. This happens consistently. I talked to a friend who knows a lot about programming with Linux audio subsystems and he said it's most likely an issue with how the program handles buffering. A lot of programs do no implement this correctly and fail like this when Jack is using an uncommon buffer size, such as used in high latency audio production setups.

Has anyone else experienced this, and also does anyone know a fix for this?
Thanks

Lew Rockwell Fan
Fanatic
Fanatic
Posts: 169
Joined: 2017-06-14, 15:20

Re: Video content randomly freezing and stopping with Jack

Unread post by Lew Rockwell Fan » 2019-05-13, 17:40

This may be irrelevant. For one thing, I'm not sure exactly what you mean by "consistently". But, FWIW, I have similar issues with Pulse. But NOT consistently. I've always assumed the problem was either at the source or in the connection in between (like maybe a bandwidth issue) because a video on another page will play just fine. I might come back to the problem page the next day & it will work fine.
"To attempt to silence a man is to pay him homage, for it is an acknowledgement that his arguments are both impossible to answer and impossible to ignore." - John Bryant

User avatar
tom__
Moongazer
Moongazer
Posts: 7
Joined: 2019-02-25, 02:11

Re: Video content randomly freezing and stopping with Jack

Unread post by tom__ » 2019-07-26, 02:33

What I meant by consistently is that it is reproducible.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24589
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Video content randomly freezing and stopping with Jack

Unread post by Moonchild » 2019-07-26, 08:51

You may want to create an issue on our GitHub tracker with the exact environment you're working in and steps to reproduce, so we can put it on our backlog for things to look at. Unfortunately our de facto media component owner (Travis) currently has very little time to work on UXP and priority there is to get EME updated to Google's new API. But at least it will be known and others may be able to look at it too.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
tom__
Moongazer
Moongazer
Posts: 7
Joined: 2019-02-25, 02:11

Re: Video content randomly freezing and stopping with Jack

Unread post by tom__ » 2019-09-02, 05:36

Unfortunately I do not have any Microsoft accounts so I am not able to do that, however the steps to reproduce are pretty simple. Just launch Pale Moon on a Linux machine with Jack Audio Connection Kit audio subsystem. Then go to youtube.com or invidio.us and play videos until pressing play no longer works. It will buffer but refuse to play.

Also, I thought EME support was going to be dropped is it not?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24589
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Video content randomly freezing and stopping with Jack

Unread post by Moonchild » 2019-09-02, 08:00

we can't do anything with a 1-sentence description.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
tom__
Moongazer
Moongazer
Posts: 7
Joined: 2019-02-25, 02:11

Re: Video content randomly freezing and stopping with Jack

Unread post by tom__ » 2019-09-02, 08:16

I'll provide a back-trace as well as some logs if I encounter it again.

distantpluto
Apollo supporter
Apollo supporter
Posts: 46
Joined: 2015-12-17, 18:28
Location: UK

Re: Video content randomly freezing and stopping with Jack

Unread post by distantpluto » 2019-09-02, 09:07

Just an FYI... I use Jack exclusively (music production) and watch a lot of Youtube videos and don't have any problems. ALSA only, no pulse (never used it).

User avatar
moonbat
Astronaut
Astronaut
Posts: 562
Joined: 2015-12-09, 15:45
Location: Australia

Re: Video content randomly freezing and stopping with Jack

Unread post by moonbat » 2019-09-02, 09:40

tom__ wrote:
2019-09-02, 05:36
Unfortunately I do not have any Microsoft accounts so I am not able to do that
You don't need a Microsoft account. I created mine fairly recently, i.e. within the last few months post the Microsoft takeover, and it is a separate Github account.
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Linux Mint 19.2 Xfce x64 on HP i5 laptop with 4 GB RAM, always latest versions of PM & Basilisk unless specified.

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 6014
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: Video content randomly freezing and stopping with Jack

Unread post by New Tobin Paradigm » 2019-09-02, 11:37

EME is not going to be dropped from Basilisk at this time no. It is, however, broken at the CDM level currently as the targeted version of Google Widevine has expired. It does remain a development consern though and hopefully will be resolved sooner or later.
Image
- Oh, I've given you no word to keep, Admiral. In my judgment, you simply have no alternative. -
http://binaryoutcast.com/ | http://thereisonlyxul.org/ | Freenode #binaryoutcast

Post Reply