Problem with "Preferences" in version 28

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

User avatar
LS650V
Moongazer
Moongazer
Posts: 7
Joined: 2018-08-19, 08:50

Re: Problem with "Preferences" in version 28

Unread post by LS650V » 2019-01-26, 18:04

It has been a while since I have checked in here. With the Lubuntu LTS version I had been using on this Inspiron 6000 laptop nearing end of life, I decided to give Debian Stretch with LXDE desktop a try. The intel video driver is a bit newer, but I have the same problem with the Pale Moon Preferences Menu as before.

$ inxi -G
Graphics: Card: Intel Mobile 915GM/GMS/910GML Express Graphics Controller
Display Server: X.Org 1.19.2 driver: intel
Resolution: 1280x800@59.91hz
GLX Renderer: Mesa DRI Intel 915GM x86/MMX/SSE2
GLX Version: 2.1 Mesa 13.0.6

While researching solutions to other problems unrelated to Pale Moon, I stumbled across several references to issues with the intel video driver and older hardware:

https://mxlinux.org/wiki/hardware/intel-video-driver
and
https://wiki.archlinux.org/index.php/In ... SNA_issues

Apparently the default acceleration method, called sna, can cause issues when using older intel chipsets. An alternative is to use the older acceleration method, uxa.

To do this, I followed the instructions in the links I posted above:

Created a file (as root) called /etc/X11/xorg.conf.d/20-intel.conf with the following contents:

Section "Device"
Identifier "Device0"
Driver "intel"
Option "AccelMethod" "uxa"
EndSection

Thats it. No command line incantations necessary. Rebooted system and Pale Moon Preferences Menu issue is gone.

If you already have a 20-intel.conf file, then you just need to add line
Option "AccelMethod" "uxa"
to Section "Device" or add the whole section if it is missing.

greyowl
Fanatic
Fanatic
Posts: 182
Joined: 2013-10-06, 20:58
Location: canada

Re: Problem with "Preferences" in version 28

Unread post by greyowl » 2019-01-26, 19:12

@ LS650V,

Thank you so much for the research and the solution to this problem.
I tried it on my old Dell Latitude D610 laptop. It works like a charm.
I have been hoping for a solution since August. Now, out of nowhere, it appears.
I am truly impressed.
Thanks again.

For your reference, here is my inxi -G:
$ inxi -G
Graphics:
Device-1: Intel Mobile 915GM/GMS/910GML Express Graphics driver: i915 v: kernel
Display: server: X.Org 1.19.2 driver: intel resolution: 1024x768~60Hz
OpenGL: renderer: Mesa DRI Intel 915GM x86/MMX/SSE2 v: 2.1 Mesa 13.0.6

Bito_MUC
Apollo supporter
Apollo supporter
Posts: 36
Joined: 2015-06-17, 10:03
Location: Munich (Germany)

Re: Problem with "Preferences" in version 28

Unread post by Bito_MUC » 2019-01-26, 19:15

Hi LS650V,
thank you for your advice:
Created a file (as root) called /etc/X11/xorg.conf.d/20-intel.conf with the following contents: ...
I tried to do the same on my 13 years old HP laptop running Linux Mint 19.1 (see https://forum.palemoon.org/viewtopic.php?f=37&t=20713#p159685), but the OS refuses to copy anything to the directory /etc/X11/xorg.conf.d/. Instead Linux says that I am not the "owner" of that directory and I don't have the permission to copy. I am a 100-percent newbie to linux and thus I really don't know what I else could try to run my favorite browser without this annoying "bug" on that old machine (which has no problems with any other application I have tested). Could you please tell me how I can get Linux' permission to copy the file 20-intel.conf to the directory /etc/X11/xorg.conf.d/?

The details of the GPU are here:
~$ inxi -G
Graphics:
Device-1: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics
driver: i915 v: kernel
Display: x11 server: X.Org 1.19.6 driver: intel
unloaded: fbdev,modesetting,vesa resolution: 1280x800~60Hz
OpenGL: renderer: Mesa DRI Intel 945GM x86/MMX/SSE2 v: 1.4 Mesa 18.0.5

greyowl
Fanatic
Fanatic
Posts: 182
Joined: 2013-10-06, 20:58
Location: canada

Re: Problem with "Preferences" in version 28

Unread post by greyowl » 2019-01-26, 19:37

I might be able to help you even though I am a newbe too.
I am using antiX linux.
I made the file as instructed and saved it to the desktop. I right clicked on the file and chose Properties. Then, I selected Execute to the permissions.
Then, I opened File Manage and opened the File menu, and selected Root Window.
Then, I found the file 20-intel.conf in desktop and copied it to clip board.
Then, I found /etc/X11/xorg.conf.d and pasted the file in the folder.
Then, close the Root Window and do a restart.

Hopefully, this will work for you.

Python54
Moongazer
Moongazer
Posts: 7
Joined: 2014-10-12, 18:26
Location: UK

Re: Problem with "Preferences" in version 28

Unread post by Python54 » 2019-01-26, 19:51

@ LS650V,

Many thanks! I followed your instructions on my old HP 32-bit laptop running Mint 19.1 and now Palemoon 28.3.1 preferences are working again and the Media tab has also re-appeared in the Page Info dialog.

$ inxi -G
Graphics:
Device-1: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics driver: i915 v: kernel
Display: x11 server: X.Org 1.19.6 driver: intel resolution: 1280x800~60Hz
OpenGL: renderer: Mesa DRI Intel 945GM x86/MMX/SSE2 v: 1.4 Mesa 18.0.5

@Bito_MUC

My Mint 19.1 didn't have the xorg.conf.d sub-directory so I created it using:

$ sudo mkdir /etc/X11/xorg.conf.d

[then enter your password]

I then created the file using:

sudo xed /etc/X11/xorg.conf.d/20-intel.conf

[or substitute your favourite editor for xed]

and copy/pasted LS650V's file contents, then saved and exited the editor.

Rebooted and Palemoon is now working.

Bito_MUC
Apollo supporter
Apollo supporter
Posts: 36
Joined: 2015-06-17, 10:03
Location: Munich (Germany)

Re: Problem with "Preferences" in version 28

Unread post by Bito_MUC » 2019-01-26, 20:28

@ greyowl and Python54

many thanks for your help. With your advice I got palemoon running on my oldtimer-laptop
:thumbup:

and, of course, many many thanks to LS650V: with your "copy-and-paste-solution" you made my day!
:clap:

User avatar
stevepusser
Lunatic
Lunatic
Posts: 485
Joined: 2015-08-01, 18:33
Location: California

Re: Problem with "Preferences" in version 28

Unread post by stevepusser » 2019-01-30, 19:37

Another way to do it is to create the file in a folder owned by you, then copy it as system administrator to the correct system folder, either as root or with sudo, whatever your install uses.

Code: Select all

su -c 'cp 20-intel.conf /etc/X11/xorg.conf.d'
or

Code: Select all

sudo cp 20-intel.conf /etc/X11/xorg.conf.d
If you notice video tearing, and you can't fix it with any "video sync" option in your desktop's settings, the 'intel' driver also offers a Tearfree option that could help:

Code: Select all

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod" "uxa"
   Option      "TearFree"    "true"
EndSection

greyowl
Fanatic
Fanatic
Posts: 182
Joined: 2013-10-06, 20:58
Location: canada

Re: Problem with "Preferences" in version 28

Unread post by greyowl » 2019-01-31, 15:38

I'll watch for the video tearing.
Thanks for this added approach and modification.

User avatar
sys64738
New to the forum
New to the forum
Posts: 2
Joined: 2019-01-16, 21:45

Re: Problem with "Preferences" in version 28

Unread post by sys64738 » 2019-02-04, 23:58

Unfortunately switching the AccelMethod to UXA does not work for me:

Code: Select all

$ grep AccelMethod /var/log/Xorg.0.log
[  1481.010] (**) intel(0): Option "AccelMethod" "uxa"
My setup is here.[/s]

Edit:
It works! I was missing the Driver "intel" line which seems mandatory when changing the AccelMethod.

Proteus
Newbie
Newbie
Posts: 4
Joined: 2017-12-04, 13:23

Re: Problem with "Preferences" in version 28

Unread post by Proteus » 2019-02-28, 18:58

Many thanks to LS650V for this solution:

Code: Select all

Section "Device"
Identifier "Device0"
Driver "intel"
Option "AccelMethod" "uxa"
EndSection
It works for me at Lubuntu 18.04 at two old machines (Dell Inspiron 500m, Dell Inspiron 1300).

User avatar
lu ca
Newbie
Newbie
Posts: 3
Joined: 2019-04-05, 16:54

Re: Problem with "Preferences" in version 28

Unread post by lu ca » 2019-04-05, 17:16

I'm having the same problem & I use Linux lite OS...have removed & reinstalled x86 32 bit, numerous times & same thing happens. Cannot adjust "Preferences" at all- it's like hitting a brick wall.

User avatar
Nigaikaze
Board Warrior
Board Warrior
Posts: 1029
Joined: 2014-02-02, 22:15
Location: Chicago, IL, USA

Re: Problem with "Preferences" in version 28

Unread post by Nigaikaze » 2019-04-05, 17:34

lu ca wrote:I'm having the same problem & I use Linux lite OS
Well ... have you followed the instructions in the above posts in this thread?

User avatar
lu ca
Newbie
Newbie
Posts: 3
Joined: 2019-04-05, 16:54

Re: Problem with "Preferences" in version 28

Unread post by lu ca » 2019-04-06, 06:14

Twice, I kept working on the above, but still not working. I'll keep trying tomorrow.
Thanks for your help

User avatar
dshmpm
New to the forum
New to the forum
Posts: 1
Joined: 2019-04-16, 03:25

Re: Problem with "Preferences" in version 28

Unread post by dshmpm » 2019-04-16, 03:42

For me, the browser.preferences.animateFadeIn works for ONLY for the browser preferences, but not for add on preferences.

The addon preference windows still sees X events, but does not update the window.

Palemoon release 28.4.1 on Mageia 5.1 and on fairly current VOID Linux (Feb 2019 live iso) 32bit
Always using:
env GTK2_RC_FILES=/usr/share/themes/Adwaita/gtk-2.0/gtkrc palemoon

A workaround is to open the addon preferences window, THEN maximize, restore, AGAIN maximize, restore THEN it seems to work.
This will also make the browser preferences window work if animateFadeIn is false.

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 5239
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: Problem with "Preferences" in version 28

Unread post by New Tobin Paradigm » 2019-04-16, 09:46

Is your DE and Distro predominantly GTK3 or what?
Image

- Ask not what XUL can do for you. Ask what you can do with XUL! -
http://binaryoutcast.com/ | http://thereisonlyxul.org/

User avatar
groucho
New to the forum
New to the forum
Posts: 2
Joined: 2019-05-06, 15:19

Re: Problem with "Preferences" in version 28

Unread post by groucho » 2019-05-06, 20:28

Hello:
LS650V wrote:
2019-01-26, 18:04
... researching solutions to other problems unrelated to Pale Moon ...
https://mxlinux.org/wiki/hardware/intel-video-driver
and
https://wiki.archlinux.org/index.php/In ... SNA_issues

... followed the instructions in the links I posted above:
And took the time to write it up and post it here.

Thank you so very much for doing so. =-)

Best,

G.

Post Reply