Difficulty upgrading PM from 27* to 28* in Linux Mint using repository

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

yellowfinch
Hobby Astronomer
Hobby Astronomer
Posts: 22
Joined: 2017-01-09, 17:05

Difficulty upgrading PM from 27* to 28* in Linux Mint using repository

Unread post by yellowfinch » 2018-11-20, 14:42

On my main machine (LM 18.3) I have PM 28.0.1. Before I update it to 28.2.1, I would like to test it on another machine, so...

On my older machine (LM 17.1) I added the same ...stevenpusser/xUbuntu_16.04/ repository. When I asked Synaptic to install PM 28.2.1 it balked at unresolvable dependencies:

Code: Select all

Dépend : libdbus-1-3 (>=1.9.14) mais 1.6.18-0ubuntu4.3 doit être installé
Dépend : libfontconfig1 (>=1.11.94) mais 2.11.0-0ubuntu4.2 doit être installé
Dépend : libstdc++6 (>=5.2) mais 4.8.4-2ubuntu1~14.04.3 doit être installé
So I tried the same on my friend's newer machine (LM 18.1) and I got the same errors.

Am I to understand that PM 28* can only be installed (through a repository) on LM 18.3 or later?

I tried the PM 28.1 tarball on the LM 18.1 system and it worked fine, but I really want PM to be maintained through mint-update / synaptic from now on.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 3953
Joined: 2011-10-03, 10:19
Location: Texas, USA

Re: Difficulty upgrading PM from 27* to 28* in Linux Mint using repository

Unread post by Night Wing » 2018-11-20, 15:35

Linux Pale Moon is not in the Mint repository. Since it isn't in the Mint repository, linux Pale Moon cannot be updated through the Synaptic Package Manger or through the Update Manager. Linux Pale Moon has to be manually installed by you via the tarball to be listed in the Mint Menu under Internet.

If you don't want to install linux Pale Moon in Mint, you can use it by running it's executable file like I do. If you use this method, there will be no listing in the Mint menu under Internet. You have to create the launcher icon for Pale Moon from the image file which is found in the extracted Pale Moon folder. Once the Pale Moon launcher icon is created, you can move it to where you want on the Mint Panel (taskbar).

BTW, I don't think Pusser's version of linux Pale Moon for Ubuntu will work in Mint. If you want to see what my linux Pale Moon looks like when it is "not" installed in Mint, go to the page in the link below and find my username showing what my linux Pale Moon looks like. When on that page, start from the bottom of the page and work up since I've got a few posts on that page.

https://forum.palemoon.org/viewtopic.ph ... &start=380
Last edited by Night Wing on 2018-11-20, 15:36, edited 2 times in total.
Linux Mint 19.2 (Tina) Xfce 64 Bit (Default Distribution OS) with 64 Bit linux Pale Moon
Windows 7 Home Premium & Ultimate SP1, 64 Bit (Backup OS) with 32 Bit windows Pale Moon

yellowfinch
Hobby Astronomer
Hobby Astronomer
Posts: 22
Joined: 2017-01-09, 17:05

Re: Difficulty upgrading PM from 27* to 28* in Linux Mint using repository

Unread post by yellowfinch » 2018-11-20, 16:26

Pusser's version of linux Pale Moon for Ubuntu does work in Mint! That's how I upgraded PM from 27.9.2 to 28.0.1 - with just a couple of clicks in Synaptic. And it's ready to upgrade to 28.2.1 (except I've frozen it).

Chris Liu had confirmed this, here: https://www.chrisliu.ca/2017/03/04/pale-moon-and-gcc-repositories-for-linux-mint/
Last edited by yellowfinch on 2018-11-20, 16:29, edited 1 time in total.

User avatar
Isengrim
Keeps coming back
Keeps coming back
Posts: 918
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: Difficulty upgrading PM from 27* to 28* in Linux Mint using repository

Unread post by Isengrim » 2018-11-20, 16:38

Night Wing wrote:BTW, I don't think Pusser's version of linux Pale Moon for Ubuntu will work in Mint.
Can confirm that stevenpusser's version works in Mint. Been using it since v27. AFAIK there's nothing different about it except the update mechanism.
Linux Mint 19.2 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
JavaScript is not Java
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

yellowfinch
Hobby Astronomer
Hobby Astronomer
Posts: 22
Joined: 2017-01-09, 17:05

Re: Difficulty upgrading PM from 27* to 28* in Linux Mint using repository

Unread post by yellowfinch » 2018-11-20, 16:54

Been using it since v27.
Does that mean that you were using it before LM 18.3? If so, did you have to use a repository other than the one for Ubuntu 16.04?

User avatar
Isengrim
Keeps coming back
Keeps coming back
Posts: 918
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: Difficulty upgrading PM from 27* to 28* in Linux Mint using repository

Unread post by Isengrim » 2018-11-20, 21:07

yellowfinch wrote:Does that mean that you were using it before LM 18.3? If so, did you have to use a repository other than the one for Ubuntu 16.04?
For LM 18, you will need the Ubuntu 16.04 repo. For LM 17, you will need the Ubuntu 14.04 repo, assuming Mr. Pusser still maintains it.

https://forum.palemoon.org/viewtopic.ph ... 00#p155063
Linux Mint 19.2 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
JavaScript is not Java
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

yellowfinch
Hobby Astronomer
Hobby Astronomer
Posts: 22
Joined: 2017-01-09, 17:05

Re: Difficulty upgrading PM from 27* to 28* in Linux Mint using repository

Unread post by yellowfinch » 2018-11-20, 22:07

Isengrim wrote:For LM 18, you will need the Ubuntu 16.04 repo.
Yes, that's what I did, as mentioned in my initial post.
Isengrim wrote:For LM 17, you will need the Ubuntu 14.04 repo
Thanks, but...

There never was a repository for 14.04, AFAIK. At least, on the OpenSuse page in question, i.e. the one that Pale Moon's home page links to (under « these fully-endorsed third-party builds »).

I tried the 16.04 and it does offer PM 28.2.1 but I get the very same unresolvable dependency errors.

So, I'm still hoping to get a confirmation of my original supposition: that PM 28.2.1 can only be installed (through a repository) on LM 18.3 or later.

Either that, or a trick from someone who has managed to install it on LM 18.1 or 17.3.
Last edited by yellowfinch on 2018-11-20, 22:07, edited 1 time in total.

User avatar
Isengrim
Keeps coming back
Keeps coming back
Posts: 918
Joined: 2015-09-08, 22:54
Location: 127.0.0.1
Contact:

Re: Difficulty upgrading PM from 27* to 28* in Linux Mint using repository

Unread post by Isengrim » 2018-11-20, 22:18

yellowfinch wrote:There never was a repository for 14.04, AFAIK.
I could have sworn there was, but perhaps I am remembering wrongly. I know for sure I was using Pale Moon on Linux Mint 17.x. Stevenpusser can answer that question better than I can. ;)
yellowfinch wrote:So, I'm still hoping to get a confirmation of my original supposition: that PM 28.2.1 can only be installed (through a repository) on LM 18.3 or later.
Isengrim wrote:Can confirm that stevenpusser's version works in Mint.
Isengrim's Signature wrote:Linux Mint 18.3 Cinnamon (64-bit)
What dependency errors are you seeing? And how have you tried resolving them?
Last edited by Isengrim on 2018-11-20, 22:18, edited 1 time in total.
Linux Mint 19.2 Cinnamon (64-bit), Windows 7 (64-bit), Windows 10 build 1803 (64-bit)
JavaScript is not Java
"As long as there is someone who will appreciate the work involved in the creation, the effort is time well spent." ~ Tetsuzou Kamadani, Cave Story

yellowfinch
Hobby Astronomer
Hobby Astronomer
Posts: 22
Joined: 2017-01-09, 17:05

Re: Difficulty upgrading PM from 27* to 28* in Linux Mint using repository

Unread post by yellowfinch » 2018-11-20, 22:33

Isengrim wrote:What dependency errors are you seeing? And how have you tried resolving them?
The errors are shown in my initial post.

Since they state that a certain version of those libs is required but an earlier version must be present, I interpreted this as meaning that they are unresolvable in this version of LM.

[Edit] BTW: The PM page for Linux downloads mentions among other things that « libstdc++ 4.6.1 or higher » is required. This is interesting because I have 4.8.4 (on the LM 17.3 box) so it should work, but mintupdate says that PM requires 5.2 or higher.
Last edited by yellowfinch on 2018-11-20, 22:50, edited 2 times in total.

User avatar
Nigaikaze
Board Warrior
Board Warrior
Posts: 1072
Joined: 2014-02-02, 22:15
Location: Chicago, IL, USA

Re: Difficulty upgrading PM from 27* to 28* in Linux Mint using repository

Unread post by Nigaikaze » 2018-11-21, 02:29

yellowfinch wrote:[Edit] BTW: The PM page for Linux downloads mentions among other things that « libstdc++ 4.6.1 or higher » is required. This is interesting because I have 4.8.4 (on the LM 17.3 box) so it should work, but mintupdate says that PM requires 5.2 or higher.
The PM page for Linux downloads is describing the requirements for binaries downloaded from that specific page. You could always download PM 28.2.1 from there for LM 17.3.

Here's one post on Steve's announcement thread for his repos where he describes that distros based on Trusty/14.04 (such as LM 17.3) will have to include another PPA to pull in gcc-5 in order to run his releases of PM 28:

https://forum.palemoon.org/viewtopic.ph ... 80#p148845

And here's his latest post on that thread where he makes PM 28.2.1 debs available for download for Trusty:

https://forum.palemoon.org/viewtopic.ph ... 00#p156437

It sounds like his 14.04 repo no longer works for Trusty-based distros, but you'd have to look at his posts in that thread for the various details.
Nichi nichi kore ko jitsu = Every day is a good day.

User avatar
stevepusser
Astronaut
Astronaut
Posts: 506
Joined: 2015-08-01, 18:33
Location: California

Re: Difficulty upgrading PM from 27* to 28* in Linux Mint using repository

Unread post by stevepusser » 2018-11-21, 22:18

Yes, the latest versions of PM need gcc-4.9 or greater to build, and Ubuntu 14.04 only offers 4.8. I haven't been able to build a usable newer gcc for 14.04 in the OBS repo, so I removed the 14.04 part of the repo, but still offer debs I build manually with gcc-5 from a PPA.

However, the OPs issues are related to having 14.04's gcc-4.8, plus other older libs, on what is supposedly a 16.04/18.1 base:

libstdc++6 (>=5.2) mais 4.8.4-2ubuntu1~14.04.3 doit être installé ((but 4.8.4-2ubuntu1~14.04.3 is to be installed, (but "to be" actually means "already"))

Those errors are expected on Mint 17.1 with a PM deb built on 16.04, you just can't mix Ubuntu versions like that.

You can use my manually builts debs for Trusty on Mint 17, but you will also have to add this PPA to get the gcc-5 packages to run it beforehand: https://launchpad.net/~ubuntu-toolchain ... buntu/test

I don't know why those errors are showing up on the second supposedly 18.x Mint system, they should not.
Last edited by stevepusser on 2018-11-21, 22:27, edited 2 times in total.

User avatar
Michel
Newbie
Newbie
Posts: 5
Joined: 2018-12-03, 18:36

Re: Difficulty upgrading PM from 27* to 28* in Linux Mint using repository

Unread post by Michel » 2018-12-03, 18:59

Hi,

i am on OpenSuSE Tumbleweed with Plasma and installed my PM by downloading the binaries not from OpenSuSE-Repos, but from palemoon.org, unpacking them to my /home/bin/-folder and starting it with a link from my desktop. I think, it's more flexible this way.

Did You try this way?

User avatar
stevepusser
Astronaut
Astronaut
Posts: 506
Joined: 2015-08-01, 18:33
Location: California

Re: Difficulty upgrading PM from 27* to 28* in Linux Mint using repository

Unread post by stevepusser » 2018-12-05, 19:56

Don't the binaries from Pale Moon still require at least gcc-4.9 libraries?

Locked