Missing an uMatrix or similar plugin for PM28.x

General discussion, compatibility and contributed extensions.

Moderators: Lootyhoof, FranklinDM

Locked
jb_wisemo
Moongazer
Moongazer
Posts: 14
Joined: 2016-01-27, 02:09

Missing an uMatrix or similar plugin for PM28.x

Post by jb_wisemo » 2018-10-18, 15:53

:!: Currently there is no uMatrix-like user-controlled filtering extension listed for PM 28.x on the Addons site.

In todays Internet, that is pretty much a must-have for security and privacy (sure, AdBlockers like uBlock provide a rough approximation, but not as easily fine tuned as uMatrix etc.).

:-( uMatrix for XUL browsers is abandoned upstream with last official build being 1.1.4 but some people saying they can manually compile 1.2.0 for use with PM.

:idea: So it would be real nice if someone could point to another such plugin for PM 28.x or provide a semi-forked uMatrix for PM/XUL.

doofy
Astronaut
Astronaut
Posts: 627
Joined: 2017-08-14, 23:43

Re: Missing an uMatrix or similar plugin for PM28.x

Post by doofy » 2018-10-18, 16:01

What is your objection to 1.1.4?

jb_wisemo
Moongazer
Moongazer
Posts: 14
Joined: 2016-01-27, 02:09

Re: Missing an uMatrix or similar plugin for PM28.x

Post by jb_wisemo » 2018-10-18, 16:37

doofy wrote:What is your objection to 1.1.4?
Only that it seems no one is maintaining it and making sure it deals with whatever changes in the browser (such as the precise way each browser version handles filtering of requests, cached elements, different uses of such elements for operations such as printing etc. etc.). Firefox seemed to have some silly bugs in those areas and plugins like uMatrix contain workarounds that may not be right for PM 28, PM 29 etc.

doofy
Astronaut
Astronaut
Posts: 627
Joined: 2017-08-14, 23:43

Re: Missing an uMatrix or similar plugin for PM28.x

Post by doofy » 2018-10-18, 18:37

I come at it from a simpler POV - 1.1.4 works, so I use it.

The logic of your position restricts you to most of the addons on APO. And, of course, rules out uB0.

vannilla
Board Warrior
Board Warrior
Posts: 1203
Joined: 2018-05-05, 13:29

Re: Missing an uMatrix or similar plugin for PM28.x

Post by vannilla » 2018-10-19, 12:17

jb_wisemo wrote:Firefox seemed to have some silly bugs in those areas and plugins like uMatrix contain workarounds that may not be right for PM 28, PM 29 etc.
Some of the workaround in uMatrix 1.2.0 do not apply to PM 28 anymore, because those things were fixed, the rest is either for Fennec (Firefox for Android) or for Seamonkey.
There are also a number of polyfills that are not required anymore (but that doesn't really matter since it will use the built-in version if available).
Sure, PM 29 might change some stuff, but as of 28 uMatrix works correctly.
Last edited by vannilla on 2018-10-19, 12:18, edited 2 times in total.

User avatar
Raava
Moonbather
Moonbather
Posts: 57
Joined: 2014-06-22, 22:23
Location: Europe

Re: Missing an uMatrix or similar plugin for PM28.x

Post by Raava » 2019-02-02, 07:16

vannilla wrote:Some of the workaround in uMatrix 1.2.0 do not apply to PM 28 anymore
Should one then not use a newer version that 1.2.0?

I am with doofy on this one, my 1.1.4 uMatrix works as it should, so I keep it and haven't updated it in ages.
(My system x86-64 Linux, PM 28.3.1)
yours truly, Raava (aka Rava)

User avatar
Moonraker
Board Warrior
Board Warrior
Posts: 1545
Joined: 2015-09-30, 23:02
Location: uk.

Re: Missing an uMatrix or similar plugin for PM28.x

Post by Moonraker » 2019-02-02, 08:57

More often than not update junkies introduce more issues when updating..if it fits the purpose and works then why constantly change it.
Xenial puppy linux 32-bit.

Pale moon 28.9.3

vannilla
Board Warrior
Board Warrior
Posts: 1203
Joined: 2018-05-05, 13:29

Re: Missing an uMatrix or similar plugin for PM28.x

Post by vannilla » 2019-02-02, 11:18

1.2.0 is the last version that works as intended.
Newer versions either are incompatible (e.g. WebExtension) or have some problems whose origin is unclear (and thus hard to fix.)
Anyway, if 1.2.0 is the thing for you or not, just go read the changelog and make a decision based on that.

Michaell
Fanatic
Fanatic
Posts: 145
Joined: 2018-05-26, 18:13

Re: Missing an uMatrix or similar plugin for PM28.x

Post by Michaell » 2019-02-02, 14:58

Still using 1.0.0; works fine.
Win10home(1709), PM28.13port

jb_wisemo
Moongazer
Moongazer
Posts: 14
Joined: 2016-01-27, 02:09

Re: Missing an uMatrix or similar plugin for PM28.x

Post by jb_wisemo » 2019-02-03, 12:22

You all seem to miss the point. It doesn't have to be uMatrix, just something that gets updated when necessary. There are others that are even less worthy of mention here.

As of right now, there is still no such add-on on APO, and we're all basically left with whatever we can find as loose downloads or have backed up locally.

The fact that no such plugin has been successfully added to APO and all but one has abandoned PM support upstream is hurting the long term viability of PM itself.

:arrow: Thus I am hoping someone from the PM team will reach out to relevant members of the add-on community to get this resolved.

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1825
Joined: 2012-08-19, 20:32

Re: Missing an uMatrix or similar plugin for PM28.x

Post by back2themoon » 2019-02-03, 12:32

Are there any significant advantages with running uMatrix instead of uBO in Advanced mode? I seem to remember the distance between them had been significantly reduced. uMatrix has an option for HTTP referers for example, but that is easily taken care natively by Pale Moon's about:config or another extension.
Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides
How to download videos

Windows 10 Pro • Pale Moon x64 • Emsisoft Anti-Malware

Locked