Please note: we have made some forum changes regarding user data and privacy.
More info here: Planned downtime for the forum and changes.

Startup on ⅔ of screen for split-second

Support and discussions for the x86/x64 Linux version of Pale Moon.

Moderators: trava90, satrow

Locked
ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2049
Joined: 2012-06-28, 01:20

Startup on ⅔ of screen for split-second

Post by ron_1 » 2018-08-24, 21:09

When I open Pale Moon, for a split-second it looks like it will open on only ⅔ of the screen, before it then fills out. I attached a video and a picture of this so you can see what I'm talking about. This only started happening with PM 28. In the other two computers in the house (with Windows) this does not happen. It's not a big deal but I thought it should be reported. Here's the inxi -Fxz report on my computer:

Code: Select all

System:    Host: ron Kernel: 4.9.0-8-amd64 x86_64 (64 bit gcc: 6.3.0) Desktop: MATE 1.16.2 (Gtk 3.22.11-1)
           Distro: Devuan GNU/Linux ascii
Machine:   Device: desktop System: ASUS product: All Series
           Mobo: ASUSTeK model: H81M-C v: Rev X.0x BIOS: American Megatrends v: 0804 date: 05/16/2014
CPU:       Dual core Intel Pentium G3220 (-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11972
           clock speeds: max: 3000 MHz 1: 1599 MHz 2: 1590 MHz
Graphics:  Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0
           Display Server: X.Org 1.19.2 drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1600x900@60.00hz
           GLX Renderer: Mesa DRI Intel Haswell Desktop GLX Version: 3.0 Mesa 13.0.6 Direct Rendering: Yes
Audio:     Card Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.9.0-8-amd64
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 03:00.0
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 416.1GB (21.1% used)
           ID-1: /dev/sda model: Crucial_CT256MX1 size: 256.1GB
           ID-2: /dev/sdb model: ST3160815AS size: 160.0GB
Partition: ID-1: / size: 234G used: 8.0G (4%) fs: ext4 dev: /dev/sda5
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 142 Uptime: 1:37 Memory: 552.5/3828.7MB Init: SysVinit runlevel: 2 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.121) inxi: 2.3.5 
video.zip
(360.73 KiB) Downloaded 15 times
screen.jpg

andy80
Apollo supporter
Apollo supporter
Posts: 41
Joined: 2015-01-04, 08:21
Location: Beijing

Re: Startup on ⅔ of screen for split-second

Post by andy80 » 2018-08-25, 00:15

I can confirm the behavior; it seems that PM starts with a predefined size and then is expanded to full-screen but the content is not redrawn quickly enough do avoid noticing it.

These are my inxi -Fxz info, for completeness.

Code: Select all

System:    Host: erebor Kernel: 4.12.14-lp150.12.16-default x86_64 bits: 64 gcc: 7.3.1
           Desktop: LXDE (Openbox 3.6.1) Distro: openSUSE Leap 15.0
Machine:   Device: desktop System: LENOVO product: ThinkCentre M8500t-N000 v: Lenovo Product serial: <filter>
           Mobo: LENOVO model: SHARKBAY v: NOK serial: N/A BIOS: LENOVO v: FBKT79AUS date: 04/17/2014
CPU:       Quad core Intel Core i7-4790 (-HT-MCP-) arch: Haswell rev.3 cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28733
           clock speeds: max: 3600 MHz 1: 3591 MHz 2: 3591 MHz 3: 3591 MHz 4: 3591 MHz 5: 3591 MHz 6: 3591 MHz
           7: 3591 MHz 8: 3591 MHz
Graphics:  Card: NVIDIA GK107 [GeForce GT 630 OEM] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: nvidia (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1200@59.95hz
           OpenGL: renderer: GeForce GT 630/PCIe/SSE2 version: 4.5.0 NVIDIA 390.77 Direct Render: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GK107 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.12.14-lp150.12.16-default
Network:   Card: Intel Ethernet Connection I217-LM driver: e1000e v: 3.2.6-k port: f040 bus-ID: 00:19.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1000.2GB (78.0% used)
           ID-1: /dev/sda model: WDC_WD5000AAKX size: 500.1GB
           ID-2: /dev/sdb model: WDC_WD5000AAKX size: 500.1GB
Partition: ID-1: / size: 49G used: 16G (35%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 288M used: 86M (32%) fs: ext2 dev: /dev/sda1
           ID-3: /home size: 847G used: 691G (82%) fs: ext4 dev: /dev/dm-2
           ID-4: swap-1 size: 22.45GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:42C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 235 Uptime: 0:42 Memory: 1603.9/15958.0MB Init: systemd runlevel: 5 Gcc sys: 7.3.1
           Client: Shell (bash 4.4.191) inxi: 2.3.40

User avatar
Tokia
Hobby Astronomer
Hobby Astronomer
Posts: 16
Joined: 2018-08-16, 12:02

Re: Startup on ⅔ of screen for split-second

Post by Tokia » 2018-08-25, 06:30

I have same issue on v28 (x86)
Devuan | Fluxbox | Pale Moon (x86)
---
Nothing beats peace and quiet - Tomoki Sakurai

smoki
Apollo supporter
Apollo supporter
Posts: 35
Joined: 2018-01-19, 05:34

Re: Startup on ⅔ of screen for split-second

Post by smoki » 2018-08-25, 08:40

Seems happen only when window is maximised (by let say wm button), but not on anything else... even if you stretch window to max manually also does not happen.

So it is not immediately aware that window was/is maximized and first show part of non-maximised and then maximises it :D
Last edited by smoki on 2018-08-25, 09:06, edited 4 times in total.

User avatar
Tokia
Hobby Astronomer
Hobby Astronomer
Posts: 16
Joined: 2018-08-16, 12:02

Re: Startup on ⅔ of screen for split-second

Post by Tokia » 2018-08-25, 09:19

Good catch smoki, it's maximized window bring the issues as helloimustbegoing pointed with his picture.

I use maximized window for almost all time with Openbox/rc.xml, but just now turned off to check it.

Code: Select all

<application name="Navigator">
<focus>yes</focus>
<decor>no</decor>
<maximized>false</maximized>
</application>
Surprisingly, after turning OFF, do not show anymore the concern, So indeed is a maximized that do it, but hope will be a fix for maximized because i use all time maximized Window on my single Desktop.

Regards!
Last edited by Tokia on 2018-08-25, 09:40, edited 1 time in total.
Devuan | Fluxbox | Pale Moon (x86)
---
Nothing beats peace and quiet - Tomoki Sakurai

ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2049
Joined: 2012-06-28, 01:20

Re: Startup on ⅔ of screen for split-second

Post by ron_1 » 2018-08-25, 16:33

smoki wrote:
Seems happen only when window is maximised (by let say wm button), but not on anything else... even if you stretch window to max manually also does not happen.

So it is not immediately aware that window was/is maximized and first show part of non-maximised and then maximises it
With this bit of information, I found a work-around. I opened Pale Moon and unmaximized it. Then I stretched that unmaximized window as much as possible to fit the screen. Then I re-maximized Pale Moon. Now when restarting Pale Moon, it will initially start out with the fully stretched unmaximized window before filling out. Since the difference is so small (maybe just 1 pixel?), I don't even notice the change. :thumbup: Still it would be great if this is an issue that can be fixed.

vingtzwanzig
Fanatic
Fanatic
Posts: 126
Joined: 2017-04-20, 21:25
Contact:

Re: Startup on ⅔ of screen for split-second

Post by vingtzwanzig » 2018-08-25, 21:33

My impression was it's not the window, which looks like it does start out full screen, as the desktop behind disappears immediately, but the content in the tab I think.

ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2049
Joined: 2012-06-28, 01:20

Re: Startup on ⅔ of screen for split-second

Post by ron_1 » 2018-08-25, 22:59

I assume you mean the green part at the top of my screenshot? Isn't that drawn by the OS?

User avatar
mr tribute
Fanatic
Fanatic
Posts: 129
Joined: 2016-03-19, 23:24

Re: Startup on ⅔ of screen for split-second

Post by mr tribute » 2018-08-26, 00:24

I have seen this issue with Firefox too (but didn't care about it). Maybe it has been fixed in Firefox. To be honest, I don't see this as a problem. It only happens with new windows. With an SSD you have to be super quick to see it. Firefox (and all other GTK 3 apps) on the other hand renders new windows black (initially) on my system and that is a much bigger problem. I'm very thankful for the GTK 2 version of Pale Moon v28.

Anyway, we are talking split-seconds in this thread. The fact that the Pale Moon UI remains the same on a newer base with all my add-ons working is enough to make me happy. However if enough people feel that the new-window-initial-content-rendering "bug" is a problem maybe it will get fixed. I can confirm that this "bug" doesn't show up with Pale Moon v27.9.4.

vingtzwanzig
Fanatic
Fanatic
Posts: 126
Joined: 2017-04-20, 21:25
Contact:

Re: Startup on ⅔ of screen for split-second

Post by vingtzwanzig » 2018-08-27, 01:39

I assume you mean the green part at the top of my screenshot? Isn't that drawn by the OS?
Yes, thank you for pointing that out. Dragging the pointer to various points playing your video in Pale Moon allows this to be seen easily, I had noticed the desktop behind being obscured in real time playback, but not the detail. But what I meant was the window manager was drawing the correct size, and the info was not getting relayed in time. In GTK programs you draw the elements of the window, then finally display the completed window onscreen. Otherwise the window might appear in an incomplete form at first. So I guess Pale Moon is being drawn before the size information, which the OS must already have, has been relayed. So that must be done earlier or the window shown later. That might be easier in a short GTK example program though ... ;)

User avatar
mr tribute
Fanatic
Fanatic
Posts: 129
Joined: 2016-03-19, 23:24

Re: Startup on ⅔ of screen for split-second

Post by mr tribute » 2018-08-27, 16:25

On MATE with Compiz I can see this "bug" with both Firefox 61.0.1 and Pale Moon 27.9.4. So I have to wonder if anything has changed at all. It seems the window manager may also play a part since I didn't notice it with Xfce.

ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2049
Joined: 2012-06-28, 01:20

Re: Startup on ⅔ of screen for split-second

Post by ron_1 » 2018-08-28, 22:13

Ran some live sessions to see what would happen.

On PCLinuxOS with Mate, I still have this problem.
On Linux Mint with Cinnamon, I still have this problem.
On Refracta with Xfce, no problem.
Off-topic:
Refracta with Xfce seemed to run really zippy, even off the DVD. I'm starting to consider switching.
Last edited by ron_1 on 2018-08-28, 22:14, edited 1 time in total.

ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2049
Joined: 2012-06-28, 01:20

Re: Startup on ⅔ of screen for split-second

Post by ron_1 » 2018-09-01, 16:28

So . . . does anybody have any more input on this (minor) issue? It does seem to be caused by some interaction between PM and the window manager getting borked.

As per my last post, I'm guessing that I get the same thing in Cinnamon's window manager as Mate's because they share a common ancestor? But I'm a little fuzzy on that (i.e., the common ancestor part).

User avatar
therube
Board Warrior
Board Warrior
Posts: 1101
Joined: 2018-06-08, 17:02

Re: Startup on ⅔ of screen for split-second

Post by therube » 2018-09-01, 16:43

Have you tried with 28.0.1, or do have 28.0.1 available, yet?

ron_1
Moon Magic practitioner
Moon Magic practitioner
Posts: 2049
Joined: 2012-06-28, 01:20

Re: Startup on ⅔ of screen for split-second

Post by ron_1 » 2018-09-01, 19:55

therube wrote:
Have you tried with 28.0.1, or do have 28.0.1 available, yet?
Yes, no change.

User avatar
mr tribute
Fanatic
Fanatic
Posts: 129
Joined: 2016-03-19, 23:24

Re: Startup on ⅔ of screen for split-second

Post by mr tribute » 2018-09-01, 20:33

helloimustbegoing wrote:So . . . does anybody have any more input on this (minor) issue? It does seem to be caused by some interaction between PM and the window manager getting borked.

As per my last post, I'm guessing that I get the same thing in Cinnamon's window manager as Mate's because they share a common ancestor? But I'm a little fuzzy on that (i.e., the common ancestor part).
v28 does seem to accentuate the problem more than v27 does. v27 always seems to open with fully rendered toolbars while v28 opens with toolbars half-rendered. The burning question is: Is it a problem? It only happens with new windows. I did notice it after installing v28, but I wouldn't have reported it myself. I have bigger problems than that with Linux, but not with Pale Moon.

Cinnamon's window manager is called Muffin and is a fork of Gnome 3's window manager Mutter. Standard MATE window manager is a Metacity fork called Marco.

Locked