28.0.0 won't run Topic is solved

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderators: trava90, satrow

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
User avatar
MRCS4
Apollo supporter
Apollo supporter
Posts: 39
Joined: 2015-06-09, 23:36
Location: Pacific

28.0.0 won't run

Unread post by MRCS4 » 2018-08-17, 10:14

Faulting application name: palemoon.exe, version: 4.1.4.6793, time stamp: 0x5b699a8d
Faulting module name: mozglue.dll, version: 4.1.4.6793, time stamp: 0x5b699a62
Exception code: 0x80000003
Fault offset: 0x00003686
Faulting process id: 0x8b8
Faulting application start time: 0x01d4360921abdd66
Faulting application path: C:\Program Files\Pale Moon\palemoon.exe
Faulting module path: C:\Program Files\Pale Moon\mozglue.dll
Report Id: 5f775e30-a1fc-11e8-98bd-3497f693001f

First I did the normal in-browser update, used Restart Browser and got the Windows PM stopped working dialog box. I tried all the regular ways to get it to run, e.g. safe mode switch, uninstalled, downloaded the full version, downloaded the portable version. I have a very clean boot, but I turned off Comodo anyway. Can't think of what it could be. Reinstalled 27 and it works fine.

Win7 x86
Last edited by MRCS4 on 2018-08-17, 10:24, edited 2 times in total.
"If it ain't broke, don't fix it."
-- unknown

person45
Hobby Astronomer
Hobby Astronomer
Posts: 29
Joined: 2017-10-20, 07:00

Re: 28.0.0 won't run

Unread post by person45 » 2018-08-17, 11:04

I have the same problem in that it won't run. The portable version works, but not the regular one. I tried disabling all add-ons, but it still won't work.

Ok, I fixed it. It's working now.

Go to Help>Troubleshooting Information>Refresh Pale Moon...

This will take your browser back to default state and all your add-ons will get deleted, but your cookies and bookmarks will be kept the same. So make sure to backup your add-on files.

Now the installation for 28 will work.
Last edited by person45 on 2018-08-17, 11:38, edited 3 times in total.

plodr
Hobby Astronomer
Hobby Astronomer
Posts: 28
Joined: 2015-07-27, 19:09
Location: at my computer

Re: 28.0.0 won't run

Unread post by plodr » 2018-08-17, 15:56

Windows 7 Home 32 bit. Yesterday I tried upgrading my installed version 27.9.4 and all I get is an error box. Before i did that I removed an older portable version 27.4.0.
Thinking I broke something, I downloaded the portable version of 28 and it still errored out. So, last night I restored an image from 31st July. I "had" both versions working fine earlier today.

I decided to just update the portable version then I'd still have my installed version if something went wrong. I get the same error. This is what I see when I try to upgrade.
Image

Obviously I can't give an Troubleshooting information because the v 28 browser refuses to load on this computer.

User avatar
Tomaso
Board Warrior
Board Warrior
Posts: 1304
Joined: 2015-07-23, 16:09
Location: Norway

Re: 28.0.0 won't run

Unread post by Tomaso » 2018-08-17, 16:02

System requirements for UXP applications (Win):
https://forum.palemoon.org/viewtopic.php?f=62&t=19790/
* Windows 7 or later with service packs and updates applied.
Does your Win7 installation meet that criteria?

plodr
Hobby Astronomer
Hobby Astronomer
Posts: 28
Joined: 2015-07-27, 19:09
Location: at my computer

Re: 28.0.0 won't run

Unread post by plodr » 2018-08-17, 20:20

Yes I have SP1 and I have updates thru July 2018.
I have not done the August updates yet.

Since FF Quantum v 61 is working on this computer, I might have to use that as my day to day browser if v 28 of Palemoon refuses to run.
Last edited by plodr on 2018-08-17, 20:22, edited 1 time in total.

User avatar
Sajadi
Board Warrior
Board Warrior
Posts: 1040
Joined: 2013-04-19, 00:46

Re: 28.0.0 won't run

Unread post by Sajadi » 2018-08-17, 20:33

Just a small hint, if Pale Moon really does not work for you... you could give Vivaldi browser a try. Still tons better than recent Firefox feature wise ;)

Btw. as there are others with Windows 7 also posting issues... Not sure if that is an option for you, but you could try to update your graphic card drivers - Seems Pale Moon 28 is a bit "picky" when it's about the graphics-chip

https://forum.palemoon.org/viewtopic.ph ... ck#p147653
Last edited by Sajadi on 2018-08-17, 20:37, edited 2 times in total.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24628
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: 28.0.0 won't run

Unread post by Moonchild » 2018-08-17, 21:20

Using AppCrashView to get more details about the crashes would be very helpful.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
PaleGreg
Newbie
Newbie
Posts: 4
Joined: 2018-08-14, 16:40

Re: 28.0.0 won't run

Unread post by PaleGreg » 2018-08-17, 22:23

fwiw, I just upgraded to 28 and it wouldn't run. It crashed even before opening a window on the screen. Every time. I can't make it run from the task bar. However, from the Start button, if I right click the Pale Moon icon and choose to run it from Integrated graphics (rather than from Nvidia), then it runs. I think it runs better than 27.x did. Win7 (older), 24 GB RAM.

User avatar
Sajadi
Board Warrior
Board Warrior
Posts: 1040
Joined: 2013-04-19, 00:46

Re: 28.0.0 won't run

Unread post by Sajadi » 2018-08-17, 23:07

PaleGreg wrote:fwiw, I just upgraded to 28 and it wouldn't run. It crashed even before opening a window on the screen. Every time. I can't make it run from the task bar. However, from the Start button, if I right click the Pale Moon icon and choose to run it from Integrated graphics (rather than from Nvidia), then it runs. I think it runs better than 27.x did. Win7 (older), 24 GB RAM.
Then i would say it seems that Pale Moon has an issue with the Nvidia one. Sometimes newer drivers are helping, so at least worth a try.

User avatar
MRCS4
Apollo supporter
Apollo supporter
Posts: 39
Joined: 2015-06-09, 23:36
Location: Pacific

Re: 28.0.0 won't run

Unread post by MRCS4 » 2018-08-18, 07:41

I tried everything I could think of to throw at it on the 32-bit, and I believe that mozglue.dll is just a bad dll for some of us. It installed fine on the 64-bit installation I have on another drive, same machine. As for the 32-bit, I disabled every part of Comodo, started some Windows Services that may have been needed, downloaded the latest Visual C++ Redistributable, and even put mozglue.dll in the KnownDLLs key in the registry. As a last ditch I installed the latest nVidia driver even though the one I had wasn't that old. I also tried the safe mode switch on all attempts.
"If it ain't broke, don't fix it."
-- unknown

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24628
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: 28.0.0 won't run

Unread post by Moonchild » 2018-08-18, 08:18

Mozglue is not a bad dll -- it is where the memory allocator lives and what ties most components together. The fact it crashes in that dll most likely means there's a memory inflation issue (which, as some posts above pointed to, may be related to video drivers).
Once more, getting details about the crash is essential.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
MRCS4
Apollo supporter
Apollo supporter
Posts: 39
Joined: 2015-06-09, 23:36
Location: Pacific

Re: 28.0.0 won't run

Unread post by MRCS4 » 2018-08-18, 12:51

Report.wer
(13.23 KiB) Downloaded 6 times
Moonchild wrote:Once more, getting details about the crash is essential.
Besides the Event Log info in my original post, here is the .wer file. Do you want the crash dump, too? It's about 2.5MB.

Since people seem to think it's related to the graphics card/driver, I remember the developers for the old Opera having a hard time getting hardware acceleration to work. In Advanced Preferences I turned off everything that indicated acceleration and it didn't help. My card is the GTX 750. In my previous last ditch attempt, I had updated the driver from 391.24 to the latest one, 391.35.
Last edited by MRCS4 on 2018-08-18, 13:49, edited 2 times in total.
"If it ain't broke, don't fix it."
-- unknown

plodr
Hobby Astronomer
Hobby Astronomer
Posts: 28
Joined: 2015-07-27, 19:09
Location: at my computer

Re: 28.0.0 won't run

Unread post by plodr » 2018-08-18, 13:02

@Farscape I do have Vivaldi on this computer and use it from time to time but I prefer Palemoon.

@Moonchild what is AppCrashView? I never heard of it so I've never used it. Is this it?
https://www.nirsoft.net/utils/app_crash_view.html
I use some of Nirsoft's tools but have never used it.

To others who suspect it is Nvidia, the computer has no video card but the graphics chip is Nvidia so that is probably the problem. (I'm not willing to mess with drivers for one browser since everything else is working with no problem). I'm also not buying a video card for this sff pc that has a limited time running Windows 7. In 2020, I'll pull it off the internet and have no need for a browser on the computer. Since 2 of the 4 Windows 7 computers in the house have Nvidia, I guess I have a problem updating to v 28.

I downloaded and ran the above program.
I have exactly 1 Palemoon crash showing and that is from 2015.
old_PM_crash.jpg
Possibly because it is a portable version not even starting there is no crash.
Last edited by plodr on 2018-08-18, 13:11, edited 1 time in total.

User avatar
therube
Board Warrior
Board Warrior
Posts: 1081
Joined: 2018-06-08, 17:02

Re: 28.0.0 won't run

Unread post by therube » 2018-08-18, 13:17

6/21/2015, 25.5.0.5636, that's not going to be much help.

While the "stopped working" dialog is still up, give Nirsoft's WhatIsHang a shot at it & see if it can return something of interest.
Last edited by therube on 2018-08-18, 13:23, edited 1 time in total.

User avatar
PaleGreg
Newbie
Newbie
Posts: 4
Joined: 2018-08-14, 16:40

Re: 28.0.0 won't run

Unread post by PaleGreg » 2018-08-18, 16:02

Sajadi wrote:
PaleGreg wrote:fwiw, I just upgraded to 28 and it wouldn't run. It crashed even before opening a window on the screen. Every time. I can't make it run from the task bar. However, from the Start button, if I right click the Pale Moon icon and choose to run it from Integrated graphics (rather than from Nvidia), then it runs. I think it runs better than 27.x did. Win7 (older), 24 GB RAM.
Then i would say it seems that Pale Moon has an issue with the Nvidia one. Sometimes newer drivers are helping, so at least worth a try.
Thank you. The problem wasn't there when I rebooted. Rebooting was always one of the first remedies with Windows 95. Probably led many down the path towards coffee addiction. I've been spoiled by the apparent stability of Win7, which I had not rebooted in weeks, perhaps longer.

plodr
Hobby Astronomer
Hobby Astronomer
Posts: 28
Joined: 2015-07-27, 19:09
Location: at my computer

Re: 28.0.0 won't run

Unread post by plodr » 2018-08-19, 03:27

Solved.

I have Malwarebytes Premium. I had to turn off exploit protection then finally Palemoon would run.
I'm unwilling to lower my protection to run a browser particularly when other browsers don't require me to do this.

So, for anyone like me, who is unable to even get palemoon.exe to start, if you have Malwarebytes with real time protection, turn off one of the four protection modules and see if it loads.

doofy
Astronaut
Astronaut
Posts: 536
Joined: 2017-08-14, 23:43

Re: 28.0.0 won't run

Unread post by doofy » 2018-08-19, 03:35

plodr wrote:Solved. I have Malwarebytes Premium. I had to turn off exploit protection then finally Palemoon would run.
Re enable exploit protection and turn off web protection. See if that works for you.

IIRC web protection is broken. Exploit is potentially useful, web isn't.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 24628
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: 28.0.0 won't run

Unread post by Moonchild » 2018-08-19, 08:34

Some people have reported their problem was solved so marking this thread as such -- if you still have an issue please create a new thread for your individual distinct problem that hasn't been solved yet, please.
"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
MRCS4
Apollo supporter
Apollo supporter
Posts: 39
Joined: 2015-06-09, 23:36
Location: Pacific

Re: 28.0.0 won't run [Solved]

Unread post by MRCS4 » 2018-08-19, 09:36

EMET cannot be truly disabled without uninstalling it, as far as I know. Disabling the Service will not do it. So I removed PM from the applications list. I have not experimented yet with which additional exploit box needs to be unchecked.
"If it ain't broke, don't fix it."
-- unknown

person45
Hobby Astronomer
Hobby Astronomer
Posts: 29
Joined: 2017-10-20, 07:00

Re: 28.0.0 won't run

Unread post by person45 » 2018-08-19, 16:42

MRCS4 wrote:It installed fine on the 64-bit installation I have on another drive, same machine.
Wait a second, on the same operating system, it will work on one drive but not on another?

Everything else is the same? Is there something wrong with the physical hard drive?

Locked