Disappearing Search Window

Users and developers helping users with technical Pale Moon issues (Windows and other non-Linux O.S.). Please direct questions about the Linux version to the appropriate Linux board.

Moderator: trava90

Forum rules
This board is for technical/usage questions and troubleshooting for the Pale Moon browser only. The main focus here is on Pale Moon on Windows. Please direct your questions for Linux, Android and Mac to the dedicated boards.
Technical issues and questions not related to the Pale Moon browser should be posted in "technical chat"
Please keep off-topic and general discussion out of this board, thank you!
Locked
User avatar
LAR Grizzly
Fanatic
Fanatic
Posts: 199
Joined: 2017-08-11, 16:49
Location: Ohio, USA
Contact:

Disappearing Search Window

Post by LAR Grizzly » 2018-02-18, 18:47

I've had this anomaly for some time now and I would like to find a cure. I have my Search Window in my Menu Bar (see attached photo).

Anomaly:

If I install a new add-on or just check for add-on updates, the next time I open PM, the Search Window is gone. If I go to the Customize Palette, it's not there. I've found that the culprit is NoScript. If I disable NoScript (and restart), the Search Window appears. To get it back to the Menu Bar (and stick), I have to do the following (restarting after each procedure):

1. Place the Search Window in the Location Bar
2. Re-enable NoScript
3. Place the NoScript button back on the Location Bar
4. Move the Search Window to the Menu Bar

There are no further problems until I either install an add-on or check for add-on updates.

I have the same setup in both FX 52esr and SM 2.48 and have never experienced this problem in either browser.

I notice that re-enabling NoScript in either FX or SM automatically puts the button back on the Location Bar, wherein in PM it doesn't.

I have the latest NoScript 5.1.8.4 (I have tried NoScript 5.0.6 from the PM add-ons site, but it behaves the same).

Any clues? Thanks!
Attachments
00 Header Bar.jpg
Win7 Pro SP1 64 Bit
Comodo Internet Security
Pale Moon 28.12.0, Interlink Mail 52.9.7521, Firefox 52.9.0esr, Thunderbird 52.9.1 and SeaMonkey 2.48

User avatar
LAR Grizzly
Fanatic
Fanatic
Posts: 199
Joined: 2017-08-11, 16:49
Location: Ohio, USA
Contact:

Re: Disappearing Search Window

Post by LAR Grizzly » 2018-02-28, 22:32

I'm adding at least 15 characters to Bump this post.

Bump
Win7 Pro SP1 64 Bit
Comodo Internet Security
Pale Moon 28.12.0, Interlink Mail 52.9.7521, Firefox 52.9.0esr, Thunderbird 52.9.1 and SeaMonkey 2.48

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 7564
Joined: 2012-10-09, 19:37
Location: Just beyond the Lament Configuration

Re: Disappearing Search Window

Post by New Tobin Paradigm » 2018-03-01, 00:19

Please don't bump threads.. Now to ignore your question and not answer it.
Image
- Welcome to the worst nightmare of all... reality! -

User avatar
LAR Grizzly
Fanatic
Fanatic
Posts: 199
Joined: 2017-08-11, 16:49
Location: Ohio, USA
Contact:

Re: Disappearing Search Window

Post by LAR Grizzly » 2018-03-01, 01:39

New Tobin Paradigm wrote:Please don't bump threads.. Now to ignore your question and not answer it.
Thanks. I appreciate it.
Win7 Pro SP1 64 Bit
Comodo Internet Security
Pale Moon 28.12.0, Interlink Mail 52.9.7521, Firefox 52.9.0esr, Thunderbird 52.9.1 and SeaMonkey 2.48

User avatar
LAR Grizzly
Fanatic
Fanatic
Posts: 199
Joined: 2017-08-11, 16:49
Location: Ohio, USA
Contact:

Re: Disappearing Search Window

Post by LAR Grizzly » 2018-03-04, 18:52

New Tobin Paradigm:

From the Rules Page:

C. If you want more attention to a thread, then post in that thread! It will automatically be bumped if it's been long enough since the last post. #
Win7 Pro SP1 64 Bit
Comodo Internet Security
Pale Moon 28.12.0, Interlink Mail 52.9.7521, Firefox 52.9.0esr, Thunderbird 52.9.1 and SeaMonkey 2.48

User avatar
therube
Board Warrior
Board Warrior
Posts: 1319
Joined: 2018-06-08, 17:02

Re: Disappearing Search Window

Post by therube » 2018-06-12, 03:27

With a quick look, unable to duplicate.

PM 27.9.1 portable.
Win7 x64

Existing Profile
NoScript 5.1.8.5rc3 was installed, but disabled
BarTab Tyco 4.0 was installed, enabled

Enabled NoScript
Disabled BarTab

Customize, dragging search box (quack quack as it was) to the Menu bar

Except for the spacing between Help & the search box, looks the same as your shot.
Your theme is different as are all your other button placements.

Restart
No change
Enable BarTab
No change
Repeat...


More to do to get this to happen?

What do you get if you start with a new, Profile, no theme customization except for moving the search box & only installing NoScript?
Problem still exist?
Last edited by therube on 2018-06-12, 03:31, edited 2 times in total.

User avatar
LAR Grizzly
Fanatic
Fanatic
Posts: 199
Joined: 2017-08-11, 16:49
Location: Ohio, USA
Contact:

Re: Disappearing Search Window

Post by LAR Grizzly » 2018-06-12, 03:49

therube wrote:What do you get if you start with a new, Profile, no theme customization except for moving the search box & only installing NoScript?
Problem still exist?
Thanks for testing, but it was just easier to dump NoScript and use uBlock Origin in Advanced mode. Scripts, elements and ads are now handled by one extension. Easy-Peasy.
Last edited by LAR Grizzly on 2018-06-12, 03:50, edited 2 times in total.
Win7 Pro SP1 64 Bit
Comodo Internet Security
Pale Moon 28.12.0, Interlink Mail 52.9.7521, Firefox 52.9.0esr, Thunderbird 52.9.1 and SeaMonkey 2.48

Locked