Failed to connect to the server

Anything to do with the Pale Moon Sync service.

Moderator: satrow

f23948
Moongazer
Moongazer
Posts: 10
Joined: 2018-01-09, 23:10

Failed to connect to the server

Unread post by f23948 » 2018-04-24, 04:18

Image

User avatar
Nigaikaze
Board Warrior
Board Warrior
Posts: 1072
Joined: 2014-02-02, 22:15
Location: Chicago, IL, USA

Re: Failed to connect to the server

Unread post by Nigaikaze » 2018-04-24, 04:44

Nichi nichi kore ko jitsu = Every day is a good day.

f23948
Moongazer
Moongazer
Posts: 10
Joined: 2018-01-09, 23:10

Re: Failed to connect to the server

Unread post by f23948 » 2018-04-24, 04:59

i did not see the settings
Image
Image

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23916
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Failed to connect to the server

Unread post by Moonchild » 2018-04-24, 12:23

Which version of Pale Moon are you using?
City of Heroes public server: https://www.moonshard.org/ -- Vote for it on cohservers.com

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
eskaton023
Lunatic
Lunatic
Posts: 464
Joined: 2013-08-23, 19:54

Re: Failed to connect to the server

Unread post by eskaton023 » 2018-05-11, 12:27

I'm having a similar problem with one desktop running pm 27.9.1 x86 on Win 7 x64. The clusterurl entry isn't present until I open the Sync Setup screen, fill out the account/password/recovery key and hit Next to initiate the connection. Once I do so, the clusterurl entry populates with the .net address. Only then can I change it to .org, but hitting Next again still returns the 'failed to connect' message, which makes me wonder if the changed setting is really taking affect while the Sync window is still open. If I close the Sync window after making the modification, the clusterurl entry is wiped out. When I try setting that entry manually, the value is overwritten with the .net address the next time I open the Sync window and fill out the credentials. It seems like it's caught in a loop where I can't get it to recognize the .org address.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23916
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Failed to connect to the server

Unread post by Moonchild » 2018-05-11, 17:20

eskaton023 wrote:Once I do so, the clusterurl entry populates with the .net address.
That shouldn't happen! it should populate with the .org address.
I'll look and see if there maybe is an issue server-side.
Last edited by Moonchild on 2018-05-11, 17:21, edited 1 time in total.
City of Heroes public server: https://www.moonshard.org/ -- Vote for it on cohservers.com

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23916
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Failed to connect to the server

Unread post by Moonchild » 2018-05-11, 17:23

OK I finally found the issue.
The sync server communicates back the cluster URL to use on first setup/connect -- that setting was wrong. Entirely my fault; I failed to update the server setting when moving across to .org

It should now be fixed. Thanks for the pointer, eskaton!
City of Heroes public server: https://www.moonshard.org/ -- Vote for it on cohservers.com

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
Image

User avatar
eskaton023
Lunatic
Lunatic
Posts: 464
Joined: 2013-08-23, 19:54

Re: Failed to connect to the server

Unread post by eskaton023 » 2018-05-11, 17:48

You're very welcome. Tried it again just now and it worked like a charm. Thanks.

Locked