Building Palemoon 27 for XP

Talk about code development, features, specific bugzilla bugs, enhancements, patches, and other highly technical things.

Moderator: satrow

Forum rules
Please keep everything here strictly on-topic.
This board is meant for Pale Moon source code development related subjects only like code snippets, patches, specific referenced Bugzilla bugs, mercurial, etc.

This is not for tech support! Please do not post tech support questions in the "Development" board!
Please make sure not to use this board for support questions. Most "bug reports" do not belong in this board and should initially be posted in Community Support or other relevant support boards.

Please keep things on-topic as this forum will be used for reference for Pale Moon development. Expect topics that aren't relevant as such to be moved or deleted.
User avatar
Latitude
Astronaut
Astronaut
Posts: 508
Joined: Mon Mar 21, 2016 6:28 pm

Re: Building Palemoon 27 for XP

Postby Latitude » Mon Oct 23, 2017 11:16 pm

KingsMan wrote:How to add ublockorigin to source code?


You have to contact gorhill first to discuss the license & the legality of what you're going to do.

KingsMan
Hobby Astronomer
Hobby Astronomer
Posts: 22
Joined: Sun Aug 13, 2017 7:05 am

Re: Building Palemoon 27 for XP

Postby KingsMan » Tue Oct 24, 2017 4:40 am

Latitude wrote:
KingsMan wrote:How to add ublockorigin to source code?


You have to contact gorhill first to discuss the license & the legality of what you're going to do.

Ublockorigin is under GNU GENERAL PUBLIC LICENSE
Version 3, 29 June 2007. So I can use it in my god like mod of palemoon which I wish to call as litemoon.
I want to prebundle ublockorigin . I know how to install it nothing too special. This a development discussion so speak like devs.

User avatar
Trinoc
Fanatic
Fanatic
Posts: 191
Joined: Thu Oct 24, 2013 6:09 pm
Location: UK

Re: Building Palemoon 27 for XP

Postby Trinoc » Tue Oct 24, 2017 12:19 pm

c-sanchez wrote:@Fedor2 please, can you add in the installer an option as "Portable installation"?

As I wrote in another thread. this seems to work:

1) Install Palemoon 27.5.1 into a directory (but don't try to run it).
2) Start 7-Zip, navigate to Fedor2's installer, and open it as an archive.
3) Go to the "core" directory and select all files (but not sub-directories).
4) Extract all of these files into the Bin\Palemoon sub-directory of wherever you installed 27.5.1
(Where it prompts to overwrite existing files, click "yes to all")
5) Run Palemoon-Portable.exe.

Of course this is unofficial advice from a rank amateur, so there may be pitfalls I haven't found yet.

User avatar
Thehandyman1957
Board Warrior
Board Warrior
Posts: 1195
Joined: Tue May 19, 2015 2:26 am
Location: Arizona U.S.

Re: Building Palemoon 27 for XP

Postby Thehandyman1957 » Wed Nov 08, 2017 3:44 am

Can someone please tell me how to install this? I have a friend that still uses XP and needs this version.

Thanks.
"Watch your thoughts; they become words. Watch your words; they become actions. Watch your actions; they become habits. Watch your habits; they become your character. Watch your character; it becomes your destiny."

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 20087
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: Building Palemoon 27 for XP

Postby Moonchild » Wed Nov 08, 2017 4:21 am

KingsMan wrote:Ublockorigin is under GNU GENERAL PUBLIC LICENSE
Version 3, 29 June 2007. So I can use it in my god like mod of palemoon which I wish to call as litemoon.
I want to prebundle ublockorigin . I know how to install it nothing too special. This a development discussion so speak like devs.


Please note that the MPL and GPL are not necessarily compatible licenses. You should make sure that you satisfy both licenses when you bundle things; most notably, you will probably have to present ublock's license to users and clearly mention it incorporates Gorhill's extension when they install your modded browser. If you want to avoid that, then you should discuss bundling with him first.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

KingsMan
Hobby Astronomer
Hobby Astronomer
Posts: 22
Joined: Sun Aug 13, 2017 7:05 am

Re: Building Palemoon 27 for XP

Postby KingsMan » Thu Nov 09, 2017 6:52 am

Moonchild wrote:
KingsMan wrote:Ublockorigin is under GNU GENERAL PUBLIC LICENSE
Version 3, 29 June 2007. So I can use it in my god like mod of palemoon which I wish to call as litemoon.
I want to prebundle ublockorigin . I know how to install it nothing too special. This a development discussion so speak like devs.


Please note that the MPL and GPL are not necessarily compatible licenses. You should make sure that you satisfy both licenses when you bundle things; most notably, you will probably have to present ublock's license to users and clearly mention it incorporates Gorhill's extension when they install your modded browser. If you want to avoid that, then you should discuss bundling with him first.

Thanks a lot for your honorable suggestions.

KingsMan
Hobby Astronomer
Hobby Astronomer
Posts: 22
Joined: Sun Aug 13, 2017 7:05 am

Re: Building Palemoon 27 for XP

Postby KingsMan » Fri Nov 10, 2017 1:49 pm

Thehandyman1957 wrote:Can someone please tell me how to install this? I have a friend that still uses XP and needs this version.

Thanks.

Here you go
https://github.com/Feodor2/Mypal/releases

User avatar
Latitude
Astronaut
Astronaut
Posts: 508
Joined: Mon Mar 21, 2016 6:28 pm

Re: Building Palemoon 27 for XP

Postby Latitude » Sun Nov 12, 2017 8:39 am

Are these roytam's releases?

What are the differences between roytam's & Feodor2's in his GitHub page? Are they the same?

http://o.rthost.cf/palemoon/

I found this on MSFN page of "New Moon".

User avatar
Thehandyman1957
Board Warrior
Board Warrior
Posts: 1195
Joined: Tue May 19, 2015 2:26 am
Location: Arizona U.S.

Re: Building Palemoon 27 for XP

Postby Thehandyman1957 » Sun Nov 12, 2017 10:37 pm

KingsMan wrote:
Thehandyman1957 wrote:Can someone please tell me how to install this? I have a friend that still uses XP and needs this version.

Thanks.

Here you go
https://github.com/Feodor2/Mypal/releases


I have tried to download his 32 bit version to no avail. I even opened a issue on Github.

When I click on the version I want, it takes me to a download site and proceeds to act like it's downloading to somewhere on my computer.
But when it is finished it asks me where I want to put it, and when I give it a directory "like my desktop" it gives me a error with both the built in
downloader and my OS level Internet Download Accelerator even if I use flashgot.


This is what the web page gives me after it downloads to somewhere.
Screenshot - 11_12_2017 , 3_34_22 PM.png


This is what it asks me after it downloads on the page using flashgot and the default downloader.
Screenshot - 11_12_2017 , 3_25_13 PM.png


This is what it shows after I click ok.
Screenshot - 11_12_2017 , 3_25_34 PM.png


If I use IDA I get this error.
Screenshot - 11_12_2017 , 3_34_03 PM.png


So I'm not sure why this is happening but perhaps I will try using safe mode and try again.

Ok, update: In safe mode it finally let me save it to my desktop.
The question I have is why? What would be stopping both my basic browser downloader and also a
completely separate downloader? Any ideas?

I have Disconnect, NoScript (with scripts allowed) Ublock and ABL.
"Watch your thoughts; they become words. Watch your words; they become actions. Watch your actions; they become habits. Watch your habits; they become your character. Watch your character; it becomes your destiny."

User avatar
Trinoc
Fanatic
Fanatic
Posts: 191
Joined: Thu Oct 24, 2013 6:09 pm
Location: UK

Re: Building Palemoon 27 for XP

Postby Trinoc » Mon Nov 13, 2017 12:40 am

I've installed Newmoon 27 for XP and it seems to be working OK so far.

One problem: If I try to start it while it's already running (e.g. to open a url from the command line), I get a box saying it is already running but not responding. When I do the same with Palemoon 26 portable it opens the url in the existing browser OK.

I've tried adding MOZ_NO_REMOTE to about:config, set to either 0 or 1, but neither seems to work.

If I could get this to work, I could use DefaultBrowser to set it to open urls in emails etc, just as I have with Palemoon 26 portable at the moment.

Does anyone know how I can do this?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 20087
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: Building Palemoon 27 for XP

Postby Moonchild » Mon Nov 13, 2017 7:45 am

@thehandyman: you're having trouble downloading because of the way mega tries to do downloading (downloading everything to a blob data object first, then saving to disk).

@Feodor: I already offered for people to have hosting space if they need it, but I guess y'all would rather use a dodgy service that has known issues with some setups?
If you offer releases on GitHub, why not use their option to actually add binaries and let people down from GitHub? Why use Mega?

@Trinoc: MOZ_NO_REMOTE is not something you should add to about:config. If you're using the portable launcher I supplied for Pale Moon, you need to put it in its .ini file.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

User avatar
Trinoc
Fanatic
Fanatic
Posts: 191
Joined: Thu Oct 24, 2013 6:09 pm
Location: UK

Re: Building Palemoon 27 for XP

Postby Trinoc » Mon Nov 13, 2017 12:16 pm

Moonchild wrote:@Trinoc: MOZ_NO_REMOTE is not something you should add to about:config. If you're using the portable launcher I supplied for Pale Moon, you need to put it in its .ini file.

Yes, I understand that now, thanks. The reason I tried messing with MOZ_NO_REMOTE was that with standard Palemoon Portable (versions 24-26) I found that if I removed MOZ_NO_REMOTE=1 from user.ini then I was able to link Palemoon into the registry to process links from other places such as email, using defaultbrowser.exe (set browser type = Firefox Portable and point the app path to palemoon-portable.exe). If I left MOZ_NO_REMOTE=1 in user.ini then clicking on a link in an email resulted in the error message I mentioned, saying Palemoon was already running and not responding. Since I got the same error message out of Newmoon I guessed MOZ_NO_REMOTE might be involved somehow.

The trouble is that Feodor's Newmoon portable installation does not use the portableapps.com launcher so there is no user.ini. If I run defaultbrowser.exe and point the app path at the Newmoon version of palemoon.exe then I can use a link in an email provided that Newmoon is not already running, but if it is already running I get the error message.

What is the proper way to tell Palemoon/Newmoon to open a new tab if it is started when it is already running, rather than giving an error? Is it something to do with needing MOZ_NO_REMOTE in the command line (which I might be able to patch in the registry), or in the environment, or is there something else I can do that doesn't involve system patching?

User avatar
Fedor2
Lunatic
Lunatic
Posts: 324
Joined: Mon Apr 11, 2016 1:26 am

Re: Building Palemoon 27 for XP

Postby Fedor2 » Mon Nov 13, 2017 2:08 pm

I started using mega because i have found it far better then rghost i was using before. Now i found that binaries can be attatched on github, mega remains for backup. :( github wont accept exe file, woe it wont accept files larger 10mb. Moonchild if its still possible with your host i shall to do it good.

As in my build for portable i disabled default browser and remote by intent - it is a portable. There is not known way regulate remote feature in about:config. However i provided an option to cancel portable in "set default browser" button. Once i met few users whose do want some under-portable way, seems this is one more. I consider add under-portable feature in the future.
Last edited by Fedor2 on Mon Nov 13, 2017 2:30 pm, edited 1 time in total.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 20087
Joined: Sun Aug 28, 2011 5:27 pm
Location: 58.5°N 15.5°E
Contact:

Re: Building Palemoon 27 for XP

Postby Moonchild » Mon Nov 13, 2017 2:19 pm

Fedor2 wrote:github wont accept exe file.

So, if you need hosting, why haven't you asked me? I offered it way back in the start of this thread :P
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

User avatar
Trinoc
Fanatic
Fanatic
Posts: 191
Joined: Thu Oct 24, 2013 6:09 pm
Location: UK

Re: Building Palemoon 27 for XP

Postby Trinoc » Mon Nov 13, 2017 2:39 pm

Fedor2 wrote:As in my build for portable i disabled default browser and remote by intent - it is a portable. There is not known way regulate remote feature in about:config. However i provided an option to cancel portable in "set default browser" button. Once i met few users whose do want some under-portable way, seems this is one more. I consider add under-portable feature in the future.

I just tried clicking on "Make New Moon the default browser" button. It warned me that it was changing to non-portable mode, which I OK-ed. I then clicked on a link in an email and the first thing it did was put up a pop-up asking me whether I wanted to import my settings from Internet Explorer (I didn't). Then when I dismissed the pop-up the email link appeared in a complete new instance on New Moon.

This is more complicated than what I am trying to achieve. All I really want is what I can do with Palemoon Portable and defaultbrowser.exe, namely that when Palemoon is run with a url parameter and discovers that it is already running, it passes the url to the running Palemoon to open in a new tab instead of putting up an error message.

This seems to work fine with the existing Palemoon Portable, provided that I remove MOZ_NO_REMOTE=1, but so far I haven't found any settings in Newmoon that will allow it to be run while already running, without generating the "Running and not responding" error message.

If there is nothing I can do then I could revert to my earlier fudge, which is to install the complete non-XP Palemoon Portable then overwrite certain files with ones from your release (see my post on October 24). This seems to work, but I would prefer to do it your own way if possible.

I'm not concerned about the portable version being "stealth"; I'm not running it from a USB stick or anything like that. I simply want to run it free-standing from a directory on a non-system drive, in a way that I can back up or copy to another computer by simply copying across that directory.

User avatar
Fedor2
Lunatic
Lunatic
Posts: 324
Joined: Mon Apr 11, 2016 1:26 am

Re: Building Palemoon 27 for XP

Postby Fedor2 » Mon Nov 13, 2017 2:59 pm

Trinoc
Exactly this way browser behavior i called underportable. Can do it simple with command line: palemoon.exe -profile "path to your profile", and for you not want bother with command line i shall do add feature in next version. Also you can create shortcut with that command line.

User avatar
Trinoc
Fanatic
Fanatic
Posts: 191
Joined: Thu Oct 24, 2013 6:09 pm
Location: UK

Re: Building Palemoon 27 for XP

Postby Trinoc » Mon Nov 13, 2017 3:24 pm

Fedor2 wrote:Trinoc
Exactly this way browser behavior i called underportable. Can do it simple with command line: palemoon.exe -profile "path to your profile", and for you not want bother with command line i shall do add feature in next version. Also you can create shortcut with that command line.

I tried changing the shortcut to "K:\Newmoon 27\palemoon.exe" -profile "K:\Newmoon 27\Profile" but if I run this when Newmoon portable is already running I still get an error box.

The complete text of the error is "Pale Moon is already running, but is not responding. To open a new window, you must first close the existing Pale Moon process, or restart your system".

When I pass a link to Palemoon Portable 26.5.0 after setting it up with defaultbrowser.exe it gets passed a command line such as:

"K:\Palemoon 26.5.0\Palemoon-Portable.exe" -requestPending -url "https://forum.palemoon.org/viewtopic.php?f=49&t=8891&p=59250&e=59250"

This opens a new tab in Palemoon Portable 26.5.0 with the forum thread in question.

I just tried setting up Newmoon 27 (after it had self-converted to non-portable mode) with defaultbrowser.exe, and now it seems to work with a link from an email, opening up a new tab. The command line passed is similar to the one above for 26.5.0. However I would prefer to be able to do this without changing to non-portable mode completely, as I assume this means it will be messing with the registry and other system files and will no longer be a genuinely stand-alone application.

It doesn't bother me if I have to run defaultbrowser.exe again any time I move Newmoon to a new location, but I don't really want it to be changing other system settings which would not get backed up (or transferred to another computer) by simply copying the main Newmoon directory.

lazyaccountname
Moongazer
Moongazer
Posts: 9
Joined: Sat Mar 25, 2017 7:55 pm

Re: Building Palemoon 27 for XP

Postby lazyaccountname » Sun Nov 19, 2017 7:05 am

I've been looking for updated builds of PM that don't need SSE2-capable processors because all I have to my name is this Athlon XP and it would be nice to be able to update past PM 26.5, and I found some hope with this project. However, after installing Feodor2's version I'm getting a "Couldn't load XPCOM" error when trying to run it - could it be because I'm running Windows 7? I have no idea how to tackle this matter because all I find everywhere has to do with reinstalling Firefox (or Pale Moon).
And while I'm at it, will New Moon even run on an Athlon XP anyway?

visionhelp
Apollo supporter
Apollo supporter
Posts: 41
Joined: Sat Jul 18, 2015 6:14 pm
Location: Germany

Re: Building Palemoon 27 for XP

Postby visionhelp » Thu Nov 23, 2017 10:32 am

Hi,

XP is my last Windows version I will ever use.

Pale Moon the last years is ´MY´ browser.
FireFox for exceptions.

This idea "Pale Moon for XP" is very great.
That this forum does not want to support this XP version, OK.

But with having a subforum for XP it could be done in there, too, there a subforum "Pale Moon for XP".
But OK, is not wanted.

As long as Avast, ClamWin AV, Agnitum Outpost, Thunderbird, and a working browser does it with XP, it is to use until no more practible.
And a very user friendly Linux, perhaps with a little Windows-Look, could be possible until there.
But this, I do not really think, will happen.

All my respect to the work and effort for this "New Moon".
Sadnessly programming I cannot help anything. And this is the most work, which has to be done.
Easy working "install and work with version" I would like to may expect,

mekineer
Apollo supporter
Apollo supporter
Posts: 43
Joined: Fri Nov 22, 2013 9:01 am
Location: nyc

Re: Building Palemoon 27 for XP

Postby mekineer » Fri Nov 24, 2017 4:33 am

In regards to http://www.msfn.org/board/topic/177125- ... oon-for-xp, made by roytam1
and https://github.com/Feodor2/Mypal/releases made by fedor2
Are you guys collaborating? If not, then I have no idea how to choose which one would be better, so please collaborate! Thanks for sticking with Windows XP. I'm sure a lot of people have a need for it.

Off topic, just want you to know why one person would continue to use XP (aside from only having 2GB ram):
I've been using XP, even with dual boot option for Win7, because my laptop kinda didn't support Win7, because a USB driver made my keyboard act horribly (see https://social.technet.microsoft.com/Fo ... rohardware). Actually, I was messing with windows embedded standard 7. Then just recently with Snappy Drivers https://sdi-tool.org/, I found that installing their drivers solved the issue, especially PCI Class USB 2.0 Enhanced Host Controller (watch for the expansion arrow for a drop down list, which have to be selected separately!).


Return to “Development (discussion)”

Who is online

Users browsing this forum: No registered users and 1 guest