Did something recently change with flash? I'm on Linux Topic is solved

General discussion and compatibility support about browser plug-ins.
(e.g. Adobe Flash, Java plugin, authentication plugins, Unity)

Moderators: satrow, Lootyhoof, FranklinDM


Did something recently change with flash? I'm on Linux

Post by ttggx » 2017-06-24, 21:28

Hello, I saw this thread about Java:
I'm on Linux [Manjaro] as well but thought to create a new thread because to the best of my knowledge this is about Flash.

At Bank of America they have a product called "shopsafe" that opens in a little window. You can create vendor specific "virtual" credit card numbers with it.

It's been working fine for years, but just over the past week I get "a plugin is needed to display this content". The same thing just started happening in Firefox with Shopsafe, with a little puzzle symbol in the window.

After some research I found that Google Chrome was supposed to be Flash friendly, after installing it too would not work. Then [strangely] after trying it and reloading a bunch of times it suddenly gave me an option to choose to allow flash. I can now access the Shopsafe. However, I would prefer to continue with Pale Moon, where I do a bunch of related business type stuff.

Question: I look at my palemoon plugins and it says "you don't have any add-ons of this type" [!!?]. Wouldn't that be where Adobe Flash is shown? I also used the link from the other thread to check for Java, looks like I don't have that either. So, how was I accessing the Shopsafe all these years? It definitely requires a plugin, from my experience with Chrome I'd say it is Flash.
thanks for any info!

Posts: 186
Joined: 2015-06-04, 18:12

Re: Did something recently change with flash? I'm on Linux

Post by Toa-Nuva » 2017-06-25, 07:49

Have you also checked your package manager? Make sure the package "flashplugin" is installed. (If it is, you can try reinstalling it, maybe that will fix it.)
Afterwards, restart the browser and check the "Plugins" page again.

(As for Chrome, I think (?) Chrome ships with its own, Chrome-specific version of Flash. So that would by why Flash works for you in Chrome, even though it doesn't in other browsers.)

User avatar
Posts: 239
Joined: 2014-09-19, 23:53
Location: Washington State, USA

Re: Did something recently change with flash? I'm on Linux

Post by troypulk » 2017-06-25, 15:16

Also some web sites update their flash really fast so if you have an older version it will not work.

Right now the latest is my distro has the last one still

If this is it you might have to wait for your distro to update.
SolydX EE (64-bit) Xfce 4.12

Pale Moon 28.2.0a1 (64-bit) (2018-11-07)


Re: Did something recently change with flash? I'm on Linux

Post by ttggx » 2017-06-26, 01:41

heh, thank you troypulk and Toa-Nuva! Yeah that was it, flashplugin was missing. Must have got lost in an update or something, I'll have to assume it was there before because like I said the bank app was always working. OK, great, mystery solved! thanks again, much appreciated