IDM no intregra a PM 28.0.1

Para discusiones de usuarios escritas en Español

Moderator: satrow

LoneLoz
Newbie
Newbie
Posts: 3
Joined: Wed, 11 Oct 2017, 13:45

IDM no intregra a PM 28.0.1

Unread postby LoneLoz » Sun, 09 Sep 2018, 17:36

Hola a todos, recién la anterior semana actualice mi versión de Pale Moon 27.5.0 a la versión 28.0.1, porque según pude observar, esta última versión corregía algunos errores que tenia la versión 27, pero queriendo integrar IDM a esta última versión de Pale Moon, me aparece un mensaje que menciona que el complemento "idmmzcc2.xpi" no es compatible con la versión 28.0.1, no sé si alguien me puede ayudar a solucionar este problema.

User avatar
back2themoon
Board Warrior
Board Warrior
Posts: 1196
Joined: Sun, 19 Aug 2012, 20:32

Re: IDM no intregra a PM 28.0.1

Unread postby back2themoon » Sun, 09 Sep 2018, 20:01

Safe Mode / clean profile info: Help/Restart in Safe Mode
Information to include when asking for support - How to apply user agent overrides

Windows 10 Pro - Pale Moon x64 - FossaMail x64 - Emsisoft Anti-Malware

User avatar
KNTRO
Astronaut
Astronaut
Posts: 624
Joined: Tue, 01 Jan 2013, 10:46
Location: Ḧïṡṗäṅöäṁéṛïċä
Contact:

Re: IDM no intregra a PM 28.0.1

Unread postby KNTRO » Mon, 10 Sep 2018, 16:24

LoneLoz:

Hola, cómo estás.

En la página de lanzamientos de Internet Download Manager dice:
What's new in version 6.28 Build 1
(Released: Mar 22, 2017)
[…]
A new type of extension for Firefox (webextension) has been created that supports multiprosess Firefox feature (e10s)


Es decir, que a partir de la versión 6.28 compilación 1 de IDM, el complemento para Mozilla Firefox pasó a ser una WebExtension, y Pale Moon no es compatible con ese tipo de complementos.
tenpo pini la jan seme toki e mun walo li ike? ;)

LoneLoz
Newbie
Newbie
Posts: 3
Joined: Wed, 11 Oct 2017, 13:45

Re: IDM no intregra a PM 28.0.1

Unread postby LoneLoz » Tue, 11 Sep 2018, 02:28

Antes que nada, muchas gracias a los dos por responder.

back2themoon
Estaba observando el post que me sugeriste y la verdad encontré algunas cosas interesantes que desconocía, una de ellas fue la modificación que se le puede realizar al archivo "install.rdf" del complemento de IDM, probare ha modificarlo, tal vez llegue a algún resultado satisfactorio o tal vez no.

KNTRO
Mmm, estoy algo confundido, si IDM cambio su complemento para las versiones 53 en adelante de Firefox, cosa que se tiene que utilizar el complemento "idmmzcc3.xpi", pero las versiones 27 de Pale Moon son compatibles con IDM utilizando el complemento "idmmzcc2.xpi", que es el complemento para utilizar en Firefox menores a la versión 53, entonces, me lleva a pensar que esta versión de Pale Moon tendría que utilizar el complemento "idmmzcc3.xpi", no entiendo muy bien esa parte, no sé si me pueden aclarar ese detalle.

De nuevo muchas gracias por responder.

User avatar
KNTRO
Astronaut
Astronaut
Posts: 624
Joined: Tue, 01 Jan 2013, 10:46
Location: Ḧïṡṗäṅöäṁéṛïċä
Contact:

Re: IDM no intregra a PM 28.0.1

Unread postby KNTRO » Tue, 11 Sep 2018, 03:06

LoneLoz wrote:las versiones 27 de Pale Moon son compatibles con IDM utilizando el complemento "idmmzcc2.xpi"


Pale Moon 28 está basado en Mozilla Firefox 52~55 —parcialmente—, sólo que no soporta algunos tipos de extensiones, como JetPack y WebExtensions, por lo que deberías usar el tipo de extensión heredada (legacy add-on). No lo puedo decir con el 100% de precisión, ya que no uso IDM, pero tengo entendido que existen 3 versiones del módulo de integración IDMcc:
  • idmmzcc.xpi: para Firefox 1.5 - 26
  • idmmzcc2.xpi: para Firefox 27 - 52
  • idmmzcc3.xpi: para Firefox 53 en adelante

Debería funcionar alguna de las 2 primeras versiones; la tercera ya sabemos que no va a funcionar.
tenpo pini la jan seme toki e mun walo li ike? ;)

LoneLoz
Newbie
Newbie
Posts: 3
Joined: Wed, 11 Oct 2017, 13:45

Re: IDM no intregra a PM 28.0.1

Unread postby LoneLoz » Wed, 12 Sep 2018, 02:40

Ahora ya comprendo un poco más sobre el desarrollo de Pale Moon, no sabía el dato de que la versión 28, fuera una especie de híbrido entre esas versiones de Firefox, ahora puedo entender un poco mejor el porque dejaron de ser compatibles algunos complementos, especialmente, el de IDM que es el que me interesa.

Bueno, estas en lo correcto, según la pagina oficial de IDM, menciona que el complemento "idmmzcc2.xpi", es el complemento que funciona con Pale Moon, incluso con la versión 28, pero al momento de probar el complemento con esta versión, el resultado es que no es compatible, creo que no hay de otra que esperar a que IDM pueda incluir entre sus complementos la compatibilidad para esta versión de Pale Moon.

Muchas gracias por tomarse el tiempo de responder mis preguntas,

User avatar
KNTRO
Astronaut
Astronaut
Posts: 624
Joined: Tue, 01 Jan 2013, 10:46
Location: Ḧïṡṗäṅöäṁéṛïċä
Contact:

Re: IDM no intregra a PM 28.0.1

Unread postby KNTRO » Wed, 12 Sep 2018, 04:38

LoneLoz wrote:creo que no hay de otra que esperar a que IDM pueda incluir entre sus complementos la compatibilidad para esta versión de Pale Moon.


No te voy a mentir, LoneLoz. Dudo MUCHÍSIMO que eso suceda. Y mi duda se basa en los comentarios que dijeron los propios desarrolladores de IDM. Ellos mismos dan a entender que no están, para nada, interesados en hacer que el complemento de integración de IDM sea compatible con Pale Moon.

LoneLoz wrote:Muchas gracias por tomarse el tiempo de responder mis preguntas


¡Todas las consultas son siempre bienvenidas! ¡Para eso estamos! :thumbup:
tenpo pini la jan seme toki e mun walo li ike? ;)


Return to “Spanish (Español)”

Who is online

Users browsing this forum: No registered users and 3 guests