Internet Archive's ‘noscript’ version breaks without scripts

For support with specific websites

Moderator: trava90

Forum rules
Please always mention the name/domain of the website in question in your topic title.
Please one website per topic thread (to help keep things organized). While behavior on different sites might at first glance seem similar, they are not necessarily caused by the same.

Please try to include any relevant output from the Toolkit Error Console or the Developer Tools Web Console using the following procedure:
  1. Clear any current output
  2. Navigate or refresh the page in question
  3. Copy and paste Errors or seemingly relevant Warnings into a single [ code ] block.
User avatar
Mæstro
Lunatic
Lunatic
Posts: 467
Joined: 2019-08-13, 00:30
Location: Casumia

Internet Archive's ‘noscript’ version breaks without scripts

Unread post by Mæstro » 2023-01-28, 16:52

I had discovered this problem while diagnosing my (since resolved) incompatibility between the Archive and WebComponents. As noted there, this problem is distinct and merits its own thread. In a new profile, if one disables JavaScript (through javascript.enabled, without any extension), then the Archive’s scriptless home page will keep reloading itself for ever, appending &noscript=true to the address’s end each time. The same happens for the lite search. These pages load normally in my ordinary profile, where I have scripts enabled.

While the Archive is still usable in Pale Moon with scripts, this newfound glitch is too egregious to let go without comment. Whatever could be happening here?

vannilla
Moon Magic practitioner
Moon Magic practitioner
Posts: 2203
Joined: 2018-05-05, 13:29

Re: Internet Archive's ‘noscript’ version breaks without scripts

Unread post by vannilla » 2023-01-28, 18:11

The irony is too amazing. I can't believe the scriptless page breaks when browsed with scripts disabled globally.
Anyway, while I can't look myself right now, can anybody see if the HTML contains a <noscript> tag with a redirect directive inside?

tpcsanh
Apollo supporter
Apollo supporter
Posts: 37
Joined: 2015-08-22, 13:45
Location: US

Re: Internet Archive's ‘noscript’ version breaks without scripts

Unread post by tpcsanh » 2023-01-28, 18:47

Following TheRealMaestro's recipe I see the same: reloading itself in a reasonably clean profile with JavaScript disabled and works in my very worn profile with scripts enabled. I am on Windows 10.

vannilla ... would this be the code you are looking for:

Code: Select all

<noscript><div class="no-js-redirect-container" data-owner="nginx"><h2>Redirecting you to a lite version of archive.org...</h2></div><meta http-equiv="refresh" data-owner="nginx" content="0; url=/?noscript=true?noscript=true"></noscript>

vannilla
Moon Magic practitioner
Moon Magic practitioner
Posts: 2203
Joined: 2018-05-05, 13:29

Re: Internet Archive's ‘noscript’ version breaks without scripts

Unread post by vannilla » 2023-01-28, 23:05

tpcsanh, that was exactly what I meant!
In particular, the <meta> tag.
It's basically generating a redirect to itself, but only when scripts are disabled, effectively generating a redirect loop.
Someone should contact the service operators and tell them to remove that redirect from the <noscript> tag and use other ways to do it, e.g. show a link to manually navigate to that page.

User avatar
adoxa
Fanatic
Fanatic
Posts: 195
Joined: 2019-03-16, 13:26

Re: Internet Archive's ‘noscript’ version breaks without scripts

Unread post by adoxa » 2023-01-29, 01:33

I've sent them an email, let's see what happens.

Xêrxe

Re: Internet Archive's ‘noscript’ version breaks without scripts

Unread post by Xêrxe » 2023-01-29, 01:47

Tested on Librewolf and the same glitch occurs. After multiple iterations, I am left with:

https://archive.org/?noscript=true?nosc ... cript=true

and no working page whatsoever.

User avatar
adoxa
Fanatic
Fanatic
Posts: 195
Joined: 2019-03-16, 13:26

Re: Internet Archive's ‘noscript’ version breaks without scripts

Unread post by adoxa » 2023-02-13, 12:32

adoxa wrote:
2023-01-29, 01:33
I've sent them an email, let's see what happens.
Nothing. :(

User avatar
adoxa
Fanatic
Fanatic
Posts: 195
Joined: 2019-03-16, 13:26

Re: Internet Archive's ‘noscript’ version breaks without scripts

Unread post by adoxa » 2023-04-16, 00:07

Just got a response (albeit not much of one), but turns out it's working now, anyway.

Locked