BitChute videos no longer display

For support with specific websites

Moderator: trava90

Forum rules
Please always mention the name/domain of the website in question in your topic title.

Please try and include any relevant output from the Toolkit Error Console or the Developer Tools Web Console using the following procedure:
  1. Clear any current output
  2. Navigate or refresh the page in question
  3. Copy and paste Errors or seemingly relevant Warnings into a single [ code ] block.
User avatar
CodeLurker
Hobby Astronomer
Hobby Astronomer
Posts: 26
Joined: 2022-02-16, 18:57

Re: BitChute videos no longer display

Unread post by CodeLurker » 2022-05-10, 03:25

I'm here rocking the final version of Basilisk (still holding out for CAA compatibility, or at least good substitutes for the CAA extensions I'm using); so most Pale Moon extensions don't work for me (yet). I tried the UBO custom filter

Code: Select all

bitchute.com^$inline-script
but it resulted in the search not working, and being unable to see comments; although the video would play. I tried toggling GreaseMonkey on and off between the Bitchute home page and the search page; and then back on to play the vid for a very short while. However, CoffeBreak's suggestion to try the GreaseMonkey script by Kris_88 at https://forum.palemoon.org/viewtopic.php?f=70&t=27596&start=20#p223975 worked. It appears to work 100%. It appears to be the case for most PM/Basilisk users that Bitchute does not work; but with that GreaseMonkey script, I strongly suspect it will. I thus suggest that that is the definitive solution. I tried to hack the given UBO rule; but couldn't figure out to make it apply to pages starting with "bitchute.com/video" but not "bitchute.com/search". It must be easy for those who are more familiar with writing rules for UBO. The GreaseMonkey script does it for me.

Now, I'll add the part that many technically adept helpers (including many at least semi-technically adept ones) shamefully forget (in sum causing many user-hours scratching one's head and searching in forums): how to use it!!! I found the easiest way was to go into GreaseMonkey, go back to the post with the script and copy it to the clipboard. Then, in the GreaseMonkey Manage User Scripts page (actually the "about:addons", in the "User Scripts section", click "New User Script", and if yer OS hasn't already cleared yer clipboard, as Windows is prone to unpredictably, click "Use Script from Clipboard".

I missed that solution myself, since there was so little response to it; but I think it will solve all such problems, if they solved mine. My problems always seem far more vexing than those of other people - not usually just for skimming over solutions, but because what I am trying to do is so technically intractable (e.g. try finding a light-weight, cross-platform way to kick off a thread in Qt, and return a class with yer results for many threads ... just try it sometime; or figure out what to do when QNetwork keeps locking up).

*** EDIT:

It looks like it may be only a temporary solution. It encodes version numbers in its source; so if BitChute changed player versions it used, it would break. The technique right now works beautifully, however - at least for me. It might be modified to use some kind of pattern matching.

KlarkKentThe3rd
Astronaut
Astronaut
Posts: 508
Joined: 2018-04-20, 20:31

Re: BitChute videos no longer display

Unread post by KlarkKentThe3rd » 2022-08-26, 07:25

Small question. Is it currently possible to make BitChute work again, or is the solving of the problem something on their end?

User avatar
Kris_88
Lunatic
Lunatic
Posts: 348
Joined: 2021-01-26, 11:18

Re: BitChute videos no longer display

Unread post by Kris_88 » 2022-08-26, 08:23

GreaseMonkey script:

Code: Select all

// ==UserScript==
// @name        bitchute
// @namespace   btc1
// @include     https://www.bitchute.com/*
// @run-at document-start
// @version     1
// @grant       none
// ==/UserScript==

if(window.location.hostname == 'www.bitchute.com') {

  document.addEventListener("beforescriptexecute", function(e) {
    var s;

    if(e.target.src == 'https://cdn.jsdelivr.net/npm/p2p-media-loader-core@latest/build/p2p-media-loader-core.min.js') {
      e.preventDefault();
      e.stopPropagation();
      // skip p2p-media-loader-core.min.js
    };


    if(e.target.src.indexOf('/js/common.js') >=0  &&
       e.target.src.indexOf('www.bitchute.com/static/') >=0 ) {

      e.preventDefault();
      e.stopPropagation();

      // patch common.js
      var xhr = new XMLHttpRequest();
      xhr.open("GET", e.target.src, false);
      xhr.send(null);
      if(xhr.status === 200) {
        s = document.createElement('script');
        s.type = 'text/javascript';
        s.innerHTML = xhr.responseText.replace('catch{}', 'catch(e) {}');
        s.async = false;
        e.target.parentNode.insertBefore(s, e.target.nextSibling);
      };
    };


    if(e.target.src.indexOf('/plyr.polyfilled.min.js') >= 0 &&
       e.target.src.indexOf('/plyr/3.3.9/plyr.polyfilled.min.js') < 0) {

      e.preventDefault();
      e.stopPropagation();

      // replace plyr.polyfilled.min.js
      s = document.createElement('script');
      s.type = 'text/javascript';
      s.src = 'https://cdnjs.cloudflare.com/ajax/libs/plyr/3.3.9/plyr.polyfilled.min.js';
      s.async = false;
      e.target.parentNode.insertBefore(s, e.target.nextSibling);

      // replace plyr.min.css
      var lnk = document.getElementsByTagName("link");
      for(var l of lnk) {
        if(l.href.indexOf('/plyr.min.css') >= 0)
          l.href='https://cdnjs.cloudflare.com/ajax/libs/plyr/3.3.9/plyr.css';
      };
    };

  }, true);

};

KlarkKentThe3rd
Astronaut
Astronaut
Posts: 508
Joined: 2018-04-20, 20:31

Re: BitChute videos no longer display

Unread post by KlarkKentThe3rd » 2022-08-26, 08:42

Why thank you, mysterious stranger, that does fix everything!

Not a native solution, and not Bitchute Support actually lifting a finger, but it is A solution.

User avatar
dtoxic
Moonbather
Moonbather
Posts: 73
Joined: 2017-10-04, 00:14
Location: Tau Ceti

Re: BitChute videos no longer display

Unread post by dtoxic » 2022-09-24, 16:05

@Kris_88 thank you kind stranger for the bitchute fix
Windows 7 SP1 X64
Windows 10 LTSC X64

User avatar
gepus
Keeps coming back
Keeps coming back
Posts: 820
Joined: 2017-12-14, 12:59

Re: BitChute videos no longer display

Unread post by gepus » 2022-09-24, 17:20

Hmm. Tested now with Waterfox Classic (based AFAIK on Firefox 56) and so far all videos I click are playing.

User avatar
CodeLurker
Hobby Astronomer
Hobby Astronomer
Posts: 26
Joined: 2022-02-16, 18:57

Re: BitChute videos no longer display

Unread post by CodeLurker » 2022-10-01, 13:39

The GreaseMonkey script was working for me for a while, but it looks like they broke it again.

User avatar
Kris_88
Lunatic
Lunatic
Posts: 348
Joined: 2021-01-26, 11:18

Re: BitChute videos no longer display

Unread post by Kris_88 » 2022-10-01, 18:03

Works fine for me.
p1.jpg

User avatar
CodeLurker
Hobby Astronomer
Hobby Astronomer
Posts: 26
Joined: 2022-02-16, 18:57

Re: BitChute videos no longer display

Unread post by CodeLurker » 2022-10-01, 18:57

Code: Select all

https://www.bitchute.com/search/?query=test
gives me

Code: Select all

13:45:31.947 SyntaxError: invalid regexp group 1 plyr.polyfilled.min.js:1:104691
Yep. A regex. Some CloudFlare stuff. The URL is cdnjs.cloudflare.com/ajax/libs/plyr/3.6.9/plyr.polyfilled.min.js.

That's on the search. Same error when I try to play. Same stuff that old Greasmonkey script that got it working temporarily was tweaking, different version.

Here's the offending method:

Code: Select all

.match(/^.*(?:vimeo.com\/|video\/)(?:\d+)(?:\?.*&*h=|\/)+(?<hash>[\d,a-f]+)/)
Perhaps the Windows Regex libs are a little different, or some compiler optimization bug? Maybe this will help someone more familiar with it.
Last edited by CodeLurker on 2022-10-01, 19:13, edited 1 time in total.

User avatar
Kris_88
Lunatic
Lunatic
Posts: 348
Joined: 2021-01-26, 11:18

Re: BitChute videos no longer display

Unread post by Kris_88 » 2022-10-01, 19:11

I am using the script from this post:
viewtopic.php?f=70&t=27596&p=232526#p231569
p2.jpg

User avatar
CodeLurker
Hobby Astronomer
Hobby Astronomer
Posts: 26
Joined: 2022-02-16, 18:57

Re: BitChute videos no longer display

Unread post by CodeLurker » 2022-10-01, 19:18

Yep. That's the one that used to work for me, but stopped working. Changing the occurrences of

Code: Select all

/plyr/3.3.9/plyr.polyfilled.min.js
to 3.6.9 or leaving it unchanged didn't fix it for me.

User avatar
Kris_88
Lunatic
Lunatic
Posts: 348
Joined: 2021-01-26, 11:18

Re: BitChute videos no longer display

Unread post by Kris_88 » 2022-10-01, 19:26

Check that the script is enabled:
p3.jpg

User avatar
CodeLurker
Hobby Astronomer
Hobby Astronomer
Posts: 26
Joined: 2022-02-16, 18:57

Re: BitChute videos no longer display

Unread post by CodeLurker » 2022-10-01, 19:36

My PMPlayer says "No video on page, or window already open." when hovering on the button on the toolbar; even when at the URL of the vid. It's enabled. I suspect it needs to be fixed at the Win Regex lib. level, or an issue report to CloudFlare, not a GreaseMonkey hack; although I'm open-minded on it.
Last edited by CodeLurker on 2022-10-01, 20:09, edited 1 time in total.

User avatar
Kris_88
Lunatic
Lunatic
Posts: 348
Joined: 2021-01-26, 11:18

Re: BitChute videos no longer display

Unread post by Kris_88 » 2022-10-01, 19:42

I do not use PMPlayer. This script is for the www.bitchute.com site.

User avatar
Kris_88
Lunatic
Lunatic
Posts: 348
Joined: 2021-01-26, 11:18

Re: BitChute videos no longer display

Unread post by Kris_88 » 2022-10-01, 20:49

CodeLurker wrote:
2022-10-01, 19:36
I suspect it needs to be fixed at the Win Regex lib. level, or an issue report to CloudFlare, not a GreaseMonkey hack;
Apparently, the script does not work for you for this reason...

User avatar
CodeLurker
Hobby Astronomer
Hobby Astronomer
Posts: 26
Joined: 2022-02-16, 18:57

Re: BitChute videos no longer display

Unread post by CodeLurker » 2022-10-05, 20:44

They got it working now in PM 31.2.0.1 on Win7 SP1 x64; without a special GreaseMonkey script. This should also fix a lot of other sites that use CloudFlare (far too many, IMHO, as it intentionally breaks tons of sites for TorBrowser - i.e. every site that uses it). This issue appears to only apply to Windows builds. This is surely a big milestone for PM. Great job, guys1

User avatar
CodeLurker
Hobby Astronomer
Hobby Astronomer
Posts: 26
Joined: 2022-02-16, 18:57

Re: BitChute videos no longer display

Unread post by CodeLurker » 2022-10-07, 03:35

Nope. Somehow I thought it was working, but I got the same regex error at the same point again. However, it was working, then apparently wasn't working, and now does work again. I don't know if I failed to refresh while testing, and was mistaken; but from my experience, it seems that the above GreaseMonkey script was working, stopped working, then PM didn't need it after an update, and now it only works with the script again. Maybe something's changing at CloudFlare to break it and unbreak it; but the above RegEx is still erroring out on Windows.

Post Reply