nvenergy.com suddenly stops working

For support with specific websites

Moderator: trava90

Forum rules
Please always mention the name/domain of the website in question in your topic title.

Please try and include any relevant output from the Toolkit Error Console or the Developer Tools Web Console using the following procedure:
  1. Clear any current output
  2. Navigate or refresh the page in question
  3. Copy and paste Errors or seemingly relevant Warnings into a single [ code ] block.
User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 4041
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

nvenergy.com suddenly stops working

Unread post by Pallid Planetoid » 2022-10-05, 01:19

URL: https://www.nvenergy.com/generic-login (login for Nevada Energy).

Also tested in "Safe-Mode". Apparently they've made a change that now breaks specific to Pale Moon (works on all other browsers tested, i.e. FF, Vivaldi etc.) that has been otherwise working for the past 6+ years that I'm aware of.

Renders this far (show screen-shot) before then going to blank page:
Blank page displays immediately subsequent to what you see here
Blank page displays immediately subsequent to what you see here
Error Console:

Code: Select all

Timestamp: 10/4/2022 7:21:20 AM
Error: TypeError: document.getElementById(...) is null
Source File: chrome://butwhymod/content/browser.js
Line: 28
Timestamp: 10/4/2022 7:21:21 AM
Error: TypeError: document.getElementById(...) is null
Source File: chrome://butwhymod/content/browser.js
Line: 28
Timestamp: 10/4/2022 7:21:22 AM
Error: XML Parsing Error: no root element found
Location: https://login.nvenergy.com/bheb2c.onmicrosoft.com/B2C_1A_NVE_CDX_SI/client/perftrace?tx=StateProperties=eyJUSUQiOiI1OWRhOTE3MS0wYWM3LTQ3MzYtYWVkOC02OGZkOGNjOWQ3ZjUifQ&p=B2C_1A_NVE_CDX_SI
Line Number 1, Column 1:
Source File: https://login.nvenergy.com/bheb2c.onmicrosoft.com/B2C_1A_NVE_CDX_SI/client/perftrace?tx=StateProperties=eyJUSUQiOiI1OWRhOTE3MS0wYWM3LTQ3MzYtYWVkOC02OGZkOGNjOWQ3ZjUifQ&p=B2C_1A_NVE_CDX_SI
Line: 1
Timestamp: 10/4/2022 7:21:22 AM
Error: TypeError: s is undefined
Source File: https://nvecdxcsaprod.blob.core.windows.net/files/js/unified/unified.b772ac25495a08f5320c.js
Line: 2
Presumably the 3rd error in succession "XML Parsing Error: no root element found" is likely the problem - can this be fixed in Pale Moon so web site will thankfully once again work?
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

User avatar
moonbat
Knows the dark side
Knows the dark side
Posts: 4159
Joined: 2015-12-09, 15:45
Contact:

Re: nvenergy.com suddenly stops working

Unread post by moonbat » 2022-10-05, 01:56

XML parsing error sounds like a problem with the website code, if they're serving invalid XML. Pale Moon gets criticized (not by you, not here) for actually enforcing standards so I won't be surprised if ChromeZilla browsers just let it slide as they do with many other things.
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Image
Linux Mint 21 Xfce x64 on HP i5-5200 laptop, 12 GB RAM.
AutoPageColor|PermissionsPlus|PMPlayer|Pure URL|RecordRewind|TextFX

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 33006
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: nvenergy.com suddenly stops working

Unread post by Moonchild » 2022-10-05, 13:20

"No root element found" normally means that the server spits something out that isn't XML.
This is regularly caused by overzealous "security" (mind the quotes) measures that block "unknown browsers". Considering they flat-out drop connections from outside the USA (possibly even outside NV alone), not even returning an error page, it seems to me the overwhelmingly likely cause.

Regardless of the exact cause, this isn't a Pale Moon error but rather an error of NVEnergy. If possible, contact their web support department letting them know you can't log in, and quote them the error:

Code: Select all

Error: XML Parsing Error: no root element found
Location: https://login.nvenergy.com/bheb2c.onmicrosoft.com/B2C_1A_NVE_CDX_SI/client/perftrace?tx=StateProperties=eyJUSUQiOiI1OWRhOTE3MS0wYWM3LTQ3MzYtYWVkOC02OGZkOGNjOWQ3ZjUifQ&p=B2C_1A_NVE_CDX_SI
"The best revenge is to not be like the person who wronged you." -- Marcus Aurelius
"Seek wisdom, not knowledge. Knowledge is of the past; wisdom is of the future." -- Native American proverb

User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 4041
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

Re: nvenergy.com suddenly stops working

Unread post by Pallid Planetoid » 2022-10-05, 17:15

^ Done - will report back any development (and thanks for the feedback :thumbup:)
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 4041
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

Re: nvenergy.com suddenly stops working

Unread post by Pallid Planetoid » 2022-10-13, 01:01

^ It's been a week - website login still produces blank screen as before on Pale Moon and no response from NVEnergy. (gave them all the info regarding their website problem as previously referenced by Moonchild). Note: to test for this, one does not need to login (have an account) in as much as the login page fails to render as previously described (Login URL: https://www.nvenergy.com/generic-login).

I told them I would not use their website until this gets fixed - apparently they could care less! :thumbdown: (added that because of this login issue my payments will be dependent upon their statements successfully reaching me by mail...).

Unhappily this website will have to join the number of other websites that ultimately require another browser. :( (I'm sorry to say!)
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 4780
Joined: 2011-10-03, 10:19
Location: Piney Woods of Southeast Texas, USA

Re: nvenergy.com suddenly stops working

Unread post by Night Wing » 2022-10-13, 01:43

@ Pallid Planetoid

After clicking on the link you provide, thank you for that, I too got a blank white screen.

But, after disabling uBlock Origin 1.16.4.30, refreshing the page and then the page rendered properly asking for a username and password.

At this time, I'm using 64 bit linux Pale Moon 31.3.0.1 running in 64 bit linux Mint 21 (Vanessa) Xfce. Also, I am using the lightweight theme, Moonscape.
Linux Mint 21 (Vanessa) Xfce With Linux Pale Moon, Linux Waterfox, Linux Firefox
MX Linux 21.2.1 (Wildflower) Xfce With Linux Pale Moon, Linux Waterfox, Linux Firefox

User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 4041
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

Re: nvenergy.com suddenly stops working

Unread post by Pallid Planetoid » 2022-10-13, 03:24

Thanks for the rather interesting feedback....

And I would add, very odd - in as much as I have previously tested with UbO totally disabled - and continued to get the same failed login (blank screen).

I have also previously test in "Safe-Mode" - so no add-ons are involved and still get the same result.

I'm posting this (test) right now in "Safe-Mode" actually (so UbO could not be a factor) and based on what you're reporting one would assume I'd get similar results, but not so oddly enough - same blank-screen is what I get as before (see screen-shot example below).

Screen-shot example:
As always I get a partial login page starting as it starts to load only to end up with the blank-page as seen here.
As always I get a partial login page starting as it starts to load only to end up with the blank-page as seen here.
So then are we to conclude that the page only works on 64 bit linux Pale Moon 31.3.0.1? (that would be an unexpected outcome).
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 4041
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

Re: nvenergy.com suddenly stops working

Unread post by Pallid Planetoid » 2022-10-13, 07:25

Update to my post above: because you (Night Wing) had mentioned you "refreshed the page" and then the login worked (w UbO disabled)....

So thinking that I had not actually tried disabling UbO and then refreshing the page after it failed to work w/ UbO not disabled - I attempted to load the login page to try this....

.... and lo-and-behold the Login Page worked w/out any issues and that is with Ub0 not disabled (as I had not gotten to the point of disabling the add-on yet).

No I'm wondering two things:
1) Why is the login now working after all this time?
2) How long will the login page continue to work?

I'm going to load the page once again to see if this good fortune is at least for the time being persistent.

Nope - back to where we were....

Here's what has transpired.
#1 login unexpectedly rendered correctly out-of-the-blue using the login URL (referenced in this topic):
Worked unconditionally (notice UbO extension not disabled)
Worked unconditionally (notice UbO extension not disabled)
#2 - Tried the same Login URL again - back to where we were (so I'll try what reportedly worked; disable UbO and refresh page with results displayed below):
PIC-2  back to not working.png
#3 - With a disabled UbO (notice this pointed out) I then "refreshed" page after login had failed (in #2) but in my case the issue persists with a blank page:
PIC-3 refresh w-ubo disabled - STILL BLANK PAGE.png
So I've just now managed to observe JUST ONE successful login page out of probably 10-15 attempts over the period of time this topic was started.

Any ideas on why under the same exact conditions (as you can see the conditions between test #1 and test #2 were exactly the same) the login would work ONCE and then w/out changing anything go back to not working again? :crazy: (logic would suggest if a webpage does actually work randomly then there should be a way to get the webpage to work consistently)
Last edited by Pallid Planetoid on 2022-10-13, 08:22, edited 1 time in total.
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 4041
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

Re: nvenergy.com suddenly stops working

Unread post by Pallid Planetoid » 2022-10-13, 08:07

I copied the resultant login URL that worked:

https://login.nvenergy.com/bheb2c.onmicrosoft.com/oauth2/v2.0/authorize?p=b2c_1a_nve_cdx_si&prompt=login&client_id=168f31a8-7818-4588-befa-61d8c2489447&redirect_uri=https%3A%2F%2Fwww.nvenergy.com%2Flogin&nonce=a%7E.vrWtXynOcy2UUx.n3&state=a%7E.vrWtXynOcy2UUx.n3&scope=openid+offline_access+168f31a8-7818-4588-befa-61d8c2489447&code_challenge_method=S256&code_challenge=V6SlgSBDMfyyUeadXcKDGcZpIE_qTYBLjKHHhLNNtLw&response_type=code

Using this (past into address bar) does not work in Pale Moon- however it is the URL that did ONE TIME display a successful login page (subsequent from redirect(s) from the login URL: https://www.nvenergy.com/generic-login.

However the URL (or variations thereof) DO consistently ALL WORK IN Firefox everytime!

Notice the highlighted parts of the resultant URL (after redirect(s))-- which as mentioned above is reached as a result of redirect(s) from the URL (https://www.nvenergy.com/generic-login) the company provides to their customers.

Notice: bheb2c.onmicrosoft.com, redirect_uri=https%3A%2F%2Fwww.nvenergy.com, code_challenge= ------ my guess is the "onmicrosoft.com" part of the URL (Pale Moon has chronic issues with MS related websites) and/or the "redirect" and/or the "challenge" (parts of the URL) are either in-part or all of the problem with the page failing to load in Pale Moon.
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

Blacklab
Keeps coming back
Keeps coming back
Posts: 916
Joined: 2012-06-08, 12:14

Re: nvenergy.com suddenly stops working

Unread post by Blacklab » 2022-10-13, 10:49

Hi Pallid Planetoid :) Just FYI - Late yesterday I tested your original NV Energy (NVE) login page link above (Login URL: https://www.nvenergy.com/generic-login).

On a clean Pale Moon profile I could (at first) successfully get to the proper NVE login page asking for a username and password. During page load the NVE website required me to 'Share Location' (dropdown options box from Pale Moon's 'Permissions Manager'). Without my location shared no go... NVE login failed to the blank white page. I noted that NVE wants/needs to load a Google maps script.

I then tried the NVE login link using my normal Pale Moon profile and succeeded again. :thumbup: So far so good. :)

Sadly, as you have found, this isn't at all 'repeatable' or consistent. :thumbdown: :thumbdown: Successive login attempts all end up in failure at NVE's blank white page with NVE's login page url showing various 'server errors'. Tried clearing cache and cookies didn't help, neutering uBO didn't either.
Last edited by Blacklab on 2022-10-13, 10:52, edited 1 time in total.

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 4780
Joined: 2011-10-03, 10:19
Location: Piney Woods of Southeast Texas, USA

Re: nvenergy.com suddenly stops working

Unread post by Night Wing » 2022-10-13, 10:51

@ Pallid Planetoid

I'm sure you have heard of the old adage which says: "A picture is worth a thousands words". I will get to that. Keep in mind that I still have uBlock Origin disabled for the Nvenergy site.

After clicking on both of the links in your last post in this thread, the page briefly rendered properly for less than one second of time before it went to a completely blank white colored screen.

I then refreshed the page and the login page came back and rendered properly. I tried this multiple times with the same result. So I have come to conclusion that the web maintainer or maintainers by committee................"do not know how to code properly" because they are most likely coding for Chrome (and it's ilk), Microsoft Edge, Safari and Firefox. These four browsers is all they care about.

Now for the three pictures you posted showing the page rendered properly one time and then the two other pictures where you got the white colored screen.

I noticed in the page where it rendered properly, you have the UBO (uBlock Origin) icon and the ABL (Ablock Latitude) icon if the ABL icon is Adblock Latitude. If I'm correct, why do you have both of those extensions installed?

In my opinion, I do not think it is wise to have both of those extensions installed. I think they could somehow cause a conflict for that Nvenergy site since that page is "not" geared to render properly for Pale Moon. Like having two antivirus programs installed and causing conflict for each other when running a Windows operating system.

I have UBO installed, but I do "not" have ABL installed. Maybe this is why I can get the Nvenergy page to render properly just by refreshing the page after I get the white colored page. Because in all instances, I can get to the login page "everytime" just by refreshing the page.

If you get the white colored page, then refreshing the page and you still get the white colored page, then having both UBO and ABL installed might be the problem why I can get to the login page after refreshing the page and you can not.
Linux Mint 21 (Vanessa) Xfce With Linux Pale Moon, Linux Waterfox, Linux Firefox
MX Linux 21.2.1 (Wildflower) Xfce With Linux Pale Moon, Linux Waterfox, Linux Firefox

User avatar
gepus
Keeps coming back
Keeps coming back
Posts: 822
Joined: 2017-12-14, 12:59

Re: nvenergy.com suddenly stops working

Unread post by gepus » 2022-10-13, 14:27

I get the login page after refreshing the white page. Sometimes don't even need to refresh.
Tested several times and uBO is active.
Attachments
nvenergy.png

User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 4041
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

Re: nvenergy.com suddenly stops working

Unread post by Pallid Planetoid » 2022-10-13, 15:16

Thanks for all the feedback :thumbup: - I've tried everything (as previously posted) including using "safe-mode" with/out any add-ons - out of double-digit attempts I've had one break-through successful load of the page (and this one break-through successful page load was with all add-ons ENABLED).

Screen-shot below with both add-ons discussed disabled (as previously reported):
The only time the page loaded (one time out of many attempts) is WHEN ALL ADD-ONS WERE ENABLED!
The only time the page loaded (one time out of many attempts) is WHEN ALL ADD-ONS WERE ENABLED!
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 4041
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

Re: nvenergy.com suddenly stops working

Unread post by Pallid Planetoid » 2022-10-13, 15:52

For the record, (side note):
Off-topic:
Aside from a few (small list of) "Custom Filters" (i.e. "Element Hiding Rules and "Exception Rules") - I use ABL for only two filters; "Lunar Blocklist" and "Adblock Warning Removal" and that's it. However as reported disabling ABL makes no difference (in fact the one successful page load occurred with ABL enabled).
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

User avatar
Pallid Planetoid
Knows the dark side
Knows the dark side
Posts: 4041
Joined: 2015-10-06, 16:59
Location: Los Angeles CA USA

Re: nvenergy.com suddenly stops working

Unread post by Pallid Planetoid » 2022-10-17, 15:14

I tried logging in again today to see if there's any improvement - first attempt, the page redirect resulted in a blank page - on a whim, tried again and the redirect was successful as the login worked.

Curious what the rate of getting a successful login on Pale Moon (100% success on other browsers) - based on a (small sample) test of 10 attempts the result in this case was 40% successful logins (4 out of 10 attempts).

So then this begs the question - what is the reason for a 40% login success rate? (something gets done correctly some of the time)

Bottom line test (w/ uBo and ABL both disabled for the website): Pale Moon managed to successfully navigate the login page redirect 40% of the time as contrasted to 60% that end up with a blank page presumably because the page failed to navigate the redirect in these cases. Enabling both add-ons led to a 30% success rate (I would surmise that the add-ons probably make no difference overall and that a more robust test would likely be very close to the same either way. My guess is that an optimistic login success rate would likely work-out to around a third of the time, in any event, the more attempts that are included in a test).

Additional testing:
1) With add-ons (Ubo/ABL) enabled 10% success rate for another test of 10 logins.
2) With add-ons (UbO/ABL) disabled for both nvenergy.com and the login.nvenergy.com (redirect) I got a 60% rate of success (for 10 logins. Note: I hadn't previously tried disabling for both the original and redirect).
2b) Same #2 test above repeated again resulted in only a 10% success rate - so I'm unable to observe any consistency as far as logging into the site as well using the add-ons or not.
Current Pale Moon(x86) Release | WIN10 | I5 CPU, 1.7 GHz, 6GB RAM, 500GB HD[20GB SSD]
Formerly user Pale Moon Rising - to provide context involving embedded reply threads.
Good judgment comes from experience and a lot of that comes from bad judgment. - Will Rogers
Knowing Pale Moon is indisputably #1 is defined by knowing the totality of browsers. - Pale Moon Rising

Post Reply