proxmox page blank on local server

For support with specific websites

Moderator: trava90

Forum rules
Please always mention the name/domain of the website in question in your topic title.

Please try and include any relevant output from the Toolkit Error Console or the Developer Tools Web Console using the following procedure:
  1. Clear any current output
  2. Navigate or refresh the page in question
  3. Copy and paste Errors or seemingly relevant Warnings into a single [ code ] block.
User avatar
martini2
New to the forum
New to the forum
Posts: 1
Joined: 2022-04-13, 14:40

proxmox page blank on local server

Unread post by martini2 » 2022-04-13, 16:15

Hello,
this isue has been posted before, but i can not find a solution.

Since a few weeks pale moon shows a blank page when opening the proxmox page on my server. This is happening on all computers i use (8). No matter if in safemode or with a new profile.
Palemoon is my default browser for years and this never happened before. All the time i try to keep palemoon and proxmox up to date and the page renders fine in firefox or edge so i don't know if it is a proxmox issue or a palemoon issue. I have allready reinstalled the packages responsible for rendering the web gui on the proxmox server, but this did not help.
I also tested palemoon versions 2.2.x and 2.3.x with the same negative result. How do i fix this?

Code: Select all

SyntaxError: expected expression, got '.'[Learn More]  																proxmoxlib.js:10199:34
SyntaxError: expected expression, got '.'[Learn More]  																pvemanagerlib.js:5350:39
Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help http://xhr.spec.whatwg.org/  	ext-all.js:22:15691
XML Parsing Error: no root element found																	StdWorkspace.js:1:1
Location: https://192.168.123.2:8006/PVE/StdWorkspace.js?_dc=1649865815030
Line Number 1, Column 1:  
TypeError: c is not a constructor[Learn More]																	ext-all.js:2:8
	anonymous 																				https://192.168.123.2:8006/pve2/ext6/ext-all.js:2:8
	create																					https://192.168.123.2:8006/pve2/ext6/ext-all.js:22:115977
	<anonymous> 																				https://192.168.123.2:8006/:39:30
	invoke																					https://192.168.123.2:8006/pve2/ext6/ext-all.js:22:143796
	doInvokeAll 																				https://192.168.123.2:8006/pve2/ext6/ext-all.js:22:144170
	invokeAll 																				https://192.168.123.2:8006/pve2/ext6/ext-all.js:22:143912
	handleReady 																				https://192.168.123.2:8006/pve2/ext6/ext-all.js:22:143488
	handleReadySoon/a.timer< 																		https://192.168.123.2:8006/pve2/ext6/ext-all.js:22:143630
	elevate 																				https://192.168.123.2:8006/pve2/ext6/ext-all.js:22:31445
	c 																					https://192.168.123.2:8006/pve2/ext6/ext-all.js:22:64426

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 32195
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: proxmox page blank on local server

Unread post by Moonchild » 2022-04-13, 21:47

It's an interoperability issue between Pale Moon and the latest version of proxmox, because they decided to use a JS/DOM feature (optional chaining) in their administration interface we currently don't support. A workaround would be to use an older version of proxmox that doesn't use this feature, and perhaps ask the proxmox devs to not use the feature in their management UI.
"You will observe with concern how long a useful truth may be known and exist before it is generally received and practiced on." -- Benjamin Franklin
"Compromise and collaboration lie at the heart of all great endeavours" -- Kassandra
Image

User avatar
redyoshi49q
Moongazer
Moongazer
Posts: 7
Joined: 2020-10-12, 22:07

Re: proxmox page blank on local server

Unread post by redyoshi49q » 2022-05-20, 23:22

There was a period of time after the Pale Moon v31 update where Proxmox's web interface worked from within Pale Moon for me. However, after updating the packages of Proxmox, Proxmox's web portal once again renders as a blank page for me; the first two generated errors were:

Code: Select all

SyntaxError: expected expression, got '?'[Learn More]  
proxmoxlib.js:12495:60
SyntaxError: expected expression, got '?'[Learn More]  
pvemanagerlib.js:2346:22
Clicking on the .js files linked here led to Javascript lines containing "??", which is apparently called the "nullish coalescing operator" (and is presumably not yet supported by Pale Moon's Javascript engine). With that said, versions of Proxmox that predate that project's use of the ?? operator should work with the most recent Pale Moon version due to Pale Moon v31's new support of the .? optional chaining operator (which both current and slightly older versions of Proxmox require support for).

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 32195
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: proxmox page blank on local server

Unread post by Moonchild » 2022-05-20, 23:30

Fix one thing and the devs break another chasing shinies.

FTR, we should have the nullish coalescing operator soon as well thanks to the fantastic work FranklinDM has put into getting both .? and ?? implemented (they are somewhat related from a code perspective).
Of course if proxmox devs keep chasing Chrome for their web interface then it may actually break harder with something we can't easily address. So I hope they will stop doing so.
"You will observe with concern how long a useful truth may be known and exist before it is generally received and practiced on." -- Benjamin Franklin
"Compromise and collaboration lie at the heart of all great endeavours" -- Kassandra
Image

User avatar
redyoshi49q
Moongazer
Moongazer
Posts: 7
Joined: 2020-10-12, 22:07

Re: proxmox page blank on local server

Unread post by redyoshi49q » 2022-06-19, 06:16

I am happy to report that the errors relating to the ?? operator no longer appear in the Javascript console log for a Proxmox tab in Pale Moon. ...I am less happy to report that the web GUI of a fully updated Proxmox install still produces a blank screen in Pale Moon (the first error is "SyntaxError: expected expression, got '=' pvemanagerlib.js:15620:30", and the line of code indicated by that error is "allStoragesAvailable &&= !!match[3] && !!PVE.data.ResourceStore.getById("; I'm inclined to suspect that the &&= operator is what produced the error). As before, the use of Firefox functions as a workaround.

On the Proxmox side of things, the digging that I did a few days ago suggests that the pve-manager, proxmox-widget-toolkit, and/or (with less likelihood, on account of older versions seemingly being unavailable in the repositiories) libjs-extjs packages in Proxmox would need to be downgraded and pinned to an earlier version to revert a Proxmox install to a version of the web GUI that didn't yet introduce compatibility issues with Pale Moon. With that said, trying to downgrade pve-manager in particular seems to require some extra work to make happen (recent pve-manager versions seem to depend on a package that's marked as breaking older versions of the pve-manager package), and I wasn't able to get that figured out during the time I spent trying to figure that out (I might come back to working on that later).

User avatar
FranklinDM
Add-ons Team
Add-ons Team
Posts: 389
Joined: 2017-01-14, 02:40
Location: Manila, Philippines
Contact:

Re: proxmox page blank on local server

Unread post by FranklinDM » 2022-06-19, 15:50

More syntactic sugar that we don't have support for yet: logical AND assignment operator.

Post Reply