Slow loading in YouTube/Reddit

For support with specific websites

Moderator: trava90

Forum rules
Please always mention the name/domain of the website in question in your topic title.

Please try and include any relevant output from the Toolkit Error Console or the Developer Tools Web Console using the following procedure:
  1. Clear any current output
  2. Navigate or refresh the page in question
  3. Copy and paste Errors or seemingly relevant Warnings into a single [ code ] block.
User avatar
SanAequitas
Moongazer
Moongazer
Posts: 12
Joined: 2019-01-16, 22:19

Slow loading in YouTube/Reddit

Unread post by SanAequitas » 2022-01-15, 06:31

So, currently on 29.4.2 (64bit) Pale Moon, Win 10, no fancy network or anything. Frontier fiber, 100(250?)Mbit up/down. Default themes, only addons running are Adblock Latitude, GreaseMonkey, Javascript Toggler. I do have a lot of tabs, but the majority of them aren't active or running anything.

For some reason, Youtube and Reddit pages take an extremely long time to load, compared to other sites. Clicking a link from a forum to Youtube always takes several seconds, and sometimes puts Pale Moon into a 'not responding' state for 5-10 seconds until the page loads. Other sites are plenty quick, no issues. Closing/re-opening PM seems to sometimes help them load faster, but not that much.

I've had this problem through at least 2-3 PM updates, so it wasn't a current sudden change in something. Is there a reason this happens, or is something in my settings likely not quite right?

KlarkKentThe3rd
Astronaut
Astronaut
Posts: 501
Joined: 2018-04-20, 20:31

Re: Slow loading in YouTube/Reddit

Unread post by KlarkKentThe3rd » 2022-01-15, 07:45

Slow loading on YT has been a thing for me for a very long time, definitely not new.

ReyZie93
Moongazer
Moongazer
Posts: 14
Joined: 2017-02-25, 19:40

Re: Slow loading in YouTube/Reddit

Unread post by ReyZie93 » 2022-01-15, 07:53

Yeah, I have the same behavior. Every time I open YouTube with my Pale Moon, it hangs (Not responding) for about 5-10 sec.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 31918
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Slow loading in YouTube/Reddit

Unread post by Moonchild » 2022-01-15, 10:15

This is known and there's really not much we can do about it on our end. YouTube's code used to be a lot better, even when using polymer fallback code, but at some point this long delay was introduced which only seems to happen once when loading the site. Feel free to speculate if this is deliberate or not. It's been reported and Google chooses to not respond and not do anything about.
Reddit is likely having a similar problem where scripting is just making things slow on not-Chrome.

Since it's impossible to analyse multi-megabytes of minified/obfuscated JavaScript code, there is no information what exactly is causing these delays or why. It's not something inherent to our engine itself since other sites are just fine even if very heavy on the scripting. It has to be something very specific.
"You will observe with concern how long a useful truth may be known and exist before it is generally received and practiced on." -- Benjamin Franklin
"Compromise and collaboration lie at the heart of all great endeavours" -- Kassandra
Image

User avatar
SanAequitas
Moongazer
Moongazer
Posts: 12
Joined: 2019-01-16, 22:19

Re: Slow loading in YouTube/Reddit

Unread post by SanAequitas » 2022-01-15, 16:13

Well damn.

I figured it was a YouTube issue, but then hit Reddit for some question/answer stuff, and that site was slow as well, even though there's nothing major it needs to load that I can tell. Was really hoping this was just a PM setting issue. Oh well. But it's not a first time opening for me - every single new tab has the long hang, and clicking page-to-page in the same tab doesn't usually hang up, but still takes a while to load.

Blacklab
Keeps coming back
Keeps coming back
Posts: 822
Joined: 2012-06-08, 12:14

Re: Slow loading in YouTube/Reddit

Unread post by Blacklab » 2022-01-15, 17:13

Perhaps try some of the alternative 'lightweight' front-ends for Twitter... I've been using Nitter for a while. :)

Lots of comment online... e.g. basic searches like: 'alternative front-end Twitter'... or more specific recommendation sites e.g: https://greycoder.com/nitter-a-lightwei ... o-twitter/

There's a similar sprinkling of alternative front-ends for YT... but I've found them to be less successful... Google fighting back no doubt.

User avatar
SanAequitas
Moongazer
Moongazer
Posts: 12
Joined: 2019-01-16, 22:19

Re: Slow loading in YouTube/Reddit

Unread post by SanAequitas » 2022-01-15, 18:13

Blacklab wrote:
2022-01-15, 17:13
Perhaps try some of the alternative 'lightweight' front-ends for Twitter... I've been using Nitter for a while. :)
...
There's a similar sprinkling of alternative front-ends for YT... but I've found them to be less successful... Google fighting back no doubt.
That could work, except I'm not on Twitter so I don't even know if that site has the same issues. YouTube is the main one for me, then Reddit is the occasional one, it seems to be a good source for answering troubleshooting questions for a lot of stuff nowadays. None of the other sites I regularly visit have had this problem noticeably.

User avatar
MoonWalker
Hobby Astronomer
Hobby Astronomer
Posts: 27
Joined: 2020-10-13, 15:38

Re: Slow loading in YouTube/Reddit

Unread post by MoonWalker » 2022-01-15, 18:18

A workaround for Reddit is to open each link (whether is comment or hyperlink) in a new tab. The new tab loads correctly.

I gained rendering speed by modifying layers.acceleration.force. I have had no problem at this day, but in theory is someway not secure (reason why is disabled by default).

User avatar
SanAequitas
Moongazer
Moongazer
Posts: 12
Joined: 2019-01-16, 22:19

Re: Slow loading in YouTube/Reddit

Unread post by SanAequitas » 2022-01-15, 18:21

A workaround for Reddit is to open each link (whether is comment or hyperlink) in a new tab. The new tab loads correctly.


Hmm I'll definitely have to try that. I sometimes have issues to where everything in the page loads, but it won't open anything when I try to comment/reply to someone. Hafta switch browsers sometimes just to make a reply..

Blacklab
Keeps coming back
Keeps coming back
Posts: 822
Joined: 2012-06-08, 12:14

Re: Slow loading in YouTube/Reddit

Unread post by Blacklab » 2022-01-15, 18:34

My bad... distracted reading a Twitter thread. :roll: There are similar alternative front-ends around for Reddit... although I'm only just trying them out as normal Reddit works smoothly for me using a combination of ad-blocking and script blocking.

Had meant to post this Re: alternative front-ends for Reddit: https://greycoder.com/two-lightweight-p ... to-reddit/

The alternative front-end for YT recommended a few times on this forum is 'CloudTube'... see: search.php?keywords=cloudtube. There are others out there including variations of Invidious.

indius
Moongazer
Moongazer
Posts: 13
Joined: 2016-08-02, 14:34

Re: Slow loading in YouTube/Reddit

Unread post by indius » 2022-01-20, 10:10

For reddit use old.reddit.com.

For automatic redirection install or paste this script into GreaseMonkey:

https://greasyfork.org/en/scripts/40897-old-reddit-please

Code: Select all

// ==UserScript==
// @name         Old Reddit Please!
// @namespace    http://ksir.pw/
// @version      1.3
// @description  Converts reddit.com links to old.reddit.com links
// @author       Kain (ksir.pw)
// @match        *://www.reddit.com/*
// @icon         https://www.google.com/s2/favicons?domain=www.reddit.com
// @grant        none
// @run-at       document-start
// ==/UserScript==

function test(url){
    return !!url.match(/^(|http(s?):\/\/)(|www.)reddit.com(\/.*|$)/gim);
}

function getNewPagePlease(url){
    return 'https://old.reddit.com' + url.split('reddit.com').pop();
}

function fixRedditStuff(){
    var links = Array.prototype.slice.call(document.links, 0);
    links.filter(function(link){
        if(test(link.href)){
            var greatNewLink = getNewPagePlease(link.href);
            if(link.hasAttribute('data-outbound-url')) link.setAttribute('data-outbound-url', greatNewLink);
            link.setAttribute('href', greatNewLink);
        }
    });
}

if(test(window.location.href)){window.location.assign(getNewPagePlease(window.location.href));}

window.onload = fixRedditStuff;
setInterval(fixRedditStuff, 50);

User avatar
Moonraker
Board Warrior
Board Warrior
Posts: 1858
Joined: 2015-09-30, 23:02
Location: uk.

Re: Slow loading in YouTube/Reddit

Unread post by Moonraker » 2022-01-20, 13:07

Try using the inbuilt youtube player in the DDG search engine.it cuts out all the adcrap and notifications and runs great here.
user of multiple puppy linuxes..upup,fossapup.scpup,xenialpup..... :thumbup:

Pale moon 29.4.1

User avatar
moonbat
Knows the dark side
Knows the dark side
Posts: 3892
Joined: 2015-12-09, 15:45
Contact:

Re: Slow loading in YouTube/Reddit

Unread post by moonbat » 2022-01-21, 00:29

Youtube polymer engine fixes is the best fix for Youtube, offers customization including making it more compact and reverting the dislike button.
"One hosts to look them up, one DNS to find them and in the darkness BIND them."

Image
Linux Mint 20.1 Xfce x64 on HP i5-5200 laptop, 12 GB RAM.
AutoPageColor|PermissionsPlus|PMPlayer|Pure URL|RecordRewind|TextFX

Post Reply