Default browser funktioniert unter Debian nicht

For user discussions written in German

Moderator: satrow

Locked
User avatar
berni
Moongazer
Moongazer
Posts: 14
Joined: 2018-10-02, 10:08

Default browser funktioniert unter Debian nicht

Post by berni » 2018-10-07, 07:29

Bei mir klappt es nicht, Pale Moon als Default-Browser einzustellen. Ich habe Debian Stable installiert und beim Starten von Pale Moon (mit .deb-Paket systemweit installiert) erhalte ich die Frage, ob Pale Moon mein Default-Browser sein soll. Das bejahe ich, aber es wird weiterhin Firefox geöffnet. Ich habe recherchiert und herausgefunden, dass man das mit xdg-settings steuern kann.

Bevor ich Pale Moon als Default-Browser eingestellt habe:

$> xdg-settings get default-web-browser
firefox-esr.desktop

Und danach:
$> xdg-settings get default-web-browser
/usr/bin/xdg-mime: 912: local: Moon-XYVHQZ.desktop: bad variable name
firefox-esr.desktop

$> palemoon -v
Moonchild Productions Pale Moon 28.1.0

Was kann man da machen?

PS: Es handelt sich bei diesem Thread um eine Fortsetzung von https://forum.palemoon.org/viewtopic.php?f=7&t=20594

User avatar
loxodont
Astronaut
Astronaut
Posts: 561
Joined: 2014-07-26, 23:03
Location: Mare Serenitatis

Re: Default browser funktioniert unter Debian nicht

Post by loxodont » 2018-10-11, 18:43

Hi berni,
Ich kenne mich leider nur ein bisschen mit Xubuntu und Mint aus, habe im englischen Linux board nachgefragt aber bislang keine Antwort erhalten. Mit der Suchfunktion bin ich auf ein ähnliches Problem in Linux Mint (Tara) gestossen, in dem ein mozillazine-link zu Firefox als Default-Browser gepostet wurde. Dort steht zu Firefox/Debian:

"Debian
If you want to make Mozilla Firefox your default browser, point the symlink /etc/alternatives/x-www-browser to /usr/bin/mozilla-firefox or other path where Mozilla Firefox is installed. One easy way to do this is to execute the following command as root:

update-alternatives --config x-www-browser

Doing so will present you with a list of installed browsers from which you can select Firefox."


Ich weiss nicht was ein "symlink" ist, wahrscheinlich eine Art Verknüpfung, die man auf den Pfad der palemoon.exe oder .bin-Datei einstellen soll. Mit dem o.a. Befehl soll einem schliesslich eine Browser-Liste angezeigt werden, in der man Pale Moon dann auswählen können soll. - Keine Ahnung, ob das funktioniert.
Ansonsten weiss ich ich nur grob, dass man in einigen Linux-Distros Standard- und auch Alternativ-Programme konfigurieren können soll; sowas wie einen "Anwendungs-Manager".

User avatar
berni
Moongazer
Moongazer
Posts: 14
Joined: 2018-10-02, 10:08

Re: Default browser funktioniert unter Debian nicht

Post by berni » 2018-10-12, 06:12

Hallo loxodont,

Danke dir für diesen Einsatz! Die Lösung, die du mir da beschreibst, kenne ich, aber das Problem ist dabei, dass es systemweit ist. Das heißt, danach haben alle Benutzer (das bin zwar auch jedesmal ich, aber mit anderen Accounts, bei denen ich bislang noch nicht auf Pale Moon umstellen möchte) auf dem Rechner Pale Moon als default browser und nicht nur ich. Was ich suche, ist eine Lösung, die auf Benutzerebene funktioniert. Theoretisch sollte es reichen, wenn man bei dem Popup-Fenster nach dem Starten des Browsers anklickt, dass man den Browser als Standardbrowser haben will. Beim Firefox geht das, bei Pale Moon nicht und mir ist nicht klar, woran es liegt.

Ich bin diese Woche nicht dazu gekommen, werde aber, sobald ich wieder Zeit habe, selber weiter nach der Ursache suchen. Wenn ich was gefunden habe, melde ich mich hier auf alle Fälle nochmal. Ich könnte mir durchaus vorstellen, dass es sich um einen Fehler in den xdg-settings handelt und gar nicht im Pale Moon...

User avatar
loxodont
Astronaut
Astronaut
Posts: 561
Joined: 2014-07-26, 23:03
Location: Mare Serenitatis

Re: Default browser funktioniert unter Debian nicht

Post by loxodont » 2018-10-12, 09:42

Steven Pusser, der auch Pale Moon hier für Debian und Ubuntu anbietet:
https://software.opensuse.org/download. ... e=palemoon

hat im engl. Forum so geantwortet:
"Possibly he may have to set it as the default browser in the desktop environment's settings, or as the default "x-www-browser" in the Debian alternatives system (galternatives is a nice GUI for this; KDE users can use kalternatives)"

"Vielleicht kannst du den Browser in den Einstellungen der Desktop-Umgebung als "Default" setzen, oder als Default "x-www-browser" im Debian-Alternatives-System (galternatives ist ein gutes Graphics User Interface (GUI) dafür; KDE-User können kalternatives nutzen."

PS: Wenn ich deine letzte Post richtig verstehe, gehen solche Einstellungen nicht pro User-Account od. Profil, sondern nur für alle Profile. Dann nützt obige Idee wohl auch nicht viel.

User avatar
Revoluz
Moongazer
Moongazer
Posts: 12
Joined: 2018-11-12, 14:58

Re: Default browser funktioniert unter Debian nicht

Post by Revoluz » 2018-11-14, 00:22

Ich benutze als Oberfläche lxde und da ist dasTool " libfm-pref-apps " und für xfce " exo-preferred-applications " und wenn eine Anwendung das Standard nicht erkennen kann sollte sich das Dialog automatsch öffnen womit man eine Standard Anwendung definieren.

Andere Desktops kenne ich leider nicht was für Tool sie dafür haben. Meine Erfahrung ist die, dass wenn man das " Unpassende " deinstalliert, hat danach das System mit einer Anwendung xy automatisch das Dialog öffnet um die eine Standar Anwendunt fest legen zu können.

Meistens auch nur nach einer Neuanmeldung wird das ganze mit exo-preferred-applications wirksam. Manchmal kann das " Unerwünsche " deinstalliert werden, hilft auch.

Locked