cannot use gitlab,

Discussions about applications built on our platform code that do not have a dedicated board.

Moderators: trava90, athenian200

User avatar
frostknight
Fanatic
Fanatic
Posts: 236
Joined: 2022-08-10, 02:25

cannot use gitlab,

Unread post by frostknight » 2024-04-16, 02:24

my specific fork is well... not exactly used by most of you, but I am interested in hearing if any of you can access this page:

https://gitlab.com/magnolia1234/bypass- ... rome-clean

without getting redirected to this:

https://gitlab.com/users/sign_in

and having this pop up:


Your browser is out of date!
Update your browser to view this website correctly. More Information.

This is a reason I dietest gitlab 100-x more than github (which I can sometimes tolerate) but yeah.

That fork btw is iceweasel-uxp 20240402

Its a custom build.

User avatar
RealityRipple
Astronaut
Astronaut
Posts: 691
Joined: 2018-05-17, 02:34
Location: Los Berros Canyon, California
Contact:

Re: cannot use gitlab,

Unread post by RealityRipple » 2024-04-16, 02:53

I got a normal 404 error page, but I also was already logged in to gitlab. Tested in a private window. It did redirect, but it didn't say the browser was out of date.

User avatar
andyprough
Keeps coming back
Keeps coming back
Posts: 797
Joined: 2020-05-31, 04:33

Re: cannot use gitlab,

Unread post by andyprough » 2024-04-16, 02:58

I got a cloudflare check as well, and yes it asked me to sign in, but I didn't have the "out of date browser" message.

This appears to be a bit unique to this one user's gitlab setup. For example, if I go to Trisquel's gitlab I don't get a cloudflare check and I don't get asked to sign in: https://gitlab.trisquel.org/explore

User avatar
Night Wing
Knows the dark side
Knows the dark side
Posts: 5207
Joined: 2011-10-03, 10:19
Location: Piney Woods of Southeast Texas, USA

Re: cannot use gitlab,

Unread post by Night Wing » 2024-04-16, 04:12

I got redirected, but I did "not" see the "your browser is out of date" message.

At this time I am using 64 bit linux Pale Moon (33.0.2).

User avatar
frostknight
Fanatic
Fanatic
Posts: 236
Joined: 2022-08-10, 02:25

Re: cannot use gitlab,

Unread post by frostknight » 2024-04-16, 04:39

Hmm... I wonder if my user agent is wrong then.

Or if it something else.

I forget though what basilisk-browser's useragent should be though. Reason being, iceweasel-uxp is based on basilisk browser albeit an earlier version.

User avatar
Shadow
Apollo supporter
Apollo supporter
Posts: 43
Joined: 2023-03-16, 13:21

Re: cannot use gitlab,

Unread post by Shadow » 2024-04-16, 09:55

Code: Select all

https://torrentfreak.com/dmca-targetting-bypass-paywalls-clean-isnt-what-people-should-be-angry-about-240414/

User avatar
biopsin
Fanatic
Fanatic
Posts: 122
Joined: 2016-02-07, 17:15

Re: cannot use gitlab,

Unread post by biopsin » 2024-04-16, 12:33

frostknight wrote:
2024-04-16, 02:24
..if any of you can access this page:
https://gitlab.com/magnolia1234/bypass- ... rome-clean
Nope, any gitlab.com domain gives me a cloudflare "Verify you are human" loop.

// Error log, but I cant make any of it

Code: Select all

Timestamp: 16. april 2024 kl. 14.37 +0200
Error: [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsIWebProgress.DOMWindow]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://browser/content/browser.js :: onStateChange :: line 10597"  data: no]

Timestamp: 16. april 2024 kl. 14.37 +0200
Error: XML Parsing Error: no root element found
Location: https://challenges.cloudflare.com/cdn-cgi/challenge-platform/h/b/beacon/ov1/916568055:1713267267:-vaafvhdmIRHUGF4dcFYLYknfRQYC7eB_shQ4oIkJpI/875439edeb365690/2dcbc40afbe0c14/chl_api_m
Line Number 1, Column 1:
Source File: https://challenges.cloudflare.com/cdn-cgi/challenge-platform/h/b/beacon/ov1/916568055:1713267267:-vaafvhdmIRHUGF4dcFYLYknfRQYC7eB_shQ4oIkJpI/875439edeb365690/2dcbc40afbe0c14/chl_api_m
Line: 1
Last edited by biopsin on 2024-04-16, 12:40, edited 1 time in total.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 35931
Joined: 2011-08-28, 17:27
Location: Motala, SE
Contact:

Re: cannot use gitlab,

Unread post by Moonchild » 2024-04-16, 12:33

Is cloudflare censoring us with a captcha again?

Potkeny
Fanatic
Fanatic
Posts: 142
Joined: 2018-08-03, 17:00

Re: cannot use gitlab,

Unread post by Potkeny » 2024-04-16, 13:07

My daily profile went through the cloudflare verification process (after allowing what it needed in ematrix), so it seems it is not a blanket block for now.. but of course hard to say with these verifications.

User avatar
biopsin
Fanatic
Fanatic
Posts: 122
Joined: 2016-02-07, 17:15

Re: cannot use gitlab,

Unread post by biopsin » 2024-04-16, 13:19

I also tested on my banking profile which is without extensions or other tweaks and same loop..

User avatar
moonbat
Knows the dark side
Knows the dark side
Posts: 5066
Joined: 2015-12-09, 15:45
Contact:

Re: cannot use gitlab,

Unread post by moonbat » 2024-04-16, 23:19

Shadow wrote:
2024-04-16, 09:55

Code: Select all

https://torrentfreak.com/dmca-targetting-bypass-paywalls-clean-isnt-what-people-should-be-angry-about-240414/
Why would you use code tags for a link? :roll:

User avatar
back2themoon
Moon Magic practitioner
Moon Magic practitioner
Posts: 2426
Joined: 2012-08-19, 20:32

Re: cannot use gitlab,

Unread post by back2themoon » 2024-04-17, 09:40

As mentioned, that user account you are trying to reach has been recently removed/disabled from GitLab. It can be found elsewhere (look at his Twitter account).

GitLab works fine here. Perhaps they recently made a change, requiring more aggressively user sign-in, or maybe login is necessary to attempt access to Private/disabled accounts. Cloudflare checks work fine.

In any case, for GitHub/GitLab (and other websites) installing the Palefill Web Technologies Polyfill Add-on is still recommended I believe.

User avatar
moonbat
Knows the dark side
Knows the dark side
Posts: 5066
Joined: 2015-12-09, 15:45
Contact:

Re: cannot use gitlab,

Unread post by moonbat » 2024-04-17, 22:22

back2themoon wrote:
2024-04-17, 09:40
In any case, for GitHub/GitLab (and other websites) installing the Palefill Web Technologies Polyfill Add-on is still recommended I believe.
No, not anymore since the massive compatibility improvements in 31-32. Gitlab works for me fine without that addon, I removed it long ago.

User avatar
frostknight
Fanatic
Fanatic
Posts: 236
Joined: 2022-08-10, 02:25

Re: cannot use gitlab,

Unread post by frostknight » 2024-04-18, 02:24

Shadow wrote:
2024-04-16, 09:55

Code: Select all

https://torrentfreak.com/dmca-targetting-bypass-paywalls-clean-isnt-what-people-should-be-angry-about-240414/
Is there a way to do this for all paywalls in general?

not just torrentfreak using modify http response?

User avatar
Shadow
Apollo supporter
Apollo supporter
Posts: 43
Joined: 2023-03-16, 13:21

Re: cannot use gitlab,

Unread post by Shadow » 2024-04-18, 14:21

frostknight wrote:
2024-04-18, 02:24

Is there a way to do this for all paywalls in general?

not just torrentfreak using modify http response?
Sorry, I don't know what you're really getting at. It's an article on the subject showing why you're getting what you're getting in your initial post.

Magnolia will probably upload the code again elsewhere. They haven't done themselves any favors though by not telling people the whys of the situation.
moonbat wrote:
2024-04-16, 23:19
Why would you use code tags for a link? :roll:
I posted it in code as I wanted to show the link in full since it has torrent in the URL and shortened it could be misconstrued as a torrent site with nasty popups or whatever. Maybe I should just use archive.is instead.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 35931
Joined: 2011-08-28, 17:27
Location: Motala, SE
Contact:

Re: cannot use gitlab,

Unread post by Moonchild » 2024-04-18, 14:26

Shadow wrote:
2024-04-18, 14:21
I posted it in code as I wanted to show the link in full since it has torrent in the URL and shortened it could be misconstrued as a torrent site with nasty popups or whatever.
Tip: next time just select the link and click the </> button - it will enclose the URL in [ url ] tags which prevents it from being shortened in display.

User avatar
back2themoon
Moon Magic practitioner
Moon Magic practitioner
Posts: 2426
Joined: 2012-08-19, 20:32

Re: cannot use gitlab,

Unread post by back2themoon » 2024-04-18, 14:28

Shadow wrote:
2024-04-18, 14:21
Magnolia will probably upload the code again elsewhere. They haven't done themselves any favors though by not telling people the whys of the situation.
Already uploaded and explained.

User avatar
Shadow
Apollo supporter
Apollo supporter
Posts: 43
Joined: 2023-03-16, 13:21

Re: cannot use gitlab,

Unread post by Shadow » 2024-04-18, 14:36

Moonchild wrote:
2024-04-18, 14:26
Tip: next time just select the link and click the </> button - it will enclose the URL in [ url ] tags which prevents it from being shortened in display.
Thank you for that.
back2themoon wrote:
2024-04-18, 14:28
Already uploaded and explained.
Are you referring to the tweet pictured in the article? The article said a DMCA doesn't really make any sense which makes the whole thing look iffy.

User avatar
biopsin
Fanatic
Fanatic
Posts: 122
Joined: 2016-02-07, 17:15

Re: #251002

Unread post by biopsin » 2024-04-18, 14:40

biopsin wrote:
2024-04-16, 13:19
I also tested on my banking profile which is without extensions or other tweaks and same loop..
Tested binary release on differnt location and it passes, so "quote" is local issue.

User avatar
back2themoon
Moon Magic practitioner
Moon Magic practitioner
Posts: 2426
Joined: 2012-08-19, 20:32

Re: cannot use gitlab,

Unread post by back2themoon » 2024-04-18, 17:21

Shadow wrote:
2024-04-18, 14:36
Are you referring to the tweet pictured in the article? The article said a DMCA doesn't really make any sense which makes the whole thing look iffy.
Yes, and to the link (also on Twitter) for the new location.

Don't see why I should believe TF's speculations (TF is indeed reliable, generally speaking) and not the actual developer who's running the whole thing for so long. Not that it matters anyway, since new versions are already out.

Post Reply