sending mail fails

Board for discussion of BinOC Applications and Extensions using the Unified XUL Platform.

Moderator: New Tobin Paradigm

Post Reply
User avatar
puppyX
Moonbather
Moonbather
Posts: 55
Joined: 2019-05-30, 11:43

sending mail fails

Post by puppyX » 2020-10-05, 11:50

I tried to send an email using interlink but it failed;
mailfail.JPG

Receiving is working but sending doesn't. It won't accept my email passwords when connecting to the servers. (do I need to save passwords in the manager ?) This is the first time Interlink has been used to send email.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 28789
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: sending mail fails

Post by Moonchild » 2020-10-05, 12:04

Make sure your SMTP is set according to https://support.gmx.com/pop-imap/imap/server.html
Make sure your login used for sending mail is correct.
Enter your associated password when sending mail the first time, or re-enter it if it was incorrect. Yes, you DO have to save this password in the manager unless you want to enter it with every mail you send, manually. I recommend saving it in the manager and using a master password to protect your stored passwords.
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

User avatar
puppyX
Moonbather
Moonbather
Posts: 55
Joined: 2019-05-30, 11:43

Re: sending mail fails

Post by puppyX » 2020-10-05, 13:01

Thanks for speedy reply. The GMX has POP3 and IMAP. I'm currently set up with POP3, have done for years. Will it need changing to IMAP to work with interlink ?

User avatar
Tohuwabohuix
Moon lover
Moon lover
Posts: 98
Joined: 2018-05-13, 18:50
Location: M/DE-BY/Terra/Sol/ Milky Way/Laniakea Supercluster/ Local Universe <->wOrMHoLe<-> Omni(bus)verse

Re: sending mail fails

Post by Tohuwabohuix » 2020-10-05, 13:49

puppyX wrote:
2020-10-05, 13:01
...Will it need changing to IMAP to work with interlink ?
In each e-mail-client you need to "change to"/choose (IMAP)/SMTP for sending e-mails!
Read carefully the link (IMAP Server Data) Moonchild gave you.

POP3 is only for download/receiving e-mails:
The POP3 protocol allows you to download your email and read it while being offline.

SMTP is for sending. Read carefully what is written under POP3, SMTP.

If you have used Thunderbird before, the settings are almost the same.
 
"Always look on the bright side of life"
»Eric Idle«

"Asshole - eminent member of the human body - whoever despises it might mistakenly use his own mouth in its place"
»unknown platitudinarian«

"Laedere numquam velimus, longeque absit illud propositum potius amicum quam dictum perdendi"
»Marcus Fabius Quintilian«
 

User avatar
puppyX
Moonbather
Moonbather
Posts: 55
Joined: 2019-05-30, 11:43

Re: sending mail fails

Post by puppyX » 2020-10-06, 11:13

I've reset the password, cleared all history and it's still only receiving but not sending emails.

These are the pop3 & smtp server numbers used;
https://support.gmx.com/pop-imap/pop3/s ... -imap_pop3

Application Basics

Name: Interlink
Version: 52.9.7577
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:4.6) Goanna/20200929 Interlink/52.9.7577
Profile Folder: Open Folder

(Local drive)
Application Build ID: 20200929093109
Enabled Plugins: about:plugins
Build Configuration: about:buildconfig
Memory Use: about:memory
Profiles: about:profiles

Mail and News Accounts
account1:
INCOMING: account1, , (none) Local Folders, SSL, passwordCleartext

account3:
INCOMING: account3, , (pop3) pop.gmx.com:995, SSL, passwordCleartext
OUTGOING: , mail.gmx.com:465, SSL, passwordCleartext, true

account4:
INCOMING: account4, , (pop3) mail.btinternet.com:995, SSL, passwordCleartext
OUTGOING: , mail.gmx.com:465, SSL, passwordCleartext, true

account5:
INCOMING: account5, , (pop3) pop.virgin.net:995, SSL, passwordCleartext
OUTGOING: , mail.gmx.com:465, SSL, passwordCleartext, true

Extensions
Lightning, 5.4.9.7577, false, {e2fda1a4-762b-4020-b5ad-a41df1933103}
Provider for Google Calendar, 3.3, false, {a62ef8ec-5fdc-40c2-873c-223b8a6925cc}

Important Modified Preferences

Name: Value

browser.cache.disk.capacity: 358400
extensions.lastAppVersion: 52.9.7577
font.name.sans-serif.el: Calibri
font.name.sans-serif.x-cyrillic: Calibri
font.name.sans-serif.x-unicode: Calibri
font.name.sans-serif.x-western: Calibri
font.name.serif.el: Cambria
font.name.serif.x-cyrillic: Cambria
font.name.serif.x-unicode: Cambria
font.name.serif.x-western: Cambria
font.size.fixed.el: 14
font.size.fixed.x-cyrillic: 14
font.size.fixed.x-unicode: 14
font.size.fixed.x-western: 14
font.size.variable.el: 17
font.size.variable.x-cyrillic: 17
font.size.variable.x-unicode: 17
font.size.variable.x-western: 17
gfx.crash-guard.d3d11layers.appVersion: 52.9.7577
gfx.crash-guard.d3d11layers.deviceID: 0x0046
gfx.crash-guard.d3d11layers.driverVersion: 8.15.10.2622
gfx.crash-guard.d3d11layers.feature-d2d: true
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.status.d3d11layers: 2
mail.openMessageBehavior.version: 1
mailnews.database.global.datastore.id: c827c2c5-9d9c-49c3-859b-353a727adb4
media.hardware-video-decoding.failed: false
network.cookie.cookieBehavior: 3
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1601716162
places.history.enabled: false
places.history.expiration.transient_current_max_pages: 122334
privacy.sanitize.timeSpan: 0
security.disable_button.openCertManager: false
security.disable_button.openDeviceManager: false

Graphics

GPU #1
Description: Intel(R) HD Graphics
Vendor ID: 0x8086
Device ID: 0x0046
RAM: Unknown
Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version: 8.15.10.2622
Driver Date: 1-10-2012

Features
Direct2D: true
DirectWrite: true (6.2.9200.23144)
WebGL 1 Driver Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D11 vs_4_0 ps_4_0) -- OpenGL ES 2.0 (ANGLE 2.1.0.)

AzureCanvasBackend: direct2d 1.1
AzureCanvasAccelerated: 0
AzureFallbackCanvasBackend: cairo
AzureContentBackend: direct2d 1.1

JavaScript

Incremental GC: 1

Accessibility

Activated: 0
Prevent Accessibility: 0

Library Versions

Expected minimum version
Version in use

NSPR
4.24
4.24

NSS
3.48.4
3.48.4

NSS Util
3.48.4
3.48.4

NSS SSL
3.48.4
3.48.4

NSS S/MIME
3.48.4
3.48.4
I'm concentrating on the gmx account

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 28789
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: sending mail fails

Post by Moonchild » 2020-10-06, 14:00

Looks like you are using port 465 (implicit TLS) while all the instructions state to use 587 (explicit) and STARTTLS. Maybe try that?
Also make sure your SMTP user name is your full gmx e-mail address (including the @domain)
Also be aware that some SMTP servers will not allow you to send mail through them for third-party domains (i.e. if you are sending with a from e-mail address that isn't @gmx.*)

If still no joy maybe the error console can be of help.
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

User avatar
Trapper
Fanatic
Fanatic
Posts: 112
Joined: 2016-01-29, 00:21

Re: sending mail fails

Post by Trapper » 2020-10-06, 14:15

If you're using a VPN, that's likely your problem. All VPNs block the outgoing SMTP port to prevent spam.

To solve this issue, you can either:

1) temporarily turn off the VPN before sending outgoing email, then turn it back on again
or
2) if your VPN supports an exclusion list, enter your outgoing email server's IP address to the list, thus bypassing the VPN when sending outgoing email.

User avatar
puppyX
Moonbather
Moonbather
Posts: 55
Joined: 2019-05-30, 11:43

Re: sending mail fails

Post by puppyX » 2020-10-06, 14:41

Moonchild wrote:
2020-10-06, 14:00
Looks like you are using port 465 (implicit TLS) while all the instructions state to use 587 (explicit) and STARTTLS. Maybe try that?
Also make sure your SMTP user name is your full gmx e-mail address (including the @domain)
Also be aware that some SMTP servers will not allow you to send mail through them for third-party domains (i.e. if you are sending with a from e-mail address that isn't @gmx.*)

If still no joy maybe the error console can be of help.

:D It worked thanks. changed to 587 SARTTLS and used the full email. The last time a mail box was properly set up was Windows Live Mail, years ago. I became very confused. GMX now sending and receiving.

User avatar
puppyX
Moonbather
Moonbather
Posts: 55
Joined: 2019-05-30, 11:43

Re: sending mail fails

Post by puppyX » 2020-10-06, 14:47

Trapper wrote:
2020-10-06, 14:15
If you're using a VPN, that's likely your problem. All VPNs block the outgoing SMTP port to prevent spam.

To solve this issue, you can either:

1) temporarily turn off the VPN before sending outgoing email, then turn it back on again
or
2) if your VPN supports an exclusion list, enter your outgoing email server's IP address to the list, thus bypassing the VPN when sending outgoing email.
Thanks but a VPN is not in use here. I got confused enough over this email collector, a VPN would finish me. :?

Post Reply