SASL EXTERNAL doesn't seem to work properly

Board for discussions around the Ambassador chat client and extension.

Moderator: Isengrim

User avatar
jobbautista9
Keeps coming back
Keeps coming back
Posts: 798
Joined: 2020-11-03, 06:47
Location: Philippines
Contact:

SASL EXTERNAL doesn't seem to work properly

Unread post by jobbautista9 » 2021-04-13, 05:39

So I tried to use my own certificate as a means of authentication to freenode. I imported my cert into the Certificate Manager, and when I connect to freenode, it asks me whether to use my certificate, which is expected. But what I did not expect is that it still asks me for a password. I disabled "Use SASL authentication" in the preferences, and only used my certificate instead, but now I can't connect, because my IP is banned for users not using SASL.

What's even weird is that when I connect with both certificate and password, and /whois myself, it shows my certificate fingerprint. So it sees my certificate.

My certificate has a key size of 16384-bits long, maybe that could be a factor?

I'm using the standalone client.
Image

merry mimas

XUL add-ons developer. You can find a list of add-ons I manage at http://rw.rs/~job/software.html.

Mima avatar by 絵虎. Pixiv post: https://www.pixiv.net/en/artworks/15431817

Image

Locked