Starting with Pale Moon 29.2.0, the browser no longer supports unmaintained legacy Firefox extensions that are not updated for/targeting Pale Moon directly.
Please see the relevant announcement for details.

Kindly do not create a topic for each extension that stopped working for you as that is very counterproductive. Look on the Pale Moon Add-ons Site (https://addons.palemoon.org) first for any replacements, and search the forum to see if it has already been discussed or not before making new topics. Staff may delete duplicate topics without notice.

SASL EXTERNAL doesn't seem to work properly

Board for discussions around the Ambassador chat client and extension.

Moderator: Isengrim

Post Reply
User avatar
jobbautista9
Lunatic
Lunatic
Posts: 300
Joined: 2020-11-03, 06:47
Location: Philippines
Contact:

SASL EXTERNAL doesn't seem to work properly

Post by jobbautista9 » 2021-04-13, 05:39

So I tried to use my own certificate as a means of authentication to freenode. I imported my cert into the Certificate Manager, and when I connect to freenode, it asks me whether to use my certificate, which is expected. But what I did not expect is that it still asks me for a password. I disabled "Use SASL authentication" in the preferences, and only used my certificate instead, but now I can't connect, because my IP is banned for users not using SASL.

What's even weird is that when I connect with both certificate and password, and /whois myself, it shows my certificate fingerprint. So it sees my certificate.

My certificate has a key size of 16384-bits long, maybe that could be a factor?

I'm using the standalone client.
I'm just a simple Waddle Dee, working at waddling...

Developer of Ambassador in Window Menu, BrowserTickTock, CacheSwitch, Chrome Navigator, Cite4Wiki, Clickity Touch 'n Push, ColorPili, EditDatContent, EditDatTitle, Esrever, Go Menu, User Agent Status, Website Navigation Bar, and Yet Another about:config Helper.

My PGP public key

Post Reply