Enabling layers.prefer-opengl on Windows Topic is solved

Discussions about the development and maturation of the Unified XUL Platform (UXP).
Warning: may contain highly-technical topics.

Moderator: trava90

Locked
User avatar
UCyborg
Moonbather
Moonbather
Posts: 64
Joined: 2019-01-10, 09:37

Enabling layers.prefer-opengl on Windows

Post by UCyborg » 2020-06-25, 07:48

Does this work for anyone without crashing the browser on startup? I thought to try it out since I already use OpenGL for WebGL (ANGLE is disabled), so why not use it for other parts of the browser?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 30192
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Enabling layers.prefer-opengl on Windows

Post by Moonchild » 2020-06-25, 09:57

This will only work on some set-ups.
Using OpenGL for native 3D stuff is what it is primarily designed for, so using it for WebGL in defined, relatively small viewports (canvas areas) is obviously within its normal realm of operation.
Using it for layers acceleration for web content however is a whole different matter! That goes into layering (very) large textures in a 3D-to-2D fashion.
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

User avatar
UCyborg
Moonbather
Moonbather
Posts: 64
Joined: 2019-01-10, 09:37

Re: Enabling layers.prefer-opengl on Windows

Post by UCyborg » 2020-06-26, 23:09

The code inherited from Mozilla does seem to have some broken bits related to OpenGL on Windows specifically. I remember it worked years ago without crashing. Also, Firefox 56 and 72 both launch without crashing, though UI is glitchy in this case (this could actually be a very old issue predating the startup crash problem). Firefox 52 crashes at startup.

On Linux, there aren't any UI glitches. I made sure OpenGL acceleration was actually enabled by checking about:support page and also, the driver's stats overlay showed up in the top-left corner if enabled before launching the browser. It didn't seem to improve performance, it was actually a bit slower (NVIDIA 440.xx). On the slightly related note, Mozilla still blocks NVIDIA's proprietary driver when it comes to their WebRender.

I tested with Basilisk.

Maybe the startup crash in one version and glitchy UI in another are related. Curious on what kind of setup it works properly.

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 9928
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: Enabling layers.prefer-opengl on Windows

Post by New Tobin Paradigm » 2020-06-27, 00:46

So is there a question?
I'M COMBINING THE FORCE FIELD WITH ENERGY POWER!
Image

User avatar
UCyborg
Moonbather
Moonbather
Posts: 64
Joined: 2019-01-10, 09:37

Re: Enabling layers.prefer-opengl on Windows

Post by UCyborg » 2020-06-28, 03:28

I'm asking if OpenGL layers acceleration could be get to work properly on Windows. The way it behaves, it doesn't give the impression of it being the driver issue.

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 9928
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: Enabling layers.prefer-opengl on Windows

Post by New Tobin Paradigm » 2020-06-28, 04:21

I doubt it and we really don't support it nor did Mozilla of the time. I see no reason to anyway since DX is quite capable and first party on the Windows.
I'M COMBINING THE FORCE FIELD WITH ENERGY POWER!
Image

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 30192
Joined: 2011-08-28, 17:27
Location: Tranås, SE
Contact:

Re: Enabling layers.prefer-opengl on Windows

Post by Moonchild » 2020-06-28, 10:21

UCyborg wrote:
2020-06-28, 03:28
I'm asking if OpenGL layers acceleration could be get to work properly on Windows.
Extremely unlikely. It's been unused, un-exercised and stale/unmaintained Mozilla code for years. This by itself would probably be months of work to get working properly, and we simply don't support it beyond "experimental". if it works for you, great. If it doesn't, too bad and use the default.
"Son, in life you do not fight battles because you expect to win, you fight them merely because they need to be fought." -- Snagglepuss
Image

Locked