IceWeasel-UXP / Basilisk OSX packaging issue?

Discussions about the development and maturation of the Unified XUL Platform (UXP).
Warning: may contain highly-technical topics.

Moderators: trava90, satrow

wicknix
Apollo supporter
Apollo supporter
Posts: 47
Joined: Mon, 26 Mar 2018, 04:47

IceWeasel-UXP / Basilisk OSX packaging issue?

Unread postby wicknix » Mon, 23 Jul 2018, 03:58

So i successfully built iceweasel-uxp for mac osx. The application runs on the build machine via ./mach run, but fails on any other machine after packaging. The .dmg shows a circle with a line through the app, and pops up an error. (see attached photos) I'm thinking it's a packaging issue, but i can't quite narrow it down. For the record, i have the same issue with Basilisk. This issue doesn't exist with Pale Moon 28. Any ideas?

Cheers.

IWUXP-error.png


IWUXP-Mac.png

User avatar
adesh
Astronaut
Astronaut
Posts: 564
Joined: Tue, 06 Jun 2017, 07:38

Re: IceWeasel-UXP / Basilisk OSX packaging issue?

Unread postby adesh » Mon, 23 Jul 2018, 05:43

Most probably the binary name in some "plist" file does not match with the actual binary. Edit the info file manually and try again.

wicknix
Apollo supporter
Apollo supporter
Posts: 47
Joined: Mon, 26 Mar 2018, 04:47

Re: IceWeasel-UXP / Basilisk OSX packaging issue?

Unread postby wicknix » Tue, 24 Jul 2018, 02:02

Thanks. I'll look in to that.

*edit* That was it. Thanks!
Cheers
Last edited by wicknix on Tue, 24 Jul 2018, 02:28, edited 1 time in total.


Return to “UXP development”

Who is online

Users browsing this forum: No registered users and 2 guests