IceWeasel-UXP / Basilisk OSX packaging issue?

Discussions about the development and maturation of the Unified XUL Platform (UXP).
Warning: may contain highly-technical topics.

Moderators: trava90, satrow

User avatar
wicknix
Moon lover
Moon lover
Posts: 94
Joined: 2018-03-26, 04:47
Location: Wisconsin, USA

IceWeasel-UXP / Basilisk OSX packaging issue?

Unread post by wicknix » 2018-07-23, 03:58

So i successfully built iceweasel-uxp for mac osx. The application runs on the build machine via ./mach run, but fails on any other machine after packaging. The .dmg shows a circle with a line through the app, and pops up an error. (see attached photos) I'm thinking it's a packaging issue, but i can't quite narrow it down. For the record, i have the same issue with Basilisk. This issue doesn't exist with Pale Moon 28. Any ideas?

Cheers.
IWUXP-error.png
IWUXP-Mac.png
Silence is golden, but duct tape is silver...

User avatar
adesh
Astronaut
Astronaut
Posts: 602
Joined: 2017-06-06, 07:38

Re: IceWeasel-UXP / Basilisk OSX packaging issue?

Unread post by adesh » 2018-07-23, 05:43

Most probably the binary name in some "plist" file does not match with the actual binary. Edit the info file manually and try again.

User avatar
wicknix
Moon lover
Moon lover
Posts: 94
Joined: 2018-03-26, 04:47
Location: Wisconsin, USA

Re: IceWeasel-UXP / Basilisk OSX packaging issue?

Unread post by wicknix » 2018-07-24, 02:02

Thanks. I'll look in to that.

*edit* That was it. Thanks!
Cheers
Last edited by wicknix on 2018-07-24, 02:28, edited 1 time in total.
Silence is golden, but duct tape is silver...

Locked