Page 1 of 1

Prime Video stopped working - Widevine problems

Posted: 2019-09-11, 09:32
by moonbat
It was working fine till yesterday, and obviously the plugin is activated, DRM is enabled, etc. This is on Linux Mint 19.2 Xfce x64.
Now I get a message saying -
Your web browser is missing a digital rights component.

In your web browser’s address bar, type about:addons, press Enter, and then on the left, click Plugins. For the Widevine Content Decryption Module, select Always Activate, and then refresh the video’s page and try watching the video.

Re: Prime Video stopped working - Widevine problems

Posted: 2019-09-11, 09:39
by New Tobin Paradigm
Come on dude. You know EME is busted by Google making them selves incompatible and revoking keys for the current supported version and our media expert who is also the lead linux developer is MIA. So EME-DRM is and will remain effectively busted until such tome that it isn't.

Off-topic:
Dude, I want you to slow down and do some extra research before posting or replying. I see potential in you but you are still relatively new to the area. Take your time.

Re: Prime Video stopped working - Widevine problems

Posted: 2019-09-11, 09:51
by moonbat
New Tobin Paradigm wrote:
2019-09-11, 09:39
You know EME is busted by Google making them selves incompatible and revoking keys for the current supported version and our media expert who is also the lead linux developer is MIA. So EME-DRM is and will remain effectively busted until such tome that it isn't.
Off-topic:
Dude, I want you to slow down and do some extra research before posting or replying. I see potential in you but you are still relatively new to the area. Take your time.
Oh yeah, forgot about the key thing. Looks like Firefox it is for now :(
Since Prime doesn't support Chromium.

Re: Prime Video stopped working - Widevine problems

Posted: 2019-10-22, 17:43
by chuckallisonusa
Did manange to upgrade the widevine plugin to make Netflix work in Basilisk but not Amazon prime video. wish it were different but it is not.
1.4.9.1088 update fix netflix not working but not prime... Sorry...

Re: Prime Video stopped working - Widevine problems

Posted: 2019-10-22, 23:10
by moonbat
chuckallisonusa wrote:
2019-10-22, 17:43
Did manange to upgrade the widevine plugin to make Netflix work in Basilisk but not Amazon prime video. wish it were different but it is not.
1.4.9.1088 update fix netflix not working but not prime... Sorry...
We're waiting for the updated version of the plugin to be applied on on Basilisk. Netflix has always worked for me, using Linux.

Re: Prime Video stopped working - Widevine problems

Posted: 2019-10-22, 23:57
by chuckallisonusa
Ok no issues new to the browser!