Disable check compatibility and installing addons

Board for discussions around the Basilisk web browser.

Moderator: satrow

dapgo
Fanatic
Fanatic
Posts: 103
Joined: 2016-10-11, 11:36

Disable check compatibility and installing addons

Unread post by dapgo » 2018-12-31, 15:59

I had this option in the past, and from addons this option was displayed and it was possible to "enable".
After the latest update I don't see that anymore, I tried to disabled from about:config without success.

Is there any change impacting on addons installation? if yes, how can I install an addon from Classics Addon Archive that is compatible from FF v3 to v56 without editing the xpi

Michaell
Fanatic
Fanatic
Posts: 117
Joined: 2018-05-26, 18:13

Re: Disable check compatibility and installing addons

Unread post by Michaell » 2018-12-31, 17:15

The max version number in CAA doesn't match what is in the extension. 56 must be just a default for CAA. There are some extensions that are just too old to work (I tried one that was 1.5-3.6 [it also showed 56 in CAA] and it failed without notification). If they didn't change it in 28, there was a minimum max that was required (seems like maybe 4.0 but not sure, should be in an old thread here).
Win10home(1709), PM28.4port

User avatar
Smokey20
Fanatic
Fanatic
Posts: 147
Joined: 2014-06-09, 06:06
Location: Hawaii

Re: Disable check compatibility and installing addons

Unread post by Smokey20 » 2019-01-01, 07:31

Is this the extension you used to have?
Monday, December 31, 2018 21;06;00001.png
If it is, I still have it on Fx 52.9 ESR. I haven't needed it on Basilisk. It is still available for Thunderbird at AMO (earlier versions of TB).

User avatar
New Tobin Paradigm
Off-Topic Sheriff
Off-Topic Sheriff
Posts: 5454
Joined: 2012-10-09, 19:37
Location: Sector 001

Re: Disable check compatibility and installing addons

Unread post by New Tobin Paradigm » 2019-01-01, 08:01

It won't work so quit trying.
Image

- Shadow the Hedgehog is my favorite Pokemon! -
http://binaryoutcast.com/ | http://thereisonlyxul.org/

dapgo
Fanatic
Fanatic
Posts: 103
Joined: 2016-10-11, 11:36

Re: Disable check compatibility and installing addons

Unread post by dapgo » 2019-01-03, 11:41

Yes, I have this extension and it was working in Basilisk until last update
Smokey20 wrote:Is this the extension you used to have?

Monday, December 31, 2018 21;06;00001.png

If it is, I still have it on Fx 52.9 ESR. I haven't needed it on Basilisk. It is still available for Thunderbird at AMO (earlier versions of TB).

dapgo
Fanatic
Fanatic
Posts: 103
Joined: 2016-10-11, 11:36

Re: Disable check compatibility and installing addons

Unread post by dapgo » 2019-01-03, 11:49

What "won't work"?
Do you mean disabling the checks?
Do you mean the functions of "Disable Add-on Compatibility Checks 1.3.1-signed.1-signed" addon?
Do you mean the addon that i is failing to be installed? (and which with checks disabled I can install in Waterfox)

Anyway if you think that it will not work, it means that there were changes impacting last Basilick and addon management. right?
New Tobin Paradigm wrote:It won't work so quit trying.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 23690
Joined: 2011-08-28, 17:27
Location: 58°2'16"N 14°58'31"E
Contact:

Re: Disable check compatibility and installing addons

Unread post by Moonchild » 2019-01-03, 14:26

Disabling the checks using the addon will not work.
City of Heroes public server: https://www.moonshard.org/ -- Vote for it: Image

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne
"I'm afraid you have me mistaken for someone who can be shamed by a child." -- Quillspawn

dapgo
Fanatic
Fanatic
Posts: 103
Joined: 2016-10-11, 11:36

Re: Disable check compatibility and installing addons

Unread post by dapgo » 2019-01-04, 13:43

And, is it possible to disable checks from about:config?
Moonchild wrote:Disabling the checks using the addon will not work.

Post Reply