Bookmark issues?

Board for discussions around the Basilisk web browser.

Moderator: satrow

User avatar
New to the forum
New to the forum
Posts: 2
Joined: 2018-09-11, 22:39

Bookmark issues?

Unread post by citrusella » 2018-09-12, 18:04

I copied a bookmark backup over from Firefox (partially as a test (version was 52.9 ESR)) and then decided I didn't want to do that (my Firefox backup theoretically was supposed to have 5019 bookmarks ('s time to start over) and not even all of them showed up--in fact none of the more recent ones I actually wanted to mess with did). So after I tried to not do that, I attempted to restore the Basilisk ones that I had (which was, like, the default plus 1) and it's unable to process the backup for some reason. It doesn't matter if the Firefox ones are still there or deleted (though I attempted to re-restore the Firefox ones just now after having deleted them all, and they won't restore either).

Apparently I can't go five seconds in this post without thinking to test something, because I was about to say that it wasn't a catastrophic issue, but I just realized I can't get the bookmark button to work on certain sites at all (specifically, the one I'm noticing is one that was previously in my bookmarks before the Firefox backup was added, which doesn't allow the bookmark button to be pressed and inconsistently reports whether or not it's bookmarked in terms of the star being colored), and I noticed on other sites, they either mistakenly thought they were bookmarked (like Tumblr, which appeared to be taking its info from the no-longer-existent imported bookmarks) and/or they wouldn't actually get properly bookmarked even if the bookmark button works (I tested this on Tumblr and one other site--Tumblr let me remove the 26 bookmarks of itself it thought I had, then when I tried to re-bookmark it, it changed color to being bookmarked and stayed that way through reloads and browser restarts, but it doesn't actually get listed as a bookmark, which makes bookmarking kind of useless).

I was originally going to ask if this was an issue with the backups or an issue with Basilisk but the second paragraph implies something deeper to my untrained eye...

I'm loath to go too far into testing by removing anything else, though I fear I might have to do something like removing the places file or something since AFAIK that's where actual bookmarks are (but presumably that'd wipe my history, too? I have no idea how any of this works...). Any less nuclear options I can try to take first?

EDIT: Appears things like the address bar autocomplete aren't working, either, so maybe this is more far reaching than I thought...

EDIT 2: Turns out Google is my friend and my places file was corrupt and needed to be removed. ...Maybe I should just delete this post now? :oops:
Last edited by citrusella on 2018-09-12, 18:25, edited 5 times in total.