Which extension should I add

Board for discussions around the Basilisk web browser.

Moderator: satrow

User avatar
Moondog
Newbie
Newbie
Posts: 4
Joined: Fri, 10 Aug 2018, 22:00

Which extension should I add

Unread postby Moondog » Fri, 10 Aug 2018, 23:32

Hello ... I'm a newbie to forum and browser . I understand this browser is in testing beta and it a copycat of palemoon/ firefox browser . I only have used Firefox and Chrome . So far I only have adblock for extensions. I'm curious what else should I add for security purpose, pop ups and such? thanks

User avatar
SpockFan02
Lunatic
Lunatic
Posts: 459
Joined: Sun, 24 Sep 2017, 16:35

Re: Which extension should I add

Unread postby SpockFan02 » Sat, 11 Aug 2018, 02:13

I would consider Basilisk to be secure sans extensions. It can also block normal pop-up windows on its own (about:preferences#content, Block pop-up windows), and I would think adblock should take care of other pop-ups.

Most add-ons compatible with Firefox 52 should also work in Basilisk, FYI.

User avatar
helloimustbegoing
Board Warrior
Board Warrior
Posts: 1887
Joined: Thu, 28 Jun 2012, 01:20

Re: Which extension should I add

Unread postby helloimustbegoing » Sat, 11 Aug 2018, 02:35


User avatar
Moondog
Newbie
Newbie
Posts: 4
Joined: Fri, 10 Aug 2018, 22:00

Re: Which extension should I add

Unread postby Moondog » Sat, 11 Aug 2018, 18:14

Thanks guys for your input :thumbup: . I'm totally new with this one been a long time Firefox user, though I'm finding Firefox not as fast as of late. Gave Chrome a try for the first time as well, but I really dislike Google as a company and their attitude my way or the highway tech support ... What's the trick in getting Decentraleyes added ? Because when I gave it a go it said it didn't get installed, not compatible issues
Last edited by Moondog on Sat, 11 Aug 2018, 18:30, edited 2 times in total.

User avatar
helloimustbegoing
Board Warrior
Board Warrior
Posts: 1887
Joined: Thu, 28 Jun 2012, 01:20

Re: Which extension should I add

Unread postby helloimustbegoing » Sat, 11 Aug 2018, 21:07

Moondog wrote:
What's the trick in getting Decentraleyes added ? Because when I gave it a go it said it didn't get installed, not compatible issues

Hmm, I thought the PM version of Decentraleyes could be added to Basilisk. Try the link below, click the FF ESR 52 link.

https://decentraleyes.org/

User avatar
therube
Astronaut
Astronaut
Posts: 620
Joined: Fri, 08 Jun 2018, 17:02

Re: Which extension should I add

Unread postby therube » Sun, 12 Aug 2018, 12:21

testing beta

Isn't that perpetual testing beta?
copycat of palemoon

And not a copycat of Pale Moon?

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22159
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Which extension should I add

Unread postby Moonchild » Sun, 12 Aug 2018, 16:13

To clarify things once more:

Basilisk is an individual product. It has nothing to do with Pale Moon apart from the fact that both build on the same platform.
Basilisk is stated to be more or less beta at any time because it is the platform's reference application, and more of a development vessel for the platform than a completely polished "final" browser. Although one can say that the same is true for any version of Firefox these days.
Last edited by Moonchild on Sun, 12 Aug 2018, 16:16, edited 1 time in total.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
Moondog
Newbie
Newbie
Posts: 4
Joined: Fri, 10 Aug 2018, 22:00

Re: Which extension should I add

Unread postby Moondog » Sun, 12 Aug 2018, 18:30

helloimustbegoing wrote:
Moondog wrote:
What's the trick in getting Decentraleyes added ? Because when I gave it a go it said it didn't get installed, not compatible issues

Hmm, I thought the PM version of Decentraleyes could be added to Basilisk. Try the link below, click the FF ESR 52 link.

https://decentraleyes.org/


Hi... When I try using the firefox one I get the following

This add-on requires a newer version of Firefox (at least version 56.0a1). You are using Firefox 52.9.
Preview of Decentraleyes

User avatar
helloimustbegoing
Board Warrior
Board Warrior
Posts: 1887
Joined: Thu, 28 Jun 2012, 01:20

Re: Which extension should I add

Unread postby helloimustbegoing » Sun, 12 Aug 2018, 19:14

Untitled.jpg

User avatar
Moondog
Newbie
Newbie
Posts: 4
Joined: Fri, 10 Aug 2018, 22:00

Re: Which extension should I add

Unread postby Moondog » Sun, 12 Aug 2018, 20:20

Got it now ... Thank you


Return to “Basilisk”

Who is online

Users browsing this forum: No registered users and 4 guests