Basilisk takes 50% of CPU even after closing a page full of GIF/GIFV pics.

Board for discussions around the Basilisk web browser.

Moderator: satrow

Latitude
Banned user
Banned user
Posts: 597
Joined: Mon, 21 Mar 2016, 18:28

Basilisk takes 50% of CPU even after closing a page full of GIF/GIFV pics.

Unread postby Latitude » Fri, 25 May 2018, 14:28

Basilisk takes 50% of CPU even after closing a page full of GIF/GIFV pics (and with another Reddit tabs) with quite long application uptime - and if I try to close Basilisk, it would still appear in my 3rd-party process manager (i.e. Process Hacker) & will take 50% of CPU usage & won't exit at all.

I have to close it from Process Hacker forcibly.

Example page: https://old.reddit.com/r/watchpeopledie - sorry for the NSFW nature of this subreddit.

Do you experience this too or just me?

Is it related with the web cache?
Last edited by Latitude on Fri, 25 May 2018, 14:40, edited 3 times in total.

User avatar
billmcct
Lunatic
Lunatic
Posts: 448
Joined: Tue, 04 Sep 2012, 15:19
Location: Atlanta Georgia USA

Re: Basilisk takes 50% of CPU even after closing a page full of GIF/GIFV pics.

Unread postby billmcct » Fri, 25 May 2018, 16:00

Not seeing that using Basilisk latest win7 x64.
screenshot.2.jpg
Win 7 x64 - Pale Moon 28x x32

User avatar
satrow
Forum staff
Forum staff
Posts: 1703
Joined: Thu, 08 Sep 2011, 11:27

Re: Basilisk takes 50% of CPU even after closing a page full of GIF/GIFV pics.

Unread postby satrow » Fri, 25 May 2018, 18:02

I'd guess you picked up a malware cryptominer.

BillZM
Hobby Astronomer
Hobby Astronomer
Posts: 28
Joined: Wed, 21 Feb 2018, 21:03

Re: Basilisk takes 50% of CPU even after closing a page full of GIF/GIFV pics.

Unread postby BillZM » Sat, 26 May 2018, 17:59

Are you running an ad blocker? Perhaps that would help.

Latitude
Banned user
Banned user
Posts: 597
Joined: Mon, 21 Mar 2016, 18:28

Re: Basilisk takes 50% of CPU even after closing a page full of GIF/GIFV pics.

Unread postby Latitude » Sun, 27 May 2018, 09:16

BillZM wrote:Are you running an ad blocker? Perhaps that would help.


uBlock Origin + uMatrix.

User avatar
satrow
Forum staff
Forum staff
Posts: 1703
Joined: Thu, 08 Sep 2011, 11:27

Re: Basilisk takes 50% of CPU even after closing a page full of GIF/GIFV pics.

Unread postby satrow » Sun, 27 May 2018, 09:19

Any non-default lists loaded?

Latitude
Banned user
Banned user
Posts: 597
Joined: Mon, 21 Mar 2016, 18:28

Re: Basilisk takes 50% of CPU even after closing a page full of GIF/GIFV pics.

Unread postby Latitude » Sun, 27 May 2018, 11:47

satrow wrote:Any non-default lists loaded?


Yep. Including the hosts files.

It may be the culprit as Basilisk doesn't behave like that if I "refresh" it.

User avatar
satrow
Forum staff
Forum staff
Posts: 1703
Joined: Thu, 08 Sep 2011, 11:27

Re: Basilisk takes 50% of CPU even after closing a page full of GIF/GIFV pics.

Unread postby satrow » Sun, 27 May 2018, 11:53

I'm only using Ubo, here's what I have loading:

BasiliskUbO.jpg

Latitude
Banned user
Banned user
Posts: 597
Joined: Mon, 21 Mar 2016, 18:28

Re: Basilisk takes 50% of CPU even after closing a page full of GIF/GIFV pics.

Unread postby Latitude » Sun, 27 May 2018, 12:24

satrow wrote:I'm only using Ubo, here's what I have loading:

BasiliskUbO.jpg


uBO + uMatrix may be overkill.

I use the "firefox-legacy" version of it (https://github.com/gorhill/uBlock/relea ... acy-1.16.4).

BillZM
Hobby Astronomer
Hobby Astronomer
Posts: 28
Joined: Wed, 21 Feb 2018, 21:03

Re: Basilisk takes 50% of CPU even after closing a page full of GIF/GIFV pics.

Unread postby BillZM » Sun, 27 May 2018, 13:44

Have you disabled one extension at a time to see if one may be giving you problems?

Latitude
Banned user
Banned user
Posts: 597
Joined: Mon, 21 Mar 2016, 18:28

Re: Basilisk takes 50% of CPU even after closing a page full of GIF/GIFV pics.

Unread postby Latitude » Sun, 27 May 2018, 13:50

BillZM wrote:Have you disabled one extension at a time to see if one may be giving you problems?


It isn't Basilisk' fault.

"Refreshing" Basilisk would solve this, of course.

The culprit must be one/some of my extensions.


Return to “Basilisk”

Who is online

Users browsing this forum: No registered users and 3 guests