youtube not working on basilik on windows Topic is solved

Board for discussions around the Basilisk web browser.

Moderator: satrow

ianas
Moonbather
Moonbather
Posts: 60
Joined: Sat, 25 Nov 2017, 02:48

youtube not working on basilik on windows

Unread postby ianas » Fri, 13 Apr 2018, 21:40

I recently found out I can't play any youtube videos on Basilisks
I tried youtube in safe mode without any addons (thinking it might be an addon issue) but all I get on youtube is a blank page both Firefox and IE work fine
this is what Basilisk gets
Image
using Basilisk 55.0.2018.03.21 64bit on win7
can I get a confirmation that this isn't just me (as google does have local servers it could be my local google acting up)

coffeebreak
Board Warrior
Board Warrior
Posts: 1364
Joined: Sat, 26 Sep 2015, 04:51
Location: U.S.

Re: youtube not working on basilik on windows

Unread postby coffeebreak » Fri, 13 Apr 2018, 21:53

YouTube videos play for me. (Basilisk-2018.03.21, Win 7 x86)

ianas
Moonbather
Moonbather
Posts: 60
Joined: Sat, 25 Nov 2017, 02:48

Re: youtube not working on basilik on windows

Unread postby ianas » Fri, 13 Apr 2018, 22:12

well it's seams broken for me I even tried with a US proxy youtube videos just don't load in Basilisk for me I don't know why
https://imgur.com/a/TPEH7

ianas
Moonbather
Moonbather
Posts: 60
Joined: Sat, 25 Nov 2017, 02:48

Re: youtube not working on basilik on windows

Unread postby ianas » Fri, 13 Apr 2018, 22:20

I found the culprit
to get the new dark youtube layout I had the preference

Code: Select all

general.useragent.override.youtube.com

set to

Code: Select all

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0


edit
nope I had a Firefox window open and opened youtube video in it by mistake and well youtube works in FF not in Basilisk :(
Last edited by ianas on Fri, 13 Apr 2018, 22:22, edited 1 time in total.

coffeebreak
Board Warrior
Board Warrior
Posts: 1364
Joined: Sat, 26 Sep 2015, 04:51
Location: U.S.

Re: youtube not working on basilik on windows  Topic is solved

Unread postby coffeebreak » Fri, 13 Apr 2018, 23:06

ianas wrote:to get the new dark youtube layout I had the preference

I'm not using any user agent override for YT.
Here's what I get for that video...
bsk-youtube.png

Have you tried a new profile?
Last edited by coffeebreak on Fri, 13 Apr 2018, 23:15, edited 2 times in total.

ianas
Moonbather
Moonbather
Posts: 60
Joined: Sat, 25 Nov 2017, 02:48

Re: youtube not working on basilik on windows

Unread postby ianas » Fri, 13 Apr 2018, 23:24

my fault I've accidentally turned off javascript re-enabaling it fixes youtube :oops:
tanks guys

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 22147
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: youtube not working on basilik on windows

Unread postby Moonchild » Sat, 14 Apr 2018, 13:45

ianas wrote:my fault I've accidentally turned off javascript re-enabaling it fixes youtube :oops:
tanks guys


And this is exactly why I'd prefer to remove that pref.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

ianas
Moonbather
Moonbather
Posts: 60
Joined: Sat, 25 Nov 2017, 02:48

Re: youtube not working on basilik on windows

Unread postby ianas » Sun, 15 Apr 2018, 00:42

the thing is I use the prefbar addon and I sometimes "accidentally" disable javascript the thing that confused me was that javascript was disabled in safe mode too my understanding was that in safe mode user prefs wore ignored
I'd also give part of the blame to google I was using 2 browsers at the time and when I tried uploading an image on imgur it warned me javascript is off youtube said nothing :/
Image
it was basically my fault for not seeing the checkbox but if it is possible maybe in safe mode user set preferences should be ignored?

coffeebreak
Board Warrior
Board Warrior
Posts: 1364
Joined: Sat, 26 Sep 2015, 04:51
Location: U.S.

Re: youtube not working on basilik on windows

Unread postby coffeebreak » Sun, 15 Apr 2018, 03:45

ianas wrote:the thing that confused me was that javascript was disabled in safe mode too my understanding was that in safe mode user prefs wore ignored

Safe mode does not disable javascript - it just disables the Just-in-time (JIT) JavaScript compiler.
(Wikipedia: Just-in-time compilation)

Secondly, custom user prefs are not "ignored" in safe mode, on the contrary, they are retained.
So the custom preference you created when you disabled javascript (unchecked the PrefBar box) persisted in safe mode.


Return to “Basilisk”

Who is online

Users browsing this forum: No registered users and 2 guests