Amazon streaming

Forum for discussions around the Basilisk web browser.

Moderator: satrow

User avatar
Deadhead
Newbie
Newbie
Posts: 4
Joined: Tue, 12 Sep 2017, 05:02

Amazon streaming

Postby Deadhead » Wed, 17 Jan 2018, 20:59

Basilisk streamed Amazon and Netflix just fine until about two days ago. Netflix still is ok but Amazon will not play any videos at all. I have Windows 10 64 and also tried Basilisk with a new profile. DRM is enabled. Nothing works.

User avatar
Stuhero
New to the forum
New to the forum
Posts: 1
Joined: Tue, 06 Feb 2018, 00:18

Re: Amazon streaming

Postby Stuhero » Tue, 06 Feb 2018, 00:45

I am having a similar issue although I am new to Basilisk. I have never had Amazon streaming work for me but it works fine on Firefox and Netflix works fine on all my browsers. I did go through all the suggestions I found trying to fix it. Please let us know if you found a fix.

User avatar
Deadhead
Newbie
Newbie
Posts: 4
Joined: Tue, 12 Sep 2017, 05:02

Re: Amazon streaming

Postby Deadhead » Fri, 16 Feb 2018, 03:19

Just updated to the 2-14-18 version and it STILL will not play Amazon videos. I give up. Going back to Waterfox which does play Amazon as well as Netflix.

Nick2018
Moongazer
Moongazer
Posts: 8
Joined: Sun, 11 Feb 2018, 16:15

Re: Amazon streaming

Postby Nick2018 » Mon, 19 Feb 2018, 14:49

Hello,

This problem may be related. I cannot play any videos from this link: https://www.cbsnews.com/news/oprah-foll ... -michigan/

I don't have any problem playing them in Pale Moon, Firefox ESR, or Internet Explorer. I do not have Flash Player installed. Are these videos looking for it?

When I went to www.cbs.com and tried to play any video I was told that the video was not available. However, when I used Internet Explore I was told that I needed Flash Player. I will install Flash Player and give an update.

BTW, all of my browsers are fully updated, 64 bit, running on a Windows 7 Pro machine fully updated.

Also, I had a website, chase.com, tell me that my browser needed to be updated. I found this to be odd since all of the others mentioned here that I use have never told me that.

Thanks,

Nick

Nick2018
Moongazer
Moongazer
Posts: 8
Joined: Sun, 11 Feb 2018, 16:15

Re: Amazon streaming

Postby Nick2018 » Mon, 19 Feb 2018, 15:19

Hello,

After installing Flash Player for both the Firefox version via Basilisk and the Internet Explorer version, ONLY Internet Explorer plays the videos that required Flash on www.cbs.com.

I still cannot play this video on Pale Moon, Basilisk, or Firefox: http://www.cbs.com/shows/60_minutes/vid ... ivided-ii/ but it does play in Internet Explorer.

This CBS video plays everywhere except Basilisk: https://www.cbsnews.com/news/oprah-foll ... -michigan/

It appears to me that CBS is doing some strange things with their video feeds.

Thanks,

Nick

User avatar
Sajadi
Keeps coming back
Keeps coming back
Posts: 868
Joined: Fri, 19 Apr 2013, 00:46

Re: Amazon streaming

Postby Sajadi » Mon, 19 Feb 2018, 15:39

Remove both of your Flash player installs and ONLY install the Firefox variant.

Also, try with an user agent override in Pale Moon or Basilisk - a Firefox only for example: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0 - and report what happens.

If possible report also the errors from the error/webconsole part of the dev tools with copy-paste them into here. No warnings, only real error messages.

Also, http://www.cbs.com/shows/60_minutes/vid ... ivided-ii/ - i can play that in Pale Moon with Flash.

Also does work with Flash in Pale Moon: https://www.cbsnews.com/news/oprah-foll ... -michigan/

Make also sure you have shut down your ads-blocker on cbsnews and that no scripts are blocked by No-script or similar if you have one of these for example.
Last edited by Sajadi on Mon, 19 Feb 2018, 17:11, edited 5 times in total.

Nick2018
Moongazer
Moongazer
Posts: 8
Joined: Sun, 11 Feb 2018, 16:15

Re: Amazon streaming

Postby Nick2018 » Tue, 20 Feb 2018, 14:38

Hello,

Thank you for the reply! I was able to get the first link in my last post to work after turning off my VPN. Via my VPN there is a built in ad blocker that I can enable or disable. I am still however having a problem with the second link. The second link plays in Internet Explorer 11 but the web site told me that I needed a new browser because I.E. is outdated but the video continued to play.

I even installed Basilisk 32 bit on a Windows 10 32 bit machine and before I added any add-ons I could not get the second link to work.

I am okay with this one link not working.

Thank you again. I appreciate the help.

Nick

RJARRRPCGP
Fanatic
Fanatic
Posts: 159
Joined: Mon, 22 Jun 2015, 19:48
Location: USA (North Springfield, Vermont)

Re: Amazon streaming

Postby RJARRRPCGP » Tue, 20 Feb 2018, 16:18

Nick2018 wrote: I was told that the video was not available.


Suspect script blocker. Most likely NoScript or the like...

BillZM
Moongazer
Moongazer
Posts: 13
Joined: Wed, 21 Feb 2018, 21:03

Re: Amazon streaming

Postby BillZM » Thu, 22 Feb 2018, 21:21

I have Basilisk streaming Amazon Video and Netflix beautifully in Silverlight with these useragent overrides. Got the idea from the useragent strings in Pale Moon.
general.useragent.override.amazon.com Mozilla/5.0 (Windows NT 10.0; rv:46.9) Gecko/20100101 Firefox/46.9
general.useragent.override.netflix.com Mozilla/5.0 (Windows NT 10.0; rv:46.9) Gecko/20100101 Firefox/46.9

Not sure what the cbs.com and cbsnews.com issues are. I tried similar useragent overrides for Firefox/55.0 for both.
Seemed to get farther into processing. I'm guessing I have the browser working, but not sure.
CBS may require log-in or purchase of their CBS All Access service.
*** cbs.com
The first video shows a blurred static picture with this message across it: "Sorry, this video is currently unavailable. Please refresh your page or try again later."
So the useragent string may be helping for cbs.com
*** cbsnews.com
The second video presents a black screen but doesn't play. No error message is given. Tried turning off the ad blocker but that didn't help. Didn't try logging in, but wondered if that might be part of the problem.
Searched for the same video through cbs.com vs cbsnews.com and it came up like the first video, showing a blurred static picture with the same "unavailable" message.

coffeebreak
Board Warrior
Board Warrior
Posts: 1185
Joined: Sat, 26 Sep 2015, 04:51
Location: U.S.

Re: Amazon streaming

Postby coffeebreak » Fri, 23 Feb 2018, 02:41

BillZM wrote:*** cbs.com ......*** cbsnews.com

I can play both videos in Basilisk. (in html5.) Leaving aside the adblocker stuff, here is what worked for me...
(Win 7 x86, Basilisk-2018.02.14)

No user agent overrides for either site.

The cbs.com video: allow cookies, local storage (dom.storage.enabled = true), indexedDB (dom.indexedDB.enabled = true), MSE enabled (default values), autoplay enabled (media.autoplay.enabled = true)

The cbsnews.com video: allow cookies, local storage, autoplay disabled (media.autoplay.enabled = false), MSE enabled (default values)

The MSE settings are a group (in about:config) like so: media.mediasource.*
Leave them at their defaults.

BillZM
Moongazer
Moongazer
Posts: 13
Joined: Wed, 21 Feb 2018, 21:03

Re: Amazon streaming

Postby BillZM » Fri, 23 Feb 2018, 05:38

coffeebreak wrote:Leaving aside the adblocker stuff, here is what worked for me...
(Win 7 x86, Basilisk-2018.02.14)


Thanks. I got those settings to work for me too. The reversal in media.autoplay.enabled between the two sites is puzzling. Exactly as you described. Neither setting worked for both.
(Win10 x86 1709, Basilisk-2018.02.02 e10s one content process, ublock origin)
Last edited by BillZM on Fri, 23 Feb 2018, 05:39, edited 1 time in total.

User avatar
Sajadi
Keeps coming back
Keeps coming back
Posts: 868
Joined: Fri, 19 Apr 2013, 00:46

Re: Amazon streaming

Postby Sajadi » Sat, 24 Feb 2018, 00:35

That 2 videos work both with flash and out of the box - with a Firefox/57 general useragent override without changing further settings beside activating MSE+MP4

harktu
Moongazer
Moongazer
Posts: 9
Joined: Wed, 14 Feb 2018, 12:18

Re: Amazon streaming

Postby harktu » Mon, 26 Feb 2018, 03:15

(previous content deleted, my misunderstood)
so the issue is whenever "media.autoplay.enabled false" vk videos are not working too, but when true they'r working.
https://vk.com/videos473232366
Last edited by harktu on Mon, 26 Feb 2018, 08:32, edited 5 times in total.

coffeebreak
Board Warrior
Board Warrior
Posts: 1185
Joined: Sat, 26 Sep 2015, 04:51
Location: U.S.

Re: Amazon streaming

Postby coffeebreak » Mon, 26 Feb 2018, 09:39

harktu wrote:so the issue is whenever "media.autoplay.enabled false" vk videos are not working too, but when true they'r working.
https://vk.com/videos473232366

The videos on that page play fine for me whether autoplay is enabled or not.

I don't have a VK account, so wasn't logged in. Don't know if that would make a difference.
(basilisk-2018.02.14, Win 7 x86)

harktu
Moongazer
Moongazer
Posts: 9
Joined: Wed, 14 Feb 2018, 12:18

Re: Amazon streaming

Postby harktu » Mon, 26 Feb 2018, 14:58

got it. when the setting is false, it shows loading cycle only, i need to click a point on player bar to start the video.


i understood 1 more point. when i set "history=never remember" browser blocks some content.
e.g.
https://www.primevideo.com/ref=atv_dp_p ... ay=trailer
https://www.asus.com/Laptops/X751LB/HelpDesk_Download/

coffeebreak
Board Warrior
Board Warrior
Posts: 1185
Joined: Sat, 26 Sep 2015, 04:51
Location: U.S.

Re: Amazon streaming

Postby coffeebreak » Tue, 27 Feb 2018, 07:36

harktu wrote:when i set "history=never remember" browser blocks some content.

That would be caused by the browser's built-in Tracking Protection.
(Read more here and here.)

The Asus page displayed fine here once Tracking Protection was disabled for the site.
(no amazon prime account here, so didn't try that.)

When Basilisk is set globally to "Never remember history", it puts the browser into permanent private browsing mode - It causes every window to be a private window.

Since the browser uses Tracking Protection in private windows by default, when "Never remember history" is in use Tracking Protection is potentially always active, unless it's been deliberately turned off.

It can be turned off entirely at Preferences > Privacy.

Or turned off per site (a shield displays in the identity panel in the urlbar if Tracking Protection is active).
Click the identity panel to bring up the option to turn it off.
asus-basilisk-trackingProtection.png

harktu
Moongazer
Moongazer
Posts: 9
Joined: Wed, 14 Feb 2018, 12:18

Re: Amazon streaming

Postby harktu » Tue, 27 Feb 2018, 22:53

tnx disabling tracking protection worked for asus but for primevideo its little bit strange,
disabling tracking in private window did the thing. but in normal window disabled or enabled not makes difference. content still blocked.
Last edited by harktu on Tue, 27 Feb 2018, 23:03, edited 1 time in total.

coffeebreak
Board Warrior
Board Warrior
Posts: 1185
Joined: Sat, 26 Sep 2015, 04:51
Location: U.S.

Re: Amazon streaming

Postby coffeebreak » Tue, 27 Feb 2018, 23:21

harktu wrote:...but for primevideo its little bit strange,
disabling tracking in private window did the thing. but in normal window disabled or enabled not makes difference. content still blocked.

Just guessing, since I can't try amazon prime...
Do you have any ad/script/content blocker(s) installed? If so, try disabling them.

You might also try clearing cache, and Amazon's cookies.


Return to “Basilisk”

Who is online

Users browsing this forum: loxodont and 5 guests