Basilisk updated Topic is solved

Forum for discussions around the Basilisk web browser.

Moderator: satrow

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 21708
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Basilisk updated

Unread postby Moonchild » Fri, 29 Dec 2017, 02:46

Basilisk has just been updated to 2017-12-28 which is an intermediate update i wanted to publish to get at least the Mozilla interference with the browser under control.
If you've previously tinkered with the blocklist settings etc. please revert preferences to their defaults.

Release notes: https://www.basilisk-browser.org/releasenotes.shtml
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

dodona
Apollo supporter
Apollo supporter
Posts: 33
Joined: Mon, 18 Dec 2017, 08:50

Re: Basilisk updated

Unread postby dodona » Fri, 29 Dec 2017, 08:18

unfortunately the patch let our "settings service" still making problems. There is something wrong with basilisk, as meanwhile I reactivated firefox 56 which has no blocklist settings at all.

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 21708
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Basilisk updated

Unread postby Moonchild » Fri, 29 Dec 2017, 09:20

Did you reset all preferences to their defaults?
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 21708
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Basilisk updated

Unread postby Moonchild » Fri, 29 Dec 2017, 10:13

If you're still having issues, try clearing the url from preference "services.settings.server". Disabling the extension blocklist altogether as recommended by some is not smart because it also has entries in there to prevent certain features on specific graphics drivers/hardware which are known to be problematic.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
Isengrim
Lunatic
Lunatic
Posts: 351
Joined: Tue, 08 Sep 2015, 22:54
Location: 127.0.0.1
Contact:

Re: Basilisk updated

Unread postby Isengrim » Fri, 29 Dec 2017, 15:46

Just updated to the latest version, and I am still seeing the warnings appear for installed add-ons. I tried "refreshing" the profile, which if I'm not mistaken includes resetting all about:config preferences to their defaults. Also tried clearing the URL from services.settings.server as mentioned.

That being said, while the warnings are still appearing, the browser is no longer automatically disabling add-ons with the blocklist enabled, so that is an improvement. Thank you for the update!
Linux Mint 18.3 Cinnamon (64-bit)
Windows 7 (64-bit) (Sometimes)
Windows 10 (64-bit) (Sometimes)

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 21708
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Basilisk updated

Unread postby Moonchild » Fri, 29 Dec 2017, 20:54

Apparently, the warnings can be cleared by disabling and re-enabling the extensions affected.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

dodona
Apollo supporter
Apollo supporter
Posts: 33
Joined: Mon, 18 Dec 2017, 08:50

Re: Basilisk updated

Unread postby dodona » Fri, 29 Dec 2017, 22:35

some 6 hours ago I followed your advice and I did a reset to all the blocklist options and immediately after starting/restarting b I set extensions.blocklist.enabled to false. Since then no problems anymore. Thanks! :thumbup:

Anyhow I wonder that entering blocklist as search key in about:config of firefox56 results in a result set 0, null, zerso, njada. Apparently blocklist is a basilisk feature. :crazy:
Last edited by dodona on Fri, 29 Dec 2017, 22:36, edited 1 time in total.

User avatar
New Tobin Paradigm
Knows the dark side
Knows the dark side
Posts: 4436
Joined: Tue, 09 Oct 2012, 19:37

Re: Basilisk updated

Unread postby New Tobin Paradigm » Fri, 29 Dec 2017, 22:57

Why did you disable the blocklist again...

Image

User avatar
Moonchild
Pale Moon guru
Pale Moon guru
Posts: 21708
Joined: Sun, 28 Aug 2011, 17:27
Location: 58.5°N 15.5°E
Contact:

Re: Basilisk updated

Unread postby Moonchild » Sat, 30 Dec 2017, 02:39

New Tobin Paradigm wrote:Why did you disable the blocklist again...

Because following simple instructions is hard, apparently.
Improving Mozilla code: You know you're on the right track with code changes when you spend the majority of your time deleting code.

"If you want to build a better world for yourself, you have to be willing to build one for everybody." -- Coyote Osborne

User avatar
helloimustbegoing
Board Warrior
Board Warrior
Posts: 1835
Joined: Thu, 28 Jun 2012, 01:20

Re: Basilisk updated

Unread postby helloimustbegoing » Sat, 30 Dec 2017, 02:59

Moonchild wrote:
Apparently, the warnings can be cleared by disabling and re-enabling the extensions affected.

Moonchild wrote:
If you're still having issues, try clearing the url from preference "services.settings.server".

Neither of these worked for me. Anything else left to try?
Last edited by helloimustbegoing on Sat, 30 Dec 2017, 03:07, edited 3 times in total.

User avatar
gracious1
Keeps coming back
Keeps coming back
Posts: 823
Joined: Sun, 15 May 2016, 05:00
Location: muggy, muggy upstate NY
Contact:

Re: Basilisk updated

Unread postby gracious1 » Sat, 30 Dec 2017, 03:30

Moonchild wrote:Apparently, the warnings can be cleared by disabling and re-enabling the extensions affected.

My experience with Basilisk on Ubuntu, however, has been that that doesn't work.
In fact, I just tried it on the latest version. The warnings did not go away; or in some cases, they went away temporarily, but came back
In the case of Themes Menu, Add-ons Manager wouldn't let me enable; there was only a remove button.

I also want to report that on my default profile I had selected the option to "Check for updates, but let you choose whether to install them"; however Basilisk updated itself without any action on my part, so it seems that this setting doesn't quite work.

This was updating to v. 2017.12.28 from 2017.12.03 on Ubuntu 14.04.
Last edited by gracious1 on Sat, 30 Dec 2017, 03:43, edited 6 times in total.
Image“Life is what happens to us while we are making other plans.” ― Allen Saunders

User avatar
gracious1
Keeps coming back
Keeps coming back
Posts: 823
Joined: Sun, 15 May 2016, 05:00
Location: muggy, muggy upstate NY
Contact:

Re: Basilisk updated

Unread postby gracious1 » Sat, 30 Dec 2017, 04:51

My steps for the Extensions issues in Basilisk 2017.12.28 (64-bit) on Ubuntu 14.04

  1. In Terminal, enter

    Code: Select all

    basilisk -P --no-remote
  2. In Profile Manager, create new profile (and use it)
  3. Go to about:config and clear value of services.setting.server
  4. Install these add-ons from AMO or github, restarting when prompted:
    • CookieKeeper
    • Decentraleyes 1.3.8
    • Extension Options Menu
    • Privacy Badger
    • Restart Manager
    • QuickNote
    • uBlock Origin 1.14.22
  5. Go to about:addons (Add-ons Manager) and observe:
    Basilisk addons warnings persist 01.png
  6. Now disable everything and observe:
    Basilisk addons warnings persist 02.png
  7. Now restart Basilisk; observe:
    Basilisk addons messed up 03.png

    Note the following:
    • Decentraleyes & Extension Options Menu re-enabled themselves somehow and appear normal
    • CookieKeeper remains disabled and has a warning
    • Restart Manager & uBlock Origin re-enabled themselves somehow, and also show the warning
    • QuickNote remains diabled; and its "Enable" button has disappeared, leaving only "Remove; and it has the warning.
  8. Go back to about:config and set extensions.blocklist.enabled to false
  9. Return to about:addons, and all the warning are gone, except for uBlock Origin thus:
    Basilisk addons messed up 04.png
  10. Now restart browser; Add-ons Manager unchanged from previous step.
  11. Now disable and re-enable uBlock Origin; no change.
  12. Now remove uBlock Origin and re-install from Github; no change.

FIN
Image“Life is what happens to us while we are making other plans.” ― Allen Saunders

User avatar
Terryphi
Fanatic
Fanatic
Posts: 161
Joined: Wed, 26 Aug 2015, 06:32
Location: Wales, UK

Re: Basilisk updated

Unread postby Terryphi » Sat, 30 Dec 2017, 07:15

gracious1,
"Check for updates, but let you choose whether to install them" works for me as expected on Linux Mint.
Linux Mint 19.0 64bit MATE. Latest builds of Pale Moon and Basilisk.

User avatar
Terryphi
Fanatic
Fanatic
Posts: 161
Joined: Wed, 26 Aug 2015, 06:32
Location: Wales, UK

Re: Basilisk updated

Unread postby Terryphi » Sat, 30 Dec 2017, 07:30

gracious1,
Screenshot after disabling and then enabling UBO.
Image
Linux Mint 19.0 64bit MATE. Latest builds of Pale Moon and Basilisk.

dodona
Apollo supporter
Apollo supporter
Posts: 33
Joined: Mon, 18 Dec 2017, 08:50

Re: Basilisk updated

Unread postby dodona » Sat, 30 Dec 2017, 09:18

New Tobin Paradigm wrote:Why did you disable the blocklist again...

otherwise the mess starts again.
Now we have a second signature problem too:

Image

read more on the issuehttps://support.mozilla.org/en-US/kb/add-on-signing-in-firefox?as=u&utm_source=inproduct

Again I mention that none of the both problems happens running firefox56 with the same profile, extensions, ... :?:

coffeebreak
Board Warrior
Board Warrior
Posts: 1284
Joined: Sat, 26 Sep 2015, 04:51
Location: U.S.

Re: Basilisk updated

Unread postby coffeebreak » Sat, 30 Dec 2017, 11:18

dodona wrote:Now we have a second signature problem too...

For the second problem...
Since it's related to add-on signing, does it help if you flip the following setting in about:config to false?

Code: Select all

services.blocklist.signing.enforced


dodona wrote:Again I mention that none of the both problems happens running firefox56 with the same profile, extensions,...

1) Did you copy over your Firefox (or Pale Moon) profile to use in Basilisk?
2) What is your operating system?

If you are on Windows and did copy your profile from another browser, try using a fresh profile (from scratch) - it should get rid of the warnings.

dodona
Apollo supporter
Apollo supporter
Posts: 33
Joined: Mon, 18 Dec 2017, 08:50

Re: Basilisk updated

Unread postby dodona » Mon, 01 Jan 2018, 18:37

coffeebreak wrote:
dodona wrote:Now we have a second signature problem too...

For the second problem...
Since it's related to add-on signing, does it help if you flip the following setting in about:config to false?

Code: Select all

services.blocklist.signing.enforced

it isn't that simple. Setting ...signing.enforced has no effect. Gues it works only in fifefox nightly builds and so on.

dodona wrote:Again I mention that none of the both problems happens running firefox56 with the same profile, extensions,...

coffeebreak wrote:
dodona wrote:2) What is your operating system?

If you are on Windows and did copy your profile from another browser, try using a fresh profile (from scratch) - it should get rid of the warnings.

Linux.

dodona
Apollo supporter
Apollo supporter
Posts: 33
Joined: Mon, 18 Dec 2017, 08:50

Re: Basilisk updated

Unread postby dodona » Mon, 01 Jan 2018, 18:38

dodona wrote:
coffeebreak wrote:
dodona wrote:Now we have a second signature problem too...

For the second problem...
Since it's related to add-on signing, does it help if you flip the following setting in about:config to false?

Code: Select all

services.blocklist.signing.enforced

it isn't that simple. Setting ...signing.enforced has no effect. Guess it works only in fifefox nightly builds and so on.

coffeebreak wrote:
dodona wrote:2) What is your operating system?

Linux.

dodona
Apollo supporter
Apollo supporter
Posts: 33
Joined: Mon, 18 Dec 2017, 08:50

Re: Basilisk updated

Unread postby dodona » Mon, 01 Jan 2018, 18:39

coffeebreak wrote:
dodona wrote:Now we have a second signature problem too...

For the second problem...
Since it's related to add-on signing, does it help if you flip the following setting in about:config to false?

Code: Select all

services.blocklist.signing.enforced

it isn't that simple. Setting ...signing.enforced has no effect. Guess it works only in fifefox nightly builds and so on.

coffeebreak wrote:
dodona wrote:2) What is your operating system?

Linux.[

dodona
Apollo supporter
Apollo supporter
Posts: 33
Joined: Mon, 18 Dec 2017, 08:50

Re: Basilisk updated

Unread postby dodona » Mon, 01 Jan 2018, 18:45

interesting observation.
Today from 8-18h (Central European Time), what is new years night in US, the whole blocklist.setting mess disappeared.
Then at ~ 19h a restart and immediately blocklist disabled all extensions.

It looks like a tcp communication to a blocklist service, which restarted the mess again, after it slept new years night.

BTW. conversion of web pages to the print mode don't work at all:
Failed to load article from page


Return to “Basilisk”

Who is online

Users browsing this forum: ltcomdata and 2 guests