Why I Can't Install Some Addons

Board for discussions around the Basilisk web browser.

Moderator: satrow

Locked
Walpurgisnacht
Moongazer
Moongazer
Posts: 7
Joined: 2017-12-05, 14:45

Why I Can't Install Some Addons

Post by Walpurgisnacht » 2017-12-05, 15:04

I can't install some legacy Firefox addons like this: https://addons.mozilla.org/it/firefox/a ... p-blocker/

I can install that addon on Firefox version 48+, Waterfox, but on Basilisk I get this error:
Attachments
Snap8b.jpg
Snap8b.jpg (24.6 KiB) Viewed 1848 times

GMforker
Astronaut
Astronaut
Posts: 537
Joined: 2015-08-27, 06:29
Location: Czech Republic

Re: Why I Can't Install Some Addons

Post by GMforker » 2017-12-05, 21:46

Walpurgisnacht wrote:I can't install some legacy Firefox addons like this: https://addons.mozilla.org/it/firefox/a ... p-blocker/

I can install that addon on Firefox version 48+, Waterfox, but on Basilisk I get this error:
After adding the following lines (to "manifest.json"):

Code: Select all

"applications": {
  "gecko": {
    "id": "addon@example.com"
  }
}
the problem was solved.

AFAIK: The default values (because optional=true) are wrong (I cannot look for it now)...

Walpurgisnacht
Moongazer
Moongazer
Posts: 7
Joined: 2017-12-05, 14:45

Re: Why I Can't Install Some Addons

Post by Walpurgisnacht » 2017-12-06, 10:34

GMforker wrote:
Walpurgisnacht wrote:I can't install some legacy Firefox addons like this: https://addons.mozilla.org/it/firefox/a ... p-blocker/

I can install that addon on Firefox version 48+, Waterfox, but on Basilisk I get this error:
After adding the following lines (to "manifest.json"):

Code: Select all

"applications": {
  "gecko": {
    "id": "addon@example.com"
  }
}
the problem was solved.

AFAIK: The default values (because optional=true) are wrong (I cannot look for it now)...

I've added those lines to "manifest.json", but I still get the same error... :|

GMforker
Astronaut
Astronaut
Posts: 537
Joined: 2015-08-27, 06:29
Location: Czech Republic

Re: Why I Can't Install Some Addons

Post by GMforker » 2017-12-06, 11:23

Do you have a valid JSON file?

False:

Code: Select all

  "short_name": "Poper Blocker"
  "applications": {
    "gecko": {
      "id": "addon@example.com"
    }
  }
True:

Code: Select all

  "short_name": "Poper Blocker",
  "applications": {
    "gecko": {
      "id": "addon@example.com"
    }
  }
This works for me.

Walpurgisnacht
Moongazer
Moongazer
Posts: 7
Joined: 2017-12-05, 14:45

Re: Why I Can't Install Some Addons

Post by Walpurgisnacht » 2017-12-06, 14:08

GMforker wrote:Do you have a valid JSON file?

False:

Code: Select all

  "short_name": "Poper Blocker"
  "applications": {
    "gecko": {
      "id": "addon@example.com"
    }
  }
True:

Code: Select all

  "short_name": "Poper Blocker",
  "applications": {
    "gecko": {
      "id": "addon@example.com"
    }
  }
This works for me.
I'm still getting the same error: will you upload the valid .json file, please? :crazy:

Thanks!

coffeebreak
Board Warrior
Board Warrior
Posts: 1960
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Why I Can't Install Some Addons

Post by coffeebreak » 2017-12-06, 15:58

Walpurgisnacht wrote:I'm still getting the same error

The edit worked here: the extension installed with no problem.
Use the code box designated "True:". The first line in that code box is actually already present at the bottom of the page (line 66) - Either overwrite it or add a 'comma'

Before and after pictures. Note Line 66 (and following)...
before editing.
poperblocker-before-edit.png
after editing.
poperblocker-edited.png

Walpurgisnacht
Moongazer
Moongazer
Posts: 7
Joined: 2017-12-05, 14:45

Re: Why I Can't Install Some Addons

Post by Walpurgisnacht » 2017-12-06, 16:31

coffeebreak wrote:
Walpurgisnacht wrote:I'm still getting the same error

The edit worked here: the extension installed with no problem.
Use the code box designated "True:". The first line in that code box is actually already present at the bottom of the page (line 66) - Either overwrite it or add a 'comma'

Before and after pictures. Note Line 66 (and following)...
before editing.
poperblocker-before-edit.png
after editing.
poperblocker-edited.png
I've just done that but I still get this error:

so please upload your edited "poper" addon file,
or at least your edite"manifest.json" file,
'cause I don't understand where I go wrong with it... :?
Attachments
Snap1.jpg
Snap1.jpg (18.02 KiB) Viewed 1656 times

dark_moon

Re: Why I Can't Install Some Addons

Post by dark_moon » 2017-12-07, 19:53

Just a simple question: did you rebuild the addon with the modified file? Else nothing happens

Walpurgisnacht
Moongazer
Moongazer
Posts: 7
Joined: 2017-12-05, 14:45

Re: Why I Can't Install Some Addons

Post by Walpurgisnacht » 2017-12-08, 10:57

dark_moon wrote:Just a simple question: did you rebuild the addon with the modified file? Else nothing happens
I've "unzipped" that addon, using winrar and edited "manifest.json", just like they've written above.
And then I've rebuilt the addon with the edited "manifest.json" file, but nothing has changed: I'm still getting the same error.

Why don't you upload the modified addon or, at least, a valid edited "manifest.json" file?

I really don't understand where I go wrong... :roll:

Thanks!

coffeebreak
Board Warrior
Board Warrior
Posts: 1960
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Why I Can't Install Some Addons

Post by coffeebreak » 2017-12-08, 12:00

Walpurgisnacht wrote:I really don't understand where I go wrong...

When you rebuilt, did you zip up the folder that contained the manifest.json and other files? (NOT correct).
Or just the files? (correct).
Because those files need to be in the root directory of the xpi (if they were there originally, before editing).

Walpurgisnacht
Moongazer
Moongazer
Posts: 7
Joined: 2017-12-05, 14:45

Re: Why I Can't Install Some Addons

Post by Walpurgisnacht » 2017-12-08, 14:00

coffeebreak wrote:
Walpurgisnacht wrote:I really don't understand where I go wrong...

When you rebuilt, did you zip up the folder that contained the manifest.json and other files? (NOT correct).
Or just the files? (correct).
Because those files need to be in the root directory of the xpi (if they were there originally, before editing).
Just the file.
My rebuilt addon and the orginal one are the same, except for "manifest.json" files contained.

So I really don't know what to do to make it compatible with Basilisk.

User avatar
gracious1
Keeps coming back
Keeps coming back
Posts: 876
Joined: 2016-05-15, 05:00
Location: humid upstate NY

Re: Why I Can't Install Some Addons

Post by gracious1 » 2017-12-08, 14:15

GMforker wrote:Do you have a valid JSON file?

False:

Code: Select all

  "short_name": "Poper Blocker"
  "applications": {
    "gecko": {
      "id": "addon@example.com"
    }
  }
True:

Code: Select all

  "short_name": "Poper Blocker",
  "applications": {
    "gecko": {
      "id": "addon@example.com"
    }
  }
This works for me.
I don't really see any difference between these two??

Also, would it be possible just to upload the modified manifest.json file ?
20 July 1969 🌗 50th Anniversary of Apollo 11 🌓 "One small step for [a] man, one giant leap for mankind." 🚀

coffeebreak
Board Warrior
Board Warrior
Posts: 1960
Joined: 2015-09-26, 04:51
Location: U.S.

Re: Why I Can't Install Some Addons

Post by coffeebreak » 2017-12-08, 16:10

gracious1 wrote:I don't really see any difference between these two??

The 'comma':
the-difference.png
the-difference.png (42.63 KiB) Viewed 1425 times

Walpurgisnacht
Moongazer
Moongazer
Posts: 7
Joined: 2017-12-05, 14:45

Re: Why I Can't Install Some Addons

Post by Walpurgisnacht » 2017-12-08, 16:20

coffeebreak wrote:
gracious1 wrote:I don't really see any difference between these two??

The 'comma':
the-difference.png

Thank you very much coffeebreak!

Hitchhiker
Apollo supporter
Apollo supporter
Posts: 32
Joined: 2017-12-10, 11:06
Location: The Netherlands

Re: Why I Can't Install Some Addons

Post by Hitchhiker » 2017-12-13, 16:48

Some advice please folks.

I have the same problem as the OP albeit with a different extension which is this one.

There's no manifest.json in the root of my profile so I created one using Notepad with the following code:

Code: Select all

  "short_name": "Anti-Paywall",
  "applications": {
    "gecko": {
      "id": "addon@https://addons.mozilla.org/en-US/firefox/addon/anti-paywall/"
    }
  }
I tried without the https:// as well, but it doesn't make any difference.

There is manifest.json file present in the gmp-widevinecdm\1.4.8.903 directory but that appears to be related to the Google Widevine Decryption module judging by its name so I assume that's not the one I want.

GMforker
Astronaut
Astronaut
Posts: 537
Joined: 2015-08-27, 06:29
Location: Czech Republic

Re: Why I Can't Install Some Addons

Post by GMforker » 2017-12-13, 21:29


Hitchhiker
Apollo supporter
Apollo supporter
Posts: 32
Joined: 2017-12-10, 11:06
Location: The Netherlands

Re: Why I Can't Install Some Addons

Post by Hitchhiker » 2017-12-14, 12:52

GMforker wrote:See also issue #238 (moebius).
I think I'll have to shelve that extension until a later date. It's supposed to be compatible with FF48+, but the first release didn't become available until November 25 this year. That in turn seems to indicate that it's a WebExtension rather than legacy.

The developer also stated on issue #7 that it's not compatible with Basilisk which more or less confirms it as a WebExtension I think.

Thanks for the response anyway.

Locked